]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
Rel 1; obsolete patches dropped
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_without  lmdb            # LMDB storage support for addzone zones
10 %bcond_with     static_libs     # static libraries
11 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
12 %bcond_with     tests           # unit tests
13 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
14 %bcond_with     hip             # HIP RR support
15
16 %if "%{pld_release}" == "ac"
17 %bcond_with     epoll           # enable epoll support
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll           # disable epoll support
24 %endif
25
26 %define         ver     9.18.0
27 %if 0
28 %define         pverdot .P0
29 %define         pverdir -P0
30 %else
31 %define         pverdot %{nil}
32 %define         pverdir %{nil}
33 %endif
34 Summary:        BIND - DNS name server
35 Summary(de.UTF-8):      BIND - DNS-Namenserver
36 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
37 Summary(fr.UTF-8):      BIND - serveur de noms DNS
38 Summary(pl.UTF-8):      BIND - serwer nazw DNS
39 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
40 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
41 Summary(tr.UTF-8):      DNS alan adı sunucusu
42 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
43 Summary(zh_CN.UTF-8):   Internet 域名服务器
44 Name:           bind
45 Version:        %{ver}%{pverdot}
46 Release:        1
47 Epoch:          7
48 License:        MPL 2.0
49 Group:          Networking/Daemons
50 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
51 # Source0-md5:  0e6fe85e3f2d252f5cec9cb98e82bc15
52 Source1:        named.init
53 Source2:        named.sysconfig
54 Source3:        named.logrotate
55 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
57 # formerly http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt (dead URL now)
58 Source5:        dnszone-schema.txt
59 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
60 Source6:        %{name}-hip.tar.gz
61 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
62 Source7:        https://www.internic.net/domain/named.root
63 # Source7-md5:  e7b0c887f185b606e0afeb2a5512de90
64 Source8:        %{name}-127.0.0.zone
65 Source9:        %{name}-localhost.zone
66 Source10:       %{name}-named.conf
67 Source11:       %{name}.tmpfiles
68 Source12:       named.service
69
70 Patch4:         %{name}-ac-libs.patch
71 Patch5:         %{name}-edns-client-subnet.patch
72 URL:            https://www.isc.org/software/bind
73 BuildRequires:  autoconf >= 2.60
74 BuildRequires:  automake
75 BuildRequires:  bison
76 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
77 BuildRequires:  flex
78 %{?with_kerberos5:BuildRequires:        heimdal-devel}
79 BuildRequires:  json-c-devel >= 0.11
80 BuildRequires:  libatomic-devel
81 BuildRequires:  libcap-devel
82 BuildRequires:  libidn2-devel
83 # note, there is no kyua in PLD yet (work in progress)
84 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
85 BuildRequires:  libtool
86 BuildRequires:  libuv-devel >= 1.37.0
87 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
88 BuildRequires:  libxml2-devel >= 1:2.6.0
89 %{?with_lmdb:BuildRequires:     lmdb-devel}
90 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
91 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
92 BuildRequires:  pkgconfig
93 BuildRequires:  python3-devel >= 1:3.2
94 BuildRequires:  python3-sphinx_rtd_theme
95 BuildRequires:  readline-devel
96 BuildRequires:  rpm >= 4.4.9-56
97 BuildRequires:  rpmbuild(macros) >= 1.647
98 BuildRequires:  sphinx-pdg
99 BuildRequires:  zlib-devel
100 %if %{with dnstap}
101 BuildRequires:  fstrm-devel
102 BuildRequires:  protobuf-c-devel
103 %endif
104 Requires(post,preun):   /sbin/chkconfig
105 Requires(postun):       /usr/sbin/groupdel
106 Requires(postun):       /usr/sbin/userdel
107 Requires(pre):  /bin/id
108 Requires(pre):  /usr/bin/getgid
109 Requires(pre):  /usr/sbin/groupadd
110 Requires(pre):  /usr/sbin/useradd
111 Requires(pre):  fileutils
112 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
113 Requires:       psmisc >= 20.1
114 Requires:       rc-scripts >= 0.2.0
115 Requires:       systemd-units >= 38
116 Requires:       uname(release) >= 2.2.18
117 Provides:       group(named)
118 Provides:       nameserver
119 Provides:       user(named)
120 Obsoletes:      caching-nameserver
121 Conflicts:      %{name}-chroot
122 Conflicts:      logrotate < 3.8.0
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %description
126 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
127 (Domain Name System) protocols. BIND includes a DNS server (named),
128 which resolves host names to IP addresses, and a resolver library
129 (routines for applications to use when interfacing with DNS). A DNS
130 server allows clients to name resources or objects and share the
131 information with other network machines. The named DNS server can be
132 used on workstations as a caching name server, but is generally only
133 needed on one machine for an entire network. Note that the
134 configuration files for making BIND act as a simple caching nameserver
135 are included in the caching-nameserver package.
136
137 Install the bind package if you need a DNS server for your network. If
138 you want bind to act a caching name server, you will also need to
139 install the caching-nameserver package.
140
141 %description -l de.UTF-8
142 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
143 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
144 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
145 Recher des Netzwerks erforderlich.
146
147 %description -l es.UTF-8
148 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
149 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
150 un servidor de nombres caché, pero generalmente sólo hace falta en una
151 máquina para toda la red.
152
153 %description -l fr.UTF-8
154 Contient le serveur de noms named, utilisé pour définir les
155 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
156 utilisé sur les stations de travail comme serveur de nom en cache mais
157 n'est souvent nécessaire que sur une machine pour un réseau entier.
158
159 %description -l pl.UTF-8
160 Pakiet ten zawiera demona named, który służy do zmieniania nazw
161 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
162 roboczych jako bufor odwołań do serwisu nazw (caching name server),
163 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
164 program na fragment sieci.
165
166 %description -l pt_BR.UTF-8
167 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
168 IP (e vice-versa). Pode ser usado em estações de trabalho como um
169 servidor de nomes cache, mas geralmente só é necessário em uma máquina
170 para toda a rede.
171
172 %description -l ru.UTF-8
173 BIND (Berkeley Internet Name Domain) является реализацией протоколов
174 DNS (Domain Name System). BIND включает DNS сервер (named) и
175 библиотеку "резолвера" (подпрограммы для приложений, через которые
176 происходят обращения к DNS). DNS сервер named может быть использован
177 на рабочих станциях как кеширующий сервер, но обычно запускается на
178 одной машине в локальной сети и используется остальными машинами (этим
179 достигается намного более эффективное кеширование).
180
181 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
182 кеширующего сервера, включены в пакет caching-nameserver.
183
184 %description -l tr.UTF-8
185 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
186 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
187 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
188 için sadece bir makina üzerinde kurulur.
189
190 %description -l uk.UTF-8
191 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
192 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
193 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
194 сервер named може бути використаний на робочих станціях як кешируючий
195 сервер, але звичайно запускається на одній машині в локальній мережі і
196 використовується іншими (цим досягається більша ефективність
197 використання кешу).
198
199 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
200 кешируючого серверу, включені в пакет caching-nameserver.
201
202 %package utils
203 Summary:        DNS utils - host, dig, dnsquery, nslookup
204 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
205 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
206 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
207 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
208 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
209 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
210 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
211 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
212 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
213 Group:          Networking/Utilities
214 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
215 Requires:       iconv
216
217 %description utils
218 Bind-utils contains a collection of utilities for querying DNS (Domain
219 Name Service) name servers to find out information about Internet
220 hosts. These tools will provide you with the IP addresses for given
221 host names, as well as other information about registered domains and
222 network addresses.
223
224 You should install bind-utils if you need to get information from DNS
225 name servers.
226
227 %description utils -l de.UTF-8
228 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
229 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
230 Informationen über registrierte Domains und Netzwerk-Adressen.
231
232 %description utils -l es.UTF-8
233 Conjunto de utilitarios para consulta a servidores de nombres. Estas
234 herramientas permiten la determinación de direcciones IP para nombres
235 de máquinas informados y busca información sobre dominios registrados
236 y direcciones de red.
237
238 %description utils -l fr.UTF-8
239 Ensemble d'utilitaires pour interroger les serveurs de noms et
240 rechercher des hôtes. Ces outils vous permettent de déterminer les
241 adresses IP pour des noms d'hôtes donnés, et trouver des informations
242 sur les noms de domaine déclarés et les adresses réseau.
243
244 %description utils -l pl.UTF-8
245 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
246 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
247 i ich adresach IP.
248
249 %description utils -l pt_BR.UTF-8
250 Conjunto de utilitários para consulta a servidores DNS. Estas
251 ferramentas permitem a determinação de endereços IP para nomes de
252 máquinas informados e busca informações sobre domínios registrados e
253 endereços de rede. Você deveria instalar este pacote se necessitar
254 obter informações de servidores DNS.
255
256 %description utils -l ru.UTF-8
257 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
258 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
259 доменному имени (и наоборот) и другую информацию о зарегистрированных
260 доменах и сетевых адресах.
261
262 %description utils -l tr.UTF-8
263 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
264 için kullanılan araçlar bulunmaktadır.
265
266 %description utils -l uk.UTF-8
267 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
268 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
269 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
270 домени та адреси.
271
272 %package libs
273 Summary:        DNS libraries
274 Summary(pl.UTF-8):      Biblioteki DNS
275 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
276 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
277 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
278 Group:          Libraries
279 Requires:       json-c >= 0.11
280 Requires:       libuv >= 1.37.0
281 Requires:       libxml2 >= 1:2.6.0
282
283 %description libs
284 The bind-libs package contains all libraries required for running BIND
285 and bind utils.
286
287 %description libs -l pl.UTF-8
288 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
289 lub programów z pakietu bind-utils.
290
291 %description libs -l ru.UTF-8
292 Библиотеки, необходимые для работы bind.
293
294 %description libs -l uk.UTF-8
295 Бібліотеки, необхідні для роботи bind.
296
297 %package devel
298 Summary:        DNS development includes
299 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
300 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
301 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
302 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
303 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
304 Group:          Development/Libraries
305 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
306
307 %description devel
308 The bind-devel package contains all the include files and symlinks
309 required for DNS (Domain Name Service) development for BIND.
310
311 You should install bind-devel if you want to develop bind DNS
312 applications. If you install bind-devel, you'll also need to install
313 bind-libs.
314
315 %description devel -l es.UTF-8
316 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
317 para el bind.
318
319 %description devel -l pl.UTF-8
320 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
321 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
322 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
323 pakiet.
324
325 %description devel -l pt_BR.UTF-8
326 Todos os arquivos de cabeçalho e bibliotecas necessários para o
327 desenvolvimento com o bind.
328
329 %description devel -l ru.UTF-8
330 Все хедеры и библиотеки, необходимые для написания программ с
331 использованием BIND 9.x.x.
332
333 %description devel -l uk.UTF-8
334 Всі хедери та бібліотеки, необхідні для розробки програм з
335 використанням BIND 9.x.x.
336
337 %package static
338 Summary:        DNS static libs
339 Summary(pl.UTF-8):      Biblioteki statyczne DNS
340 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
341 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
342 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
343 Group:          Development/Libraries
344 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
345
346 %description static
347 Static bind libraries.
348
349 %description static -l pl.UTF-8
350 Statyczne biblioteki binda.
351
352 %description static -l pt_BR.UTF-8
353 Bibliotecas estáticas para desenvolvimento DNS.
354
355 %description static -l ru.UTF-8
356 Статические библиотеки, необходимые для написания программ с
357 использованием BIND.
358
359 %description static -l uk.UTF-8
360 Статичні бібліотеки, необхідні для розробки програм з використанням
361 BIND.
362
363 %prep
364 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
365
366 %patch4 -p1
367 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
368 %{?with_edns_cli:%patch5 -p0}
369
370 %build
371 %{__libtoolize}
372 %{__aclocal}
373 %{__autoconf}
374 %{__automake}
375 %configure \
376         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
377         LDFLAGS="%{rpmldflags}" \
378         %{?with_dnstap:--enable-dnstap} \
379         %{!?with_epoll:--disable-epoll --disable-devpoll} \
380         --enable-full-report \
381         --enable-largefile \
382         %{?with_static_libs:--enable-static} \
383         %{?with_kerberos5:--with-gssapi} \
384         --with-libidn2 \
385         --with-libxml2 \
386         %{?with_ssl:--with-openssl} \
387         %{?with_geoip:--with-maxminddb} \
388         --with-lmdb%{!?with_lmdb:=no} \
389         --with-tuning \
390         --disable-silent-rules
391
392 %{__make}
393 %{__make} -C doc/arm html
394
395 %{?with_hip:%{__make} -C bind-hip}
396
397 %if %{with tests}
398 %if %{with system_tests}
399 %{__make} test-force
400 %else
401 sh unit/unittest.sh
402 %endif
403 %endif
404
405 %install
406 rm -rf $RPM_BUILD_ROOT
407 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
408         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
409         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
410         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
411
412 %{__make} install \
413         DESTDIR=$RPM_BUILD_ROOT
414
415 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
416 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
417 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
418 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
419
420 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
421 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
422 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
423 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
424 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
425 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
426 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
427 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
428
429 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
430 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
431 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
432 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
433
434 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
435
436 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
437 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
438
439 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
440
441 # we don't want Makefiles in documentation...
442 rm -rf _doc
443 cp -a doc _doc
444 %{__rm} _doc/misc/Makefile*
445
446 %clean
447 rm -rf $RPM_BUILD_ROOT
448
449 %pre
450 if [ -f %{_sysconfdir}/named.boot ]; then
451         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
452         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
453         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
454 fi
455 %groupadd -g 58 named
456 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
457
458 %post
459 /sbin/chkconfig --add named
460 %service named restart
461 %systemd_post named.service
462
463 %preun
464 if [ "$1" = "0" ]; then
465         %service named stop
466         /sbin/chkconfig --del named
467 fi
468 %systemd_preun named.service
469
470 %postun
471 if [ "$1" = "0" ]; then
472         %userremove named
473         %groupremove named
474 fi
475 %systemd_reload
476
477 %post   libs -p /sbin/ldconfig
478 %postun libs -p /sbin/ldconfig
479
480 %triggerpostun -- %{name} < 7:9.9.2.P2-2
481 %systemd_trigger named.service
482
483 %files
484 %defattr(644,root,root,755)
485 %doc README.md %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
486 %doc _doc/misc/* _doc/arm/_build/html/*.html
487
488 %{systemdunitdir}/named.service
489 %attr(754,root,root) /etc/rc.d/init.d/named
490 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
491 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
492 %{_sysconfdir}/named.conf
493 %{_sysconfdir}/bind.keys
494
495 %attr(755,root,root) %{_bindir}/dnssec-*
496 %attr(755,root,root) %{_bindir}/named-*
497 %attr(755,root,root) %{_bindir}/nsec3hash
498 %attr(755,root,root) %{_sbindir}/ddns-confgen
499 %attr(755,root,root) %{_sbindir}/named
500 %attr(755,root,root) %{_sbindir}/rndc
501 %attr(755,root,root) %{_sbindir}/rndc-confgen
502 %attr(755,root,root) %{_sbindir}/tsig-keygen
503
504 %{_mandir}/man1/dnssec-*.1*
505 %{_mandir}/man1/named-*.1*
506 %{_mandir}/man1/nsec3hash.1*
507 %{_mandir}/man5/named.conf.5*
508 %{_mandir}/man5/rndc.conf.5*
509 %{_mandir}/man8/ddns-confgen.8*
510 %{_mandir}/man8/named.8*
511 %{_mandir}/man8/rndc.8*
512 %{_mandir}/man8/rndc-confgen.8*
513 %{_mandir}/man8/tsig-keygen.8*
514 %lang(ja) %{_mandir}/ja/man8/named*
515
516 %{systemdtmpfilesdir}/%{name}.conf
517
518 %attr(770,root,named) %dir %{_var}/lib/named
519 %attr(770,root,named) %dir %{_var}/lib/named/D
520 %attr(770,root,named) %dir %{_var}/lib/named/M
521 %attr(770,root,named) %dir %{_var}/lib/named/S
522 %attr(770,root,named) %dir %{_var}/lib/named/dev
523 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
524 %attr(750,root,named) %dir %{_var}/lib/named/etc
525 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
526 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
527 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
528 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
529 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
530 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
531
532 %config(noreplace,missingok) %{_var}/log/named
533 %config(noreplace,missingok) %{_var}/log/named.stats
534
535 %attr(770,root,named) %dir %{_var}/run/named
536
537 %dir %{_libdir}/bind
538 %attr(755,root,root) %{_libdir}/bind/filter-a.so
539 %attr(755,root,root) %{_libdir}/bind/filter-aaaa.so
540 %{_mandir}/man8/filter-a.8*
541 %{_mandir}/man8/filter-aaaa.8*
542
543 %files utils
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_bindir}/arpaname
546 %attr(755,root,root) %{_bindir}/delv
547 %attr(755,root,root) %{_bindir}/dig
548 %attr(755,root,root) %{_bindir}/host
549 %attr(755,root,root) %{_bindir}/named-rrchecker
550 %attr(755,root,root) %{_bindir}/mdig
551 %attr(755,root,root) %{_bindir}/nslookup
552 %attr(755,root,root) %{_bindir}/nsupdate
553 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
554 %{_mandir}/man1/arpaname.1*
555 %{_mandir}/man1/delv.1*
556 %{_mandir}/man1/dig.1*
557 %{_mandir}/man1/host.1*
558 %{_mandir}/man1/mdig.1*
559 %{_mandir}/man1/named-rrchecker.1*
560 %{_mandir}/man1/nslookup.1*
561 %{_mandir}/man1/nsupdate.1*
562
563 %lang(fi) %{_mandir}/fi/man1/host.1*
564
565 %lang(fr) %{_mandir}/fr/man1/host.1*
566
567 %lang(hu) %{_mandir}/hu/man1/host.1*
568
569 %lang(ja) %{_mandir}/ja/man1/dig.1*
570 %lang(ja) %{_mandir}/ja/man1/host.1*
571 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
572 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
573
574 %lang(pl) %{_mandir}/pl/man1/host.1*
575
576 %files libs
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
579 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
580 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
581 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
582 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
583 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
584 %attr(755,root,root) %{_libdir}/libns-%{version}.so
585
586 %files devel
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/libbind9.so
589 %attr(755,root,root) %{_libdir}/libdns.so
590 %attr(755,root,root) %{_libdir}/libirs.so
591 %attr(755,root,root) %{_libdir}/libisc.so
592 %attr(755,root,root) %{_libdir}/libisccc.so
593 %attr(755,root,root) %{_libdir}/libisccfg.so
594 %attr(755,root,root) %{_libdir}/libns.so
595 %{_libdir}/libbind9.la
596 %{_libdir}/libdns.la
597 %{_libdir}/libirs.la
598 %{_libdir}/libisc.la
599 %{_libdir}/libisccc.la
600 %{_libdir}/libisccfg.la
601 %{_libdir}/libns.la
602 %{_includedir}/bind9
603 %{_includedir}/dns
604 %{_includedir}/dst
605 %{_includedir}/irs
606 %{_includedir}/isc
607 %{_includedir}/isccc
608 %{_includedir}/isccfg
609 %{_includedir}/ns
610
611 %if %{with static_libs}
612 %files static
613 %defattr(644,root,root,755)
614 %{_libdir}/libbind9.a
615 %{_libdir}/libdns.a
616 %{_libdir}/libirs.a
617 %{_libdir}/libisc.a
618 %{_libdir}/libisccc.a
619 %{_libdir}/libisccfg.a
620 %{_libdir}/libns.a
621 %endif
622
623 %if %{with ldap}
624 %files -n openldap-schema-bind
625 %defattr(644,root,root,755)
626 %{_datadir}/openldap/schema/dnszone.schema
627 %endif
This page took 0.161793 seconds and 3 git commands to generate.