]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
43a40f8730273f58be7bec64d00c34711337bc4b
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with edns_cli            # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %if "%{pld_release}" == "ac"
15 %bcond_with             epoll           # enable epoll support
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll           # disable epoll support
22 %endif
23
24 %define         ver     9.8.1
25 %if 1
26 %define         pverdot .P1
27 %define         pverdir -P1
28 %else
29 %define         pverdot %{nil}
30 %define         pverdir %{nil}
31 %endif
32 Summary:        BIND - DNS name server
33 Summary(de.UTF-8):      BIND - DNS-Namenserver
34 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
35 Summary(fr.UTF-8):      BIND - serveur de noms DNS
36 Summary(pl.UTF-8):      BIND - serwer nazw DNS
37 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
38 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
39 Summary(tr.UTF-8):      DNS alan adı sunucusu
40 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
41 Summary(zh_CN.UTF-8):   Internet 域名服务器
42 Name:           bind
43 Version:        %{ver}%{pverdot}
44 Release:        4
45 Epoch:          7
46 License:        BSD-like
47 Group:          Networking/Daemons
48 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49 # Source0-md5:  afa41f8203d50bedad65071f9b6f96d7
50 Source1:        named.init
51 Source2:        named.sysconfig
52 Source3:        named.logrotate
53 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
55 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        ftp://rs.internic.net/domain/root.zone
60 # Source7-md5:  268175178a06a1588134bd8afe4b3685
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Source11:       %{name}.tmpfiles
65 Patch0:         %{name}-time.patch
66 Patch1:         %{name}-link.patch
67 Patch2:         %{name}-pmake.patch
68 Patch3:         %{name}-sdb-ldap.patch
69 Patch4:         %{name}-ac-libs.patch
70 Patch5:         %{name}-edns-client-subnet.patch
71 URL:            https://www.isc.org/software/bind
72 BuildRequires:  autoconf >= 2.59
73 BuildRequires:  automake
74 BuildRequires:  bison
75 BuildRequires:  flex
76 %{?with_kerberos5:BuildRequires:        heimdal-devel}
77 BuildRequires:  idnkit-devel
78 BuildRequires:  libtool
79 %{?with_hip:BuildRequires:      libxml2-devel}
80 %{?with_sql:BuildRequires:      mysql-devel}
81 %{?with_ldap:BuildRequires:     openldap-devel}
82 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
83 %{?with_sql:BuildRequires:      postgresql-devel}
84 BuildRequires:  rpm >= 4.4.9-56
85 BuildRequires:  rpmbuild(macros) >= 1.268
86 %{?with_sql:BuildRequires:      unixODBC-devel}
87 Requires(post,preun):   /sbin/chkconfig
88 Requires(postun):       /usr/sbin/groupdel
89 Requires(postun):       /usr/sbin/userdel
90 Requires(pre):  /bin/id
91 Requires(pre):  /usr/bin/getgid
92 Requires(pre):  /usr/sbin/groupadd
93 Requires(pre):  /usr/sbin/useradd
94 Requires(pre):  fileutils
95 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
96 Requires:       psmisc >= 20.1
97 Requires:       rc-scripts >= 0.2.0
98 Provides:       group(named)
99 Provides:       nameserver
100 Provides:       user(named)
101 Obsoletes:      caching-nameserver
102 Conflicts:      %{name}-chroot
103 Conflicts:      kernel < 2.2.18
104 Conflicts:  logrotate < 3.8.0
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         schemadir       /usr/share/openldap/schema
108
109 %description
110 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
111 (Domain Name System) protocols. BIND includes a DNS server (named),
112 which resolves host names to IP addresses, and a resolver library
113 (routines for applications to use when interfacing with DNS). A DNS
114 server allows clients to name resources or objects and share the
115 information with other network machines. The named DNS server can be
116 used on workstations as a caching name server, but is generally only
117 needed on one machine for an entire network. Note that the
118 configuration files for making BIND act as a simple caching nameserver
119 are included in the caching-nameserver package.
120
121 Install the bind package if you need a DNS server for your network. If
122 you want bind to act a caching name server, you will also need to
123 install the caching-nameserver package.
124
125 %description -l de.UTF-8
126 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
127 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
128 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
129 Recher des Netzwerks erforderlich.
130
131 %description -l es.UTF-8
132 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
133 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
134 un servidor de nombres caché, pero generalmente sólo hace falta en una
135 máquina para toda la red.
136
137 %description -l fr.UTF-8
138 Contient le serveur de noms named, utilisé pour définir les
139 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
140 utilisé sur les stations de travail comme serveur de nom en cache mais
141 n'est souvent nécessaire que sur une machine pour un réseau entier.
142
143 %description -l pl.UTF-8
144 Pakiet ten zawiera demona named, który służy do zmieniania nazw
145 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
146 roboczych jako bufor odwołań do serwisu nazw (caching name server),
147 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
148 program na fragment sieci.
149
150 %description -l pt_BR.UTF-8
151 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
152 IP (e vice-versa). Pode ser usado em estações de trabalho como um
153 servidor de nomes cache, mas geralmente só é necessário em uma máquina
154 para toda a rede.
155
156 %description -l ru.UTF-8
157 BIND (Berkeley Internet Name Domain) является реализацией протоколов
158 DNS (Domain Name System). BIND включает DNS сервер (named) и
159 библиотеку "резолвера" (подпрограммы для приложений, через которые
160 происходят обращения к DNS). DNS сервер named может быть использован
161 на рабочих станциях как кеширующий сервер, но обычно запускается на
162 одной машине в локальной сети и используется остальными машинами (этим
163 достигается намного более эффективное кеширование).
164
165 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
166 кеширующего сервера, включены в пакет caching-nameserver.
167
168 %description -l tr.UTF-8
169 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
170 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
171 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
172 için sadece bir makina üzerinde kurulur.
173
174 %description -l uk.UTF-8
175 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
176 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
177 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
178 сервер named може бути використаний на робочих станціях як кешируючий
179 сервер, але звичайно запускається на одній машині в локальній мережі і
180 використовується іншими (цим досягається більша ефективність
181 використання кешу).
182
183 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
184 кешируючого серверу, включені в пакет caching-nameserver.
185
186 %package utils
187 Summary:        DNS utils - host, dig, dnsquery, nslookup
188 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
189 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
190 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
191 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
192 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
193 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
194 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
195 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
196 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
197 Group:          Networking/Utilities
198 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
199 Requires:       iconv
200
201 %description utils
202 Bind-utils contains a collection of utilities for querying DNS (Domain
203 Name Service) name servers to find out information about Internet
204 hosts. These tools will provide you with the IP addresses for given
205 host names, as well as other information about registered domains and
206 network addresses.
207
208 You should install bind-utils if you need to get information from DNS
209 name servers.
210
211 %description utils -l de.UTF-8
212 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
213 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
214 Informationen über registrierte Domains und Netzwerk-Adressen.
215
216 %description utils -l es.UTF-8
217 Conjunto de utilitarios para consulta a servidores de nombres. Estas
218 herramientas permiten la determinación de direcciones IP para nombres
219 de máquinas informados y busca información sobre dominios registrados
220 y direcciones de red.
221
222 %description utils -l fr.UTF-8
223 Ensemble d'utilitaires pour interroger les serveurs de noms et
224 rechercher des hôtes. Ces outils vous permettent de déterminer les
225 adresses IP pour des noms d'hôtes donnés, et trouver des informations
226 sur les noms de domaine déclarés et les adresses réseau.
227
228 %description utils -l pl.UTF-8
229 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
230 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
231 i ich adresach IP.
232
233 %description utils -l pt_BR.UTF-8
234 Conjunto de utilitários para consulta a servidores DNS. Estas
235 ferramentas permitem a determinação de endereços IP para nomes de
236 máquinas informados e busca informações sobre domínios registrados e
237 endereços de rede. Você deveria instalar este pacote se necessitar
238 obter informações de servidores DNS.
239
240 %description utils -l ru.UTF-8
241 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
242 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
243 доменному имени (и наоборот) и другую информацию о зарегистрированных
244 доменах и сетевых адресах.
245
246 %description utils -l tr.UTF-8
247 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
248 için kullanılan araçlar bulunmaktadır.
249
250 %description utils -l uk.UTF-8
251 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
252 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
253 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
254 домени та адреси.
255
256 %package libs
257 Summary:        DNS libraries
258 Summary(pl.UTF-8):      Biblioteki DNS
259 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
260 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
261 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
262 Group:          Libraries
263
264 %description libs
265 The bind-libs package contains all libraries required for running BIND
266 and bind utils.
267
268 %description libs -l pl.UTF-8
269 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
270 lub programów z pakietu bind-utils.
271
272 %description libs -l ru.UTF-8
273 Библиотеки, необходимые для работы bind.
274
275 %description libs -l uk.UTF-8
276 Бібліотеки, необхідні для роботи bind.
277
278 %package devel
279 Summary:        DNS development includes
280 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
281 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
282 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
283 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
284 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
285 Group:          Development/Libraries
286 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
287
288 %description devel
289 The bind-devel package contains all the include files and symlinks
290 required for DNS (Domain Name Service) development for BIND.
291
292 You should install bind-devel if you want to develop bind DNS
293 applications. If you install bind-devel, you'll also need to install
294 bind-libs.
295
296 %description devel -l es.UTF-8
297 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
298 para el bind.
299
300 %description devel -l pl.UTF-8
301 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
302 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
303 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
304 pakiet.
305
306 %description devel -l pt_BR.UTF-8
307 Todos os arquivos de cabeçalho e bibliotecas necessários para o
308 desenvolvimento com o bind.
309
310 %description devel -l ru.UTF-8
311 Все хедеры и библиотеки, необходимые для написания программ с
312 использованием BIND 9.x.x.
313
314 %description devel -l uk.UTF-8
315 Всі хедери та бібліотеки, необхідні для розробки програм з
316 використанням BIND 9.x.x.
317
318 %package static
319 Summary:        DNS static libs
320 Summary(pl.UTF-8):      Biblioteki statyczne DNS
321 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
322 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
323 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
324 Group:          Development/Libraries
325 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
326
327 %description static
328 Static bind libraries.
329
330 %description static -l pl.UTF-8
331 Statyczne biblioteki binda.
332
333 %description static -l pt_BR.UTF-8
334 Bibliotecas estáticas para desenvolvimento DNS.
335
336 %description static -l ru.UTF-8
337 Статические библиотеки, необходимые для написания программ с
338 использованием BIND.
339
340 %description static -l uk.UTF-8
341 Статичні бібліотеки, необхідні для розробки програм з використанням
342 BIND.
343
344 %package -n openldap-schema-bind
345 Summary:        BIND schema for openldap
346 Summary(pl.UTF-8):      Schemat BIND dla openldap
347 Group:          Development/Libraries
348 Requires(post,postun):  sed >= 4.0
349 Requires:       openldap-servers
350 Requires:       sed >= 4.0
351
352 %description -n openldap-schema-bind
353 BIND schema for openldap.
354
355 %description -n openldap-schema-bind -l pl.UTF-8
356 Schemat BIND dla openldap.
357
358 %prep
359 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
360 %patch0 -p1
361 %patch1 -p1
362 %patch2 -p1
363 %{?with_ldap:%patch3 -p1}
364 %patch4 -p1
365 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
366
367 %{?with_edns_cli:%patch5 -p0}
368
369 %build
370 %{__libtoolize}
371 %{__aclocal}
372 %{__autoconf}
373 cp -f /usr/share/automake/config.* .
374 %configure \
375         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
376         --with-idn \
377         --with-libtool \
378         %{?with_ssl:--with-openssl} \
379         %{?with_ipv6:--enable-ipv6} \
380         %{?with_kerberos5:--with-gssapi} \
381         %{?with_sql:--with-dlz-postgres=yes} \
382         %{?with_sql:--with-dlz-mysql=yes} \
383         --with-dlz-bdb=no \
384         --with-dlz-filesystem=yes \
385         %{?with_ldap:--with-dlz-ldap=yes} \
386         --with-dlz-odbc=no \
387         --with-dlz-stub=yes \
388         --enable-largefile \
389         %{!?with_epoll:--disable-epoll --disable-devpoll} \
390         %{!?with_static_libs:--enable-static=no} \
391         --enable-threads \
392         --enable-getifaddrs
393
394 %{__make}
395 %{?with_hip:cd bind-hip/; %{__make}}
396
397 %{?with_tests:%{__make} test}
398
399 %install
400 rm -rf $RPM_BUILD_ROOT
401 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
402         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
403         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
404         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
405
406 %{__make} install \
407         DESTDIR=$RPM_BUILD_ROOT
408
409 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
410 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
411 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
412
413 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
414 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
415 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
416 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
417 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
418 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
419 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
420 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
421 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
422 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
423
424 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
425 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
426 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
427 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
428
429 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
430
431 install %{SOURCE11} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
432
433 %if %{with ldap}
434 install -d $RPM_BUILD_ROOT%{schemadir}
435 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
436 %endif
437
438 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
439
440 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
441 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
442
443 # let rpm generate deps (workaround -m644 used for libs installation)
444 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
445
446 # we don't want Makefiles in documentation...
447 rm -rf _doc
448 cp -a doc _doc
449 rm -f _doc/rfc/rfc*
450 rm -f _doc/misc/Makefile*
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %pre
456 if [ -f %{_sysconfdir}/named.boot ]; then
457         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
458         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
459         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
460 fi
461 %groupadd -g 58 named
462 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
463
464 %post
465 /sbin/chkconfig --add named
466 %service named restart
467
468 %preun
469 if [ "$1" = "0" ]; then
470         %service named stop
471         /sbin/chkconfig --del named
472 fi
473
474 %postun
475 if [ "$1" = "0" ]; then
476         %userremove named
477         %groupremove named
478 fi
479
480 %post   libs -p /sbin/ldconfig
481 %postun libs -p /sbin/ldconfig
482
483 %post -n openldap-schema-bind
484 %openldap_schema_register %{schemadir}/dnszone.schema
485 %service -q ldap restart
486
487 %postun -n openldap-schema-bind
488 if [ "$1" = "0" ]; then
489         %openldap_schema_unregister %{schemadir}/dnszone.schema
490         %service -q ldap restart
491 fi
492
493 %triggerpostun -- %{name} < 7:9.4.2-2
494 /sbin/chkconfig named reset
495 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
496 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
497 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
498
499 %files
500 %defattr(644,root,root,755)
501 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
502 %doc _doc/misc/* _doc/arm/*.html _doc/rfc/index %{?with_ldap:_doc/*.sdb-ldap}
503
504 %attr(754,root,root) /etc/rc.d/init.d/named
505 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
506 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
507 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
509
510 %attr(755,root,root) %{_sbindir}/arpaname
511 %attr(755,root,root) %{_sbindir}/ddns-confgen
512 %attr(755,root,root) %{_sbindir}/dnssec-*
513 %attr(755,root,root) %{_sbindir}/genrandom
514 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
515 %attr(755,root,root) %{_sbindir}/lwresd
516 %attr(755,root,root) %{_sbindir}/named
517 %attr(755,root,root) %{_sbindir}/named-*
518 %attr(755,root,root) %{_sbindir}/nsec3hash
519 %attr(755,root,root) %{_sbindir}/rndc
520 %attr(755,root,root) %{_sbindir}/rndc-confgen
521
522 %{_mandir}/man1/arpaname.1*
523 %{_mandir}/man5/named.conf.5*
524 %{_mandir}/man5/rndc.conf.5*
525 %{_mandir}/man8/ddns-confgen.8*
526 %{_mandir}/man8/dnssec-*.8*
527 %{_mandir}/man8/genrandom.8*
528 %{_mandir}/man8/isc-hmac-fixup.8*
529 %{_mandir}/man8/lwresd.8*
530 %{_mandir}/man8/named.8*
531 %{_mandir}/man8/named-*.8*
532 %{_mandir}/man8/nsec3hash.8*
533 %{_mandir}/man8/rndc.8*
534 %{_mandir}/man8/rndc-confgen.8*
535 %lang(ja) %{_mandir}/ja/man8/named*
536
537 /usr/lib/tmpfiles.d/%{name}.conf
538
539 %attr(770,root,named) %dir %{_var}/lib/named
540 %attr(770,root,named) %dir %{_var}/lib/named/D
541 %attr(750,root,named) %dir %{_var}/lib/named/M
542 %attr(770,root,named) %dir %{_var}/lib/named/S
543 %attr(750,root,named) %dir %{_var}/lib/named/etc
544 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
545 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
546 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
547 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
548 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
549 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
550
551 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
552 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
553
554 %attr(770,root,named) %dir %{_var}/run/named
555 %attr(770,root,named) %dir %{_var}/run/lwresd
556
557 %files utils
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_bindir}/dig
560 %attr(755,root,root) %{_bindir}/host
561 %attr(755,root,root) %{_bindir}/nslookup
562 %attr(755,root,root) %{_bindir}/nsupdate
563 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
564 %{_mandir}/man1/dig.1*
565 %{_mandir}/man1/host.1*
566 %{_mandir}/man1/nslookup.1*
567 %{_mandir}/man1/nsupdate.1*
568
569 %lang(fi) %{_mandir}/fi/man1/host.1*
570
571 %lang(fr) %{_mandir}/fr/man1/host.1*
572
573 %lang(hu) %{_mandir}/hu/man1/host.1*
574
575 %lang(ja) %{_mandir}/ja/man1/dig.1*
576 %lang(ja) %{_mandir}/ja/man1/host.1*
577 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
578 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
579
580 %lang(pl) %{_mandir}/pl/man1/host.1*
581
582 %files libs
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
586 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
587 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
588 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
590 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
591 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
592 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
594 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
595 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
596
597 %files devel
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_bindir}/isc-config.sh
600 %attr(755,root,root) %{_libdir}/libbind9.so
601 %attr(755,root,root) %{_libdir}/libdns.so
602 %attr(755,root,root) %{_libdir}/libisc.so
603 %attr(755,root,root) %{_libdir}/libisccc.so
604 %attr(755,root,root) %{_libdir}/libisccfg.so
605 %attr(755,root,root) %{_libdir}/liblwres.so
606 %{_libdir}/libbind9.la
607 %{_libdir}/libdns.la
608 %{_libdir}/libisc.la
609 %{_libdir}/libisccc.la
610 %{_libdir}/libisccfg.la
611 %{_libdir}/liblwres.la
612 %{_includedir}/bind9
613 %{_includedir}/dns
614 %{_includedir}/dst
615 %{_includedir}/isc
616 %{_includedir}/isccc
617 %{_includedir}/isccfg
618 %{_includedir}/lwres
619 %{_mandir}/man1/isc-config.sh.1*
620 %{_mandir}/man3/lwres*.3*
621
622 %if %{with static_libs}
623 %files static
624 %defattr(644,root,root,755)
625 %{_libdir}/libbind9.a
626 %{_libdir}/libdns.a
627 %{_libdir}/libisc.a
628 %{_libdir}/libisccc.a
629 %{_libdir}/libisccfg.a
630 %{_libdir}/liblwres.a
631 %endif
632
633 %if %{with ldap}
634 %files -n openldap-schema-bind
635 %defattr(644,root,root,755)
636 %{_datadir}/openldap/schema/dnszone.schema
637 %endif
This page took 0.107386 seconds and 2 git commands to generate.