]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- updated to 9.14.0
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  geoip           # GeoIP support
6 %bcond_without  ipv6            # IPv6 support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_with     ldap            # LDAP DLZ support
10 %bcond_with     odbc            # ODBC DLZ support
11 %bcond_without  sql             # SQL (MySQL+PostgreSQL) DLZ support
12 %bcond_without  lmdb            # LMDB storage support for addzone zones
13 %bcond_without  static_libs     # static libraries
14 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
15 %bcond_with     tests           # unit tests
16 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
17 %bcond_with     hip             # HIP RR support
18 %bcond_with     seccomp         # libseccomp system call filtering
19
20 %if "%{pld_release}" == "ac"
21 %bcond_with     epoll           # enable epoll support
22 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
23 %ifarch %{x8664}
24 %define         with_epoll      1
25 %endif
26 %else
27 %bcond_without  epoll           # disable epoll support
28 %endif
29
30 %define         ver     9.14.0
31 %if 0
32 %define         pverdot .P0
33 %define         pverdir -P0
34 %else
35 %define         pverdot %{nil}
36 %define         pverdir %{nil}
37 %endif
38 Summary:        BIND - DNS name server
39 Summary(de.UTF-8):      BIND - DNS-Namenserver
40 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
41 Summary(fr.UTF-8):      BIND - serveur de noms DNS
42 Summary(pl.UTF-8):      BIND - serwer nazw DNS
43 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
44 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
45 Summary(tr.UTF-8):      DNS alan adı sunucusu
46 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
47 Summary(zh_CN.UTF-8):   Internet 域名服务器
48 Name:           bind
49 Version:        %{ver}%{pverdot}
50 Release:        0.1
51 Epoch:          7
52 License:        MPL 2.0
53 Group:          Networking/Daemons
54 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
55 # Source0-md5:  11d14ca17919bbdd558663dcc69ca1fb
56 Source1:        named.init
57 Source2:        named.sysconfig
58 Source3:        named.logrotate
59 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
60 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
61 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
62 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
63 Source6:        %{name}-hip.tar.gz
64 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
65 Source7:        https://www.internic.net/domain/named.root
66 # Source7-md5:  60cbad328adbff5e9313fef5cd9a8d1d
67 Source8:        %{name}-127.0.0.zone
68 Source9:        %{name}-localhost.zone
69 Source10:       %{name}-named.conf
70 Source11:       %{name}.tmpfiles
71 Source12:       named.service
72 Patch0:         %{name}-time.patch
73 Patch1:         %{name}-link.patch
74 Patch2:         %{name}-pmake.patch
75 Patch3:         %{name}-sdb-ldap.patch
76 Patch4:         %{name}-ac-libs.patch
77 Patch5:         %{name}-edns-client-subnet.patch
78 Patch6:         nsupdate_segfault.patch
79 URL:            https://www.isc.org/software/bind
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  automake
82 BuildRequires:  bison
83 BuildRequires:  flex
84 %{?with_geoip:BuildRequires:    GeoIP-devel}
85 %{?with_kerberos5:BuildRequires:        heimdal-devel}
86 BuildRequires:  json-c-devel
87 BuildRequires:  libidn2-devel
88 # note, there is no kyua in PLD yet (work in progress)
89 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
90 %{?with_seccomp:BuildRequires:  libseccomp-devel}
91 BuildRequires:  libtool
92 %{?with_hip:BuildRequires:      libxml2-devel}
93 %{?with_lmdb:BuildRequires:     lmdb-devel}
94 %{?with_sql:BuildRequires:      mysql-devel}
95 %{?with_ldap:BuildRequires:     openldap-devel}
96 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
97 %{?with_sql:BuildRequires:      postgresql-devel}
98 BuildRequires:  python3-devel
99 BuildRequires:  python3-ply
100 BuildRequires:  readline-devel
101 BuildRequires:  rpm >= 4.4.9-56
102 BuildRequires:  rpmbuild(macros) >= 1.647
103 %{?with_odbc:BuildRequires:     unixODBC-devel}
104 BuildRequires:  zlib-devel
105 Requires(post,preun):   /sbin/chkconfig
106 Requires(postun):       /usr/sbin/groupdel
107 Requires(postun):       /usr/sbin/userdel
108 Requires(pre):  /bin/id
109 Requires(pre):  /usr/bin/getgid
110 Requires(pre):  /usr/sbin/groupadd
111 Requires(pre):  /usr/sbin/useradd
112 Requires(pre):  fileutils
113 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
114 # for dnssec-{checkds,coverage,keymgr}
115 Requires:       python3-isc = %{epoch}:%{version}-%{release}
116 Requires:       psmisc >= 20.1
117 Requires:       rc-scripts >= 0.2.0
118 Requires:       systemd-units >= 38
119 Requires:       uname(release) >= 2.2.18
120 Provides:       group(named)
121 Provides:       nameserver
122 Provides:       user(named)
123 Obsoletes:      caching-nameserver
124 Conflicts:      %{name}-chroot
125 Conflicts:      logrotate < 3.8.0
126 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
128 %define         schemadir       /usr/share/openldap/schema
129
130 %description
131 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
132 (Domain Name System) protocols. BIND includes a DNS server (named),
133 which resolves host names to IP addresses, and a resolver library
134 (routines for applications to use when interfacing with DNS). A DNS
135 server allows clients to name resources or objects and share the
136 information with other network machines. The named DNS server can be
137 used on workstations as a caching name server, but is generally only
138 needed on one machine for an entire network. Note that the
139 configuration files for making BIND act as a simple caching nameserver
140 are included in the caching-nameserver package.
141
142 Install the bind package if you need a DNS server for your network. If
143 you want bind to act a caching name server, you will also need to
144 install the caching-nameserver package.
145
146 %description -l de.UTF-8
147 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
148 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
149 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
150 Recher des Netzwerks erforderlich.
151
152 %description -l es.UTF-8
153 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
154 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
155 un servidor de nombres caché, pero generalmente sólo hace falta en una
156 máquina para toda la red.
157
158 %description -l fr.UTF-8
159 Contient le serveur de noms named, utilisé pour définir les
160 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
161 utilisé sur les stations de travail comme serveur de nom en cache mais
162 n'est souvent nécessaire que sur une machine pour un réseau entier.
163
164 %description -l pl.UTF-8
165 Pakiet ten zawiera demona named, który służy do zmieniania nazw
166 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
167 roboczych jako bufor odwołań do serwisu nazw (caching name server),
168 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
169 program na fragment sieci.
170
171 %description -l pt_BR.UTF-8
172 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
173 IP (e vice-versa). Pode ser usado em estações de trabalho como um
174 servidor de nomes cache, mas geralmente só é necessário em uma máquina
175 para toda a rede.
176
177 %description -l ru.UTF-8
178 BIND (Berkeley Internet Name Domain) является реализацией протоколов
179 DNS (Domain Name System). BIND включает DNS сервер (named) и
180 библиотеку "резолвера" (подпрограммы для приложений, через которые
181 происходят обращения к DNS). DNS сервер named может быть использован
182 на рабочих станциях как кеширующий сервер, но обычно запускается на
183 одной машине в локальной сети и используется остальными машинами (этим
184 достигается намного более эффективное кеширование).
185
186 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
187 кеширующего сервера, включены в пакет caching-nameserver.
188
189 %description -l tr.UTF-8
190 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
191 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
192 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
193 için sadece bir makina üzerinde kurulur.
194
195 %description -l uk.UTF-8
196 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
197 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
198 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
199 сервер named може бути використаний на робочих станціях як кешируючий
200 сервер, але звичайно запускається на одній машині в локальній мережі і
201 використовується іншими (цим досягається більша ефективність
202 використання кешу).
203
204 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
205 кешируючого серверу, включені в пакет caching-nameserver.
206
207 %package utils
208 Summary:        DNS utils - host, dig, dnsquery, nslookup
209 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
210 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
211 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
212 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
213 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
214 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
215 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
216 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
217 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
218 Group:          Networking/Utilities
219 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
220 Requires:       iconv
221
222 %description utils
223 Bind-utils contains a collection of utilities for querying DNS (Domain
224 Name Service) name servers to find out information about Internet
225 hosts. These tools will provide you with the IP addresses for given
226 host names, as well as other information about registered domains and
227 network addresses.
228
229 You should install bind-utils if you need to get information from DNS
230 name servers.
231
232 %description utils -l de.UTF-8
233 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
234 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
235 Informationen über registrierte Domains und Netzwerk-Adressen.
236
237 %description utils -l es.UTF-8
238 Conjunto de utilitarios para consulta a servidores de nombres. Estas
239 herramientas permiten la determinación de direcciones IP para nombres
240 de máquinas informados y busca información sobre dominios registrados
241 y direcciones de red.
242
243 %description utils -l fr.UTF-8
244 Ensemble d'utilitaires pour interroger les serveurs de noms et
245 rechercher des hôtes. Ces outils vous permettent de déterminer les
246 adresses IP pour des noms d'hôtes donnés, et trouver des informations
247 sur les noms de domaine déclarés et les adresses réseau.
248
249 %description utils -l pl.UTF-8
250 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
251 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
252 i ich adresach IP.
253
254 %description utils -l pt_BR.UTF-8
255 Conjunto de utilitários para consulta a servidores DNS. Estas
256 ferramentas permitem a determinação de endereços IP para nomes de
257 máquinas informados e busca informações sobre domínios registrados e
258 endereços de rede. Você deveria instalar este pacote se necessitar
259 obter informações de servidores DNS.
260
261 %description utils -l ru.UTF-8
262 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
263 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
264 доменному имени (и наоборот) и другую информацию о зарегистрированных
265 доменах и сетевых адресах.
266
267 %description utils -l tr.UTF-8
268 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
269 için kullanılan araçlar bulunmaktadır.
270
271 %description utils -l uk.UTF-8
272 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
273 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
274 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
275 домени та адреси.
276
277 %package libs
278 Summary:        DNS libraries
279 Summary(pl.UTF-8):      Biblioteki DNS
280 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
281 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
282 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
283 Group:          Libraries
284
285 %description libs
286 The bind-libs package contains all libraries required for running BIND
287 and bind utils.
288
289 %description libs -l pl.UTF-8
290 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
291 lub programów z pakietu bind-utils.
292
293 %description libs -l ru.UTF-8
294 Библиотеки, необходимые для работы bind.
295
296 %description libs -l uk.UTF-8
297 Бібліотеки, необхідні для роботи bind.
298
299 %package devel
300 Summary:        DNS development includes
301 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
302 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
303 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
304 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
305 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
306 Group:          Development/Libraries
307 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
308
309 %description devel
310 The bind-devel package contains all the include files and symlinks
311 required for DNS (Domain Name Service) development for BIND.
312
313 You should install bind-devel if you want to develop bind DNS
314 applications. If you install bind-devel, you'll also need to install
315 bind-libs.
316
317 %description devel -l es.UTF-8
318 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
319 para el bind.
320
321 %description devel -l pl.UTF-8
322 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
323 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
324 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
325 pakiet.
326
327 %description devel -l pt_BR.UTF-8
328 Todos os arquivos de cabeçalho e bibliotecas necessários para o
329 desenvolvimento com o bind.
330
331 %description devel -l ru.UTF-8
332 Все хедеры и библиотеки, необходимые для написания программ с
333 использованием BIND 9.x.x.
334
335 %description devel -l uk.UTF-8
336 Всі хедери та бібліотеки, необхідні для розробки програм з
337 використанням BIND 9.x.x.
338
339 %package static
340 Summary:        DNS static libs
341 Summary(pl.UTF-8):      Biblioteki statyczne DNS
342 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
343 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
344 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
345 Group:          Development/Libraries
346 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
347
348 %description static
349 Static bind libraries.
350
351 %description static -l pl.UTF-8
352 Statyczne biblioteki binda.
353
354 %description static -l pt_BR.UTF-8
355 Bibliotecas estáticas para desenvolvimento DNS.
356
357 %description static -l ru.UTF-8
358 Статические библиотеки, необходимые для написания программ с
359 использованием BIND.
360
361 %description static -l uk.UTF-8
362 Статичні бібліотеки, необхідні для розробки програм з використанням
363 BIND.
364
365 %package -n openldap-schema-bind
366 Summary:        BIND schema for openldap
367 Summary(pl.UTF-8):      Schemat BIND dla openldap
368 Group:          Development/Libraries
369 Requires(post,postun):  sed >= 4.0
370 Requires:       openldap-servers
371 Requires:       sed >= 4.0
372 %if "%{_rpmversion}" >= "5"
373 BuildArch:      noarch
374 %endif
375
376 %description -n openldap-schema-bind
377 BIND schema for openldap.
378
379 %description -n openldap-schema-bind -l pl.UTF-8
380 Schemat BIND dla openldap.
381
382 %package -n python3-isc
383 Summary:        Python 3 ISC module - functions to support BIND utilities
384 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
385 Group:          Libraries/Python
386 Requires:       python3-modules
387
388 %description -n python3-isc
389 Python 3 ISC module containing functions to support BIND utilities.
390
391 %description -n python3-isc -l pl.UTF-8
392 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
393 BIND-a.
394
395 %prep
396 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
397 %patch0 -p1
398 %patch1 -p1
399 %patch2 -p1
400 %{?with_ldap:%patch3 -p1}
401 %patch4 -p1
402 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
403 %{?with_edns_cli:%patch5 -p0}
404 %patch6 -p0
405
406 %build
407 %{__libtoolize}
408 %{__aclocal}
409 %{__autoconf}
410 cp -f /usr/share/automake/config.* .
411 %configure \
412         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
413         %{!?with_epoll:--disable-epoll --disable-devpoll} \
414         --enable-full-report \
415         --enable-getifaddrs \
416         %{?with_ipv6:--enable-ipv6} \
417         --enable-largefile \
418         %{__enable_disable seccomp} \
419         %{!?with_static_libs:--disable-static} \
420         --enable-threads \
421         %{?with_kerberos5:--with-gssapi} \
422         --with-libidn2 \
423         --with-libtool \
424         %{?with_ssl:--with-openssl} \
425         %{?with_sql:--with-dlz-postgres} \
426         %{?with_sql:--with-dlz-mysql} \
427         --without-dlz-bdb \
428         --with-dlz-filesystem \
429         %{?with_ldap:--with-dlz-ldap} \
430         --with-dlz-odbc%{!?with_odbc:=no} \
431         --with-dlz-stub \
432         %{?with_geoip:--with-geoip} \
433         --with-lmdb%{!?with_lmdb:=no} \
434         --with-python=%{__python3}
435
436 %{__make}
437
438 %{?with_hip:%{__make} -C bind-hip}
439
440 %if %{with tests}
441 %if %{with system_tests}
442 %{__make} test-force
443 %else
444 sh unit/unittest.sh
445 %endif
446 %endif
447
448 %install
449 rm -rf $RPM_BUILD_ROOT
450 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
451         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
452         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
453         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
454
455 %{__make} install \
456         DESTDIR=$RPM_BUILD_ROOT
457
458 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
459 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
460 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
461 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
462
463 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
464 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
465 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
466 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
467 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
468 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
469 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
470 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
471 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
472
473 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
474 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
475 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
476 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
477
478 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
479
480 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
481 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
482
483 %if %{with ldap}
484 install -d $RPM_BUILD_ROOT%{schemadir}
485 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
486 %endif
487
488 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
489
490 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
491 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
492
493 # let rpm generate deps (workaround -m644 used for libs installation)
494 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
495
496 # we don't want Makefiles in documentation...
497 rm -rf _doc
498 cp -a doc _doc
499 %{__rm} _doc/misc/Makefile*
500
501 %clean
502 rm -rf $RPM_BUILD_ROOT
503
504 %pre
505 if [ -f %{_sysconfdir}/named.boot ]; then
506         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
507         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
508         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
509 fi
510 %groupadd -g 58 named
511 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
512
513 %post
514 /sbin/chkconfig --add named
515 %service named restart
516 %systemd_post named.service
517
518 %preun
519 if [ "$1" = "0" ]; then
520         %service named stop
521         /sbin/chkconfig --del named
522 fi
523 %systemd_preun named.service
524
525 %postun
526 if [ "$1" = "0" ]; then
527         %userremove named
528         %groupremove named
529 fi
530 %systemd_reload
531
532 %post   libs -p /sbin/ldconfig
533 %postun libs -p /sbin/ldconfig
534
535 %post -n openldap-schema-bind
536 %openldap_schema_register %{schemadir}/dnszone.schema
537 %service -q ldap restart
538
539 %postun -n openldap-schema-bind
540 if [ "$1" = "0" ]; then
541         %openldap_schema_unregister %{schemadir}/dnszone.schema
542         %service -q ldap restart
543 fi
544
545 %triggerpostun -- %{name} < 7:9.4.2-2
546 /sbin/chkconfig named reset
547 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
548 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
549 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
550
551 %triggerpostun -- %{name} < 7:9.9.2.P2-2
552 %systemd_trigger named.service
553
554 %files
555 %defattr(644,root,root,755)
556 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
557 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
558
559 %{systemdunitdir}/named.service
560 %attr(754,root,root) /etc/rc.d/init.d/named
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
562 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
563 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
565
566 %attr(755,root,root) %{_sbindir}/ddns-confgen
567 %attr(755,root,root) %{_sbindir}/dnssec-*
568 %attr(755,root,root) %{_sbindir}/named
569 %attr(755,root,root) %{_sbindir}/named-*
570 %attr(755,root,root) %{_sbindir}/nsec3hash
571 %attr(755,root,root) %{_sbindir}/rndc
572 %attr(755,root,root) %{_sbindir}/rndc-confgen
573 %attr(755,root,root) %{_sbindir}/tsig-keygen
574
575 %{_mandir}/man5/named.conf.5*
576 %{_mandir}/man5/rndc.conf.5*
577 %{_mandir}/man8/ddns-confgen.8*
578 %{_mandir}/man8/dnssec-*.8*
579 %{_mandir}/man8/named.8*
580 %{_mandir}/man8/named-*.8*
581 %{_mandir}/man8/nsec3hash.8*
582 %{_mandir}/man8/rndc.8*
583 %{_mandir}/man8/rndc-confgen.8*
584 %{_mandir}/man8/tsig-keygen.8*
585 %lang(ja) %{_mandir}/ja/man8/named*
586
587 %{systemdtmpfilesdir}/%{name}.conf
588
589 %attr(770,root,named) %dir %{_var}/lib/named
590 %attr(770,root,named) %dir %{_var}/lib/named/D
591 %attr(770,root,named) %dir %{_var}/lib/named/M
592 %attr(770,root,named) %dir %{_var}/lib/named/S
593 %attr(770,root,named) %dir %{_var}/lib/named/dev
594 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
595 %attr(750,root,named) %dir %{_var}/lib/named/etc
596 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
597 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
598 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
599 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
600 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
601 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
602
603 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
604 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
605
606 %attr(770,root,named) %dir %{_var}/run/named
607
608 %files utils
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_bindir}/arpaname
611 %attr(755,root,root) %{_bindir}/delv
612 %attr(755,root,root) %{_bindir}/dig
613 %attr(755,root,root) %{_bindir}/host
614 %attr(755,root,root) %{_bindir}/named-rrchecker
615 %attr(755,root,root) %{_bindir}/mdig
616 %attr(755,root,root) %{_bindir}/nslookup
617 %attr(755,root,root) %{_bindir}/nsupdate
618 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
619 %{_mandir}/man1/arpaname.1*
620 %{_mandir}/man1/delv.1*
621 %{_mandir}/man1/dig.1*
622 %{_mandir}/man1/host.1*
623 %{_mandir}/man1/mdig.1*
624 %{_mandir}/man1/named-rrchecker.1*
625 %{_mandir}/man1/nslookup.1*
626 %{_mandir}/man1/nsupdate.1*
627
628 %lang(fi) %{_mandir}/fi/man1/host.1*
629
630 %lang(fr) %{_mandir}/fr/man1/host.1*
631
632 %lang(hu) %{_mandir}/hu/man1/host.1*
633
634 %lang(ja) %{_mandir}/ja/man1/dig.1*
635 %lang(ja) %{_mandir}/ja/man1/host.1*
636 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
637 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
638
639 %lang(pl) %{_mandir}/pl/man1/host.1*
640
641 %files libs
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.1302
645 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libdns.so.1306
647 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libirs.so.1301
649 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libisc.so.1306
651 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.1302
653 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1302
655 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
656 %attr(755,root,root) %ghost %{_libdir}/libns.so.1304
657 %attr(755,root,root) %ghost %{_libdir}/named/filter-aaaa.so
658 %{_mandir}/man8/filter-aaaa.8*
659
660 %files devel
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/bind9-config
663 %attr(755,root,root) %{_bindir}/isc-config.sh
664 %attr(755,root,root) %{_libdir}/libbind9.so
665 %attr(755,root,root) %{_libdir}/libdns.so
666 %attr(755,root,root) %{_libdir}/libirs.so
667 %attr(755,root,root) %{_libdir}/libisc.so
668 %attr(755,root,root) %{_libdir}/libisccc.so
669 %attr(755,root,root) %{_libdir}/libisccfg.so
670 %attr(755,root,root) %{_libdir}/libns.so
671 %{_libdir}/libbind9.la
672 %{_libdir}/libdns.la
673 %{_libdir}/libirs.la
674 %{_libdir}/libisc.la
675 %{_libdir}/libisccc.la
676 %{_libdir}/libisccfg.la
677 %{_libdir}/libns.la
678 %{_includedir}/bind9
679 %{_includedir}/dns
680 %{_includedir}/dst
681 %{_includedir}/irs
682 %{_includedir}/isc
683 %{_includedir}/isccc
684 %{_includedir}/isccfg
685 %{_includedir}/ns
686 %{_includedir}/pk11
687 %{_includedir}/pkcs11
688 %{_mandir}/man1/bind9-config.1*
689 %{_mandir}/man1/isc-config.sh.1*
690
691 %if %{with static_libs}
692 %files static
693 %defattr(644,root,root,755)
694 %{_libdir}/libbind9.a
695 %{_libdir}/libdns.a
696 %{_libdir}/libirs.a
697 %{_libdir}/libisc.a
698 %{_libdir}/libisccc.a
699 %{_libdir}/libisccfg.a
700 %{_libdir}/libns.a
701 %endif
702
703 %if %{with ldap}
704 %files -n openldap-schema-bind
705 %defattr(644,root,root,755)
706 %{_datadir}/openldap/schema/dnszone.schema
707 %endif
708
709 %files -n python3-isc
710 %defattr(644,root,root,755)
711 %{py3_sitedir}/isc
712 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.090263 seconds and 3 git commands to generate.