]> git.pld-linux.org Git - packages/bicyclerepair.git/blob - bicyclerepair.spec
91f3029aca7ff5b83d56b9a8f3ebad55694a2613
[packages/bicyclerepair.git] / bicyclerepair.spec
1
2 #
3 # todo:
4 # - emacs, idle and vim subpackages
5 #
6
7 # Conditional build:
8 %bcond_without tests    # disables testing
9 #
10 Summary:        Python Refactoring Browser
11 Name:           bicyclerepair
12 Version:        0.9
13 %define beta    BETA4
14 Release:        0.%{beta}.1
15 License:        BSD-like
16 Group:          Development/Languages/Python
17 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}-%{beta}.tar.gz
18 # Source0-md5:  635287697aa7f3bb580267e9df203f89
19 URL:            http://bicyclerepair.sourceforge.net/
20 BuildRequires:  python-modules >= 2.2.1
21 BuildRequires:  rpm-pythonprov
22 %pyrequires_eq  python-modules
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Bicycle Repair Man is the Python Refactoring Browser, helping
28 Pythonistas everywhere glide over the gory details of refactoring
29 their code. Watch him extract jumbled code into well ordered classes.
30 Gasp, as he renames all occurrences of a method. Thank You, Bicycle
31 Repair Man!
32
33 %description -l pl
34 Bicycle Repair Man ("Mechanik Rowerowy") to narzêdzie do refaktoryzacji
35 kodu ¼ród³owego napisanego w jêzyku Python, pozwalaj±ce programistom na
36 unikniêcie morderczej pracy zwi±zanej z ulepszaniem swojego kodu. 
37
38 Patrz, jak brzydki kod przekszta³ca siê w piêkne klasy. Tchu zabraknie Ci
39 ze zdziwienia, gdy zacznie zmieniaæ wszystkie wyst±pienia metody.
40 Dziêkujemy Ci, Mechaniku Rowerowy!
41
42 %prep
43 %setup -q -n %{name}-%{version}-%{beta}
44
45 %build
46 python setup.py build
47
48 %{?with_tests:python -O testall.py -v}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 python setup.py install \
54         --optimize=2 \
55         --root=$RPM_BUILD_ROOT
56
57 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py -exec rm -f {} \;
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS COPYING ChangeLog DESIGN NEWS README*
65 %doc ide-integration/bike.vim
66 #%attr(755,root,root) %{_bindir}/*
67 %{py_sitedir}/*
This page took 0.074545 seconds and 3 git commands to generate.