]> git.pld-linux.org Git - packages/bfilter.git/blob - bfilter.spec
- some uid/gid-related dependencies
[packages/bfilter.git] / bfilter.spec
1 #
2 # Conditional build:
3 %bcond_with     gui     # Enable GTK+ UI (doesn't build)
4 #
5 Summary:        A filtering Web proxy
6 Summary(pl.UTF-8):      Filtrujące proxy WWW
7 Name:           bfilter
8 Version:        0.9.4
9 Release:        1
10 License:        GPL v2+
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/bfilter/%{name}-%{version}.tar.gz
13 # Source0-md5:  72ca85565bd4c556b06e3a264c0c24f1
14 Source1:        %{name}.init
15 URL:            http://bfilter.sf.net
16 BuildRequires:  libsigc++12-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  popt-devel
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 BuildRequires:  zlib-devel
22 Requires(post,preun):   /sbin/chkconfig
23 Requires(postun):       /usr/sbin/groupdel
24 Requires(postun):       /usr/sbin/userdel
25 Requires(pre):  /bin/id
26 Requires(pre):  /usr/bin/getgid
27 Requires(pre):  /usr/sbin/groupadd
28 Requires(pre):  /usr/sbin/useradd
29 Provides:       group(bfilter)
30 Provides:       user(bfilter)
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 BFilter is a filtering web proxy. It was originally intended for
35 removing banner ads only, but at some point it has been extended to
36 remove popups and webbugs. Its main advantage over the similar tools
37 is its heuristic ad detection algorithm.
38
39 %description -l pl.UTF-8
40 BFilter jest filtrującym proxy WWW. Pierwotnie miał on filtrować tylko
41 bannery, jednak rozszerzono go o usuwanie popupów i innych reklam.
42 Główną jego przewagą nad innymi tego rodzaju narzędziami jest
43 heurystyczny algorytm rozpoznawania reklam.
44
45 %prep
46 %setup -q
47
48 %build
49 %configure \
50         --with%{!?with_gui:out}-gui
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %pre
66 %groupadd -r -g 199 %{name}
67 %useradd -r -u 199 -s /bin/false -d / -g %{name} -c "BFilter filtering proxy" %{name}
68
69 %post
70 /sbin/chkconfig --add %{name}
71 %service %{name} restart "BFilter filtering proxy"
72
73 %preun
74 if [ "$1" = "0" ]; then
75         %service %{name} stop
76         /sbin/chkconfig --del %{name}
77 fi
78
79 %postun
80 if [ "$1" = "0" ]; then
81         %userremove %{name}
82         %groupremove %{name}
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS ChangeLog NEWS README doc/*.html doc/*.png
88 %attr(755,root,root) %{_bindir}/%{name}
89 %attr(754,root,root) /etc/rc.d/init.d/%{name}
90 %dir %{_sysconfdir}/%{name}
91 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/config
92 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/rules.local
93 %{_sysconfdir}/%{name}/config.default
94 %{_sysconfdir}/%{name}/rules
This page took 0.066676 seconds and 3 git commands to generate.