]> git.pld-linux.org Git - packages/bfilter.git/blob - bfilter.spec
- spaces->tabs
[packages/bfilter.git] / bfilter.spec
1 #
2 # Conditional build:
3 %bcond_with     gui     # Enable GTK+ UI (doesn't build)
4 #
5 Summary:        A filtering Web proxy
6 Summary(pl):    Filtruj±ce proxy WWW
7 Name:           bfilter
8 Version:        0.9.4
9 Release:        1
10 License:        GPL v2+
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13 # Source0-md5:  72ca85565bd4c556b06e3a264c0c24f1
14 Source1:        %{name}.init
15 URL:            http://bfilter.sf.net
16 BuildRequires:  libsigc++12-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  popt-devel
20 BuildRequires:  zlib-devel
21 Requires(post): /usr/sbin/groupadd
22 Requires(post): /usr/sbin/useradd
23 Requires(post,preun):   /sbin/chkconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description 
27 BFilter is a filtering web proxy. It was originally intended for
28 removing banner ads only, but at some point it has been extended to
29 remove popups and webbugs. Its main advantage over the similar tools
30 is its heuristic ad detection algorithm. 
31
32 %description -l pl
33 BFilter jest filtruj±cym proxy WWW. Pierwotnie mia³ on filtrowaæ tylko
34 bannery, jednak rozszerzono go o usuwanie popupów i innych reklam.
35 G³ówn± jego przewag± nad innymi tego rodzaju narzêdziami jest
36 heurystyczny algorytm rozpoznawania reklam.
37
38 %prep
39 %setup -q
40
41 %build
42 %configure \
43         --with%{!?with_gui:out}-gui
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %pre
59 # XXX: unify
60 /usr/sbin/groupadd -r -f %{name}
61 /usr/sbin/useradd -r -s /bin/false -d / -M -g %{name} -c 'BFilter filtering proxy' %{name}
62
63 %post
64 /sbin/chkconfig --add %{name}
65 if [ -f /var/lock/subsys/%{name} ]; then
66         /etc/rc.d/init.d/%{name} restart 1>&2
67 else
68         echo "Type \"/etc/rc.d/init.d/%{name} start\" to start %{name}." 1>&2
69 fi
70
71 %preun
72 if [ "$1" = "0" ]; then
73         if [ -f /var/lock/subsys/%{name} ]; then
74                 /etc/rc.d/init.d/%{name} stop 1>&2
75         fi
76         /sbin/chkconfig --del %{name}
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS ChangeLog NEWS README doc/*.html doc/*.png
82 %attr(755,root,root) %{_bindir}/%{name}
83 %attr(755,root,root) /etc/rc.d/init.d/%{name}
84 %dir %{_sysconfdir}/%{name}
85 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/config
86 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/rules.local
87 %{_sysconfdir}/%{name}/config.default
88 %{_sysconfdir}/%{name}/rules
This page took 0.079514 seconds and 3 git commands to generate.