]> git.pld-linux.org Git - packages/bfilter.git/blob - bfilter.spec
- converted to UTF-8
[packages/bfilter.git] / bfilter.spec
1 #
2 # Conditional build:
3 %bcond_with     gui     # Enable GTK+ UI (doesn't build)
4 #
5 Summary:        A filtering Web proxy
6 Summary(pl.UTF-8):   Filtrujące proxy WWW
7 Name:           bfilter
8 Version:        0.9.4
9 Release:        1
10 License:        GPL v2+
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/bfilter/%{name}-%{version}.tar.gz
13 # Source0-md5:  72ca85565bd4c556b06e3a264c0c24f1
14 Source1:        %{name}.init
15 URL:            http://bfilter.sf.net
16 BuildRequires:  broken-pre-scriptlet(fix:user/group)
17 BuildRequires:  libsigc++12-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  pkgconfig
20 BuildRequires:  popt-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 BuildRequires:  zlib-devel
23 Requires(post,preun):   /sbin/chkconfig
24 Requires(pre):  /bin/id
25 Requires(pre):  /usr/bin/getgid
26 Requires(pre):  /usr/sbin/groupadd
27 Requires(pre):  /usr/sbin/useradd
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 BFilter is a filtering web proxy. It was originally intended for
32 removing banner ads only, but at some point it has been extended to
33 remove popups and webbugs. Its main advantage over the similar tools
34 is its heuristic ad detection algorithm.
35
36 %description -l pl.UTF-8
37 BFilter jest filtrującym proxy WWW. Pierwotnie miał on filtrować tylko
38 bannery, jednak rozszerzono go o usuwanie popupów i innych reklam.
39 Główną jego przewagą nad innymi tego rodzaju narzędziami jest
40 heurystyczny algorytm rozpoznawania reklam.
41
42 %prep
43 %setup -q
44
45 %build
46 %configure \
47         --with%{!?with_gui:out}-gui
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %pre
63 # XXX: unify
64 # TODO register uid/gid in uid_gid.db.txt
65 %groupadd -r -g XXX -f %{name}
66 %useradd -r -u XXX -s /bin/false -d / -M -g %{name} -c "BFilter filtering proxy" %{name}
67
68 %post
69 /sbin/chkconfig --add %{name}
70 %service %{name} restart
71
72 %preun
73 if [ "$1" = "0" ]; then
74         %service %{name} stop
75         /sbin/chkconfig --del %{name}
76 fi
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS ChangeLog NEWS README doc/*.html doc/*.png
81 %attr(755,root,root) %{_bindir}/%{name}
82 %attr(754,root,root) /etc/rc.d/init.d/%{name}
83 %dir %{_sysconfdir}/%{name}
84 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/config
85 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/rules.local
86 %{_sysconfdir}/%{name}/config.default
87 %{_sysconfdir}/%{name}/rules
This page took 0.078286 seconds and 3 git commands to generate.