]> git.pld-linux.org Git - packages/beryl-core.git/blob - beryl-core.spec
- up to new 0.1.3
[packages/beryl-core.git] / beryl-core.spec
1 #
2 # TODO: python
3 #
4 %bcond_with     beryl_mesa
5
6 Summary:        OpenGL window and compositing manager
7 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
8 Name:           beryl-core
9 Version:        0.1.3
10 Release:        1
11 License:        MIT
12 Group:          X11
13 Source0:        http://releases.beryl-project.org/0.1.3/%{name}-%{version}.tar.bz2
14 # Source0-md5:  24caed8a8cb50fd30823a9ee182f85f4
15 %{?with_beryl_mesa:Source1:     http://releases.beryl-project.org/0.1.3/beryl-mesa-%{version}.tar.bz2}
16 # Source1-md5:  c22765c2637846907ee6154b548151e9
17 BuildRequires:  autoconf >= 2.57
18 BuildRequires:  automake
19 BuildRequires:  glib2-devel >= 2.0
20 BuildRequires:  intltool
21 BuildRequires:  libpng-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  python-modules >= 1:2.2
25 BuildRequires:  startup-notification-devel >= 0.7
26 BuildRequires:  xorg-lib-libSM-devel
27 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.3
28 BuildRequires:  xorg-lib-libXdamage-devel
29 BuildRequires:  xorg-lib-libXinerama-devel
30 BuildRequires:  xorg-lib-libXrandr-devel
31 BuildRequires:  xorg-proto-glproto-devel
32 BuildRequires:  xorg-util-makedepend
33 Provides:       compiz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Beryl is an OpenGL compositing manager that use
38 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
39 to texture objects. It has a flexible plug-in system and it is
40 designed to run well on most graphics hardware.
41
42 This is an enhanced version of compiz, developed mainly by Quinnstorm.
43 Some parts were optimized for speed and there were added few
44 additional plugins and patches, delivering even more eyecandy.
45
46 %description -l pl
47 Beryl jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
48 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
49 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
50 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
51
52 To jest udoskonalona wersja compiza, tworzona g³ównie przez
53 Quinnstorma. Niektóre czê¶ci zosta³y zoptymalizowane pod wzglêdem
54 prêdko¶ci oraz dodano kilka dodatkowych wtyczek i ³atek,
55 dostarczaj±cych jeszcze wiêcej ¶wiecide³ek.
56
57 %package devel
58 Summary:        Header files for beryl
59 Summary(pl):    Pliki nag³ówkowe dla beryla
60 Group:          Development
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       OpenGL-devel
63 Requires:       libpng-devel
64 Requires:       startup-notification-devel >= 0.7
65 Requires:       xorg-lib-libSM-devel
66 Requires:       xorg-lib-libXcomposite-devel >= 0.3
67 Requires:       xorg-lib-libXdamage-devel
68 Requires:       xorg-lib-libXrandr-devel
69 Conflicts:      compiz-devel
70
71 %description devel
72 Header files for beryl.
73
74 %description devel -l pl
75 Pliki nag³ówkowe dla beryla.
76
77 %prep
78 %setup -q %{?with_beryl_mesa: -a1}
79 mv -f po/{es_AR,ar}.po
80 mv -f po/{es_ES,es}.po
81 mv -f po/{fr_FR,fr}.po
82 mv -f po/{hu_HU,hu}.po
83 mv -f po/{it_IT,it}.po
84 mv -f po/{ja_JP,ja}.po
85 mv -f po/{ko_KR,ko}.po
86 mv -f po/{pt_PT,pt}.po
87 mv -f po/{sv_SE,sv}.po
88
89     # NOTE: check the list ofter any upgrade!
90 cat > po/LINGUAS <<EOF
91 ar
92 es
93 fr
94 hu
95 it
96 ja
97 ko
98 pt_BR
99 pt
100 sv
101 zh_CN
102 zh_HK
103 zh_TW
104 EOF
105
106 %build
107 sed -i 's/bin_PROGRAMS = beryl beryl-settings-dump beryl-xgl/bin_PROGRAMS = beryl beryl-settings-dump/' src/Makefile.am
108 autoreconf -v --install
109 %{__glib_gettextize}
110 intltoolize --automake --copy --force
111
112 # bashizms inside
113 sed -i -e 's@^#! /bin/sh$@#!/bin/bash@' configure
114
115 %configure \
116         %{?with_beryl_mesa:--with-berylmesadir=beryl-mesa} \
117         --disable-static
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %find_lang %{name}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog README TODO
137 %attr(755,root,root) %{_bindir}/*
138 %attr(755,root,root) %{_libdir}/*.so.*.*.*
139 %dir %{_libdir}/beryl
140 %dir %{_libdir}/beryl/backends
141 %attr(755,root,root) %{_libdir}/beryl/backends/*.so
142 %{_libdir}/beryl/backends/*.la
143 %{_datadir}/beryl
144 %{_mandir}/man1/*
145 %{_libdir}/beryl/backends
146 %{_libdir}/beryl/backends/*.so
147
148 %files devel
149 %defattr(644,root,root,755)
150 %{_libdir}/*.so
151 %{_libdir}/*.la
152 %{_libdir}/beryl/backends/*.la
153 %{_includedir}/beryl
154 %{_pkgconfigdir}/*.pc
155 %{_mandir}/man3/*.3*
This page took 0.092012 seconds and 3 git commands to generate.