]> git.pld-linux.org Git - packages/beryl-core.git/blob - beryl-core.spec
- disable Source1-md5
[packages/beryl-core.git] / beryl-core.spec
1 #
2 # Conditional build:
3 %bcond_with     beryl_mesa      # beryl-xgl statically linked with own libGL
4 #
5 Summary:        OpenGL window and compositing manager
6 Summary(pl.UTF-8):      OpenGL-owy zarządca okien i składania
7 Name:           beryl-core
8 Version:        0.2.0
9 Release:        1
10 Epoch:          1
11 License:        MIT
12 Group:          X11
13 Source0:        http://releases.beryl-project.org/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b937a4e6606d931c03d2014d08e9b096
15 #Source1:       http://releases.beryl-project.org/%{version}/beryl-mesa-%{version}.tar.bz2
16 ## Source1-md5: 387d068091bc5c6fa28f6d754e1296d1
17 Patch0:         %{name}-link.patch
18 URL:            http://beryl-project.org/
19 BuildRequires:  GConf2-devel >= 2.0
20 BuildRequires:  OpenGL-GLX-devel
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  startup-notification-devel >= 0.7
31 BuildRequires:  xorg-lib-libSM-devel
32 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.3
33 BuildRequires:  xorg-lib-libXdamage-devel
34 BuildRequires:  xorg-lib-libXinerama-devel
35 BuildRequires:  xorg-lib-libXrandr-devel
36 BuildRequires:  xorg-lib-libXrender-devel >= 0.8.4
37 BuildRequires:  xorg-proto-glproto-devel
38 BuildRequires:  xorg-util-makedepend
39 Requires:       xorg-app-xvinfo
40 Provides:       compiz
41 Obsoletes:      compiz-quinnstorm
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Beryl is an OpenGL compositing manager that use
46 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
47 to texture objects. It has a flexible plug-in system and it is
48 designed to run well on most graphics hardware.
49
50 This is an enhanced version of compiz, developed mainly by Quinnstorm.
51 Some parts were optimized for speed and there were added few
52 additional plugins and patches, delivering even more eyecandy.
53
54 %description -l pl.UTF-8
55 Beryl jest OpenGL-owym zarządcą składania, używającym rozszerzenia
56 GLX_EXT_texture_from_pixmap w celu wiązania przekierowanych okien do
57 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
58 by dobrze działać na większości kart graficznych.
59
60 To jest udoskonalona wersja compiza, tworzona głównie przez
61 Quinnstorma. Niektóre części zostały zoptymalizowane pod względem
62 prędkości oraz dodano kilka dodatkowych wtyczek i łatek,
63 dostarczających jeszcze więcej świecidełek.
64
65 %package devel
66 Summary:        Header files for beryl
67 Summary(pl.UTF-8):      Pliki nagłówkowe dla beryla
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70 Requires:       OpenGL-GLX-devel
71 Requires:       glib2-devel >= 2.0
72 Requires:       libpng-devel
73 Requires:       startup-notification-devel >= 0.7
74 Requires:       xorg-lib-libSM-devel
75 Requires:       xorg-lib-libXcomposite-devel >= 0.3
76 Requires:       xorg-lib-libXdamage-devel
77 Requires:       xorg-lib-libXinerama-devel
78 Requires:       xorg-lib-libXrandr-devel
79 Requires:       xorg-lib-libXrender-devel >= 0.8.4
80 Requires:       xorg-proto-glproto-devel
81 Obsoletes:      compiz-quinnstorm-devel
82
83 %description devel
84 Header files for beryl.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe dla beryla.
88
89 %package gconf
90 Summary:        GConf settings plugin for beryl
91 Summary(pl.UTF-8):      Wtyczka ustawień GConf dla beryla
92 Group:          Libraries
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94
95 %description gconf
96 GConf settings plugin for beryl.
97
98 %description gconf -l pl.UTF-8
99 Wtyczka ustawień GConf dla beryla.
100
101 %prep
102 %setup -q %{?with_beryl_mesa: -a1}
103 %patch0 -p1
104
105 mv -f po/{de_DE,de}.po
106 mv -f po/{hu_HU,hu}.po
107 mv -f po/{pt_PT,pt}.po
108 mv -f po/{sv_SE,sv}.po
109 mv -f po/{uk_UA,uk}.po
110
111 # NOTE: check the list after any upgrade!
112 cat > po/LINGUAS <<EOF
113 ca
114 cs
115 de
116 es
117 es_AR
118 fr
119 hu
120 it
121 ja
122 ko
123 nl
124 pl
125 pt_BR
126 pt
127 ru
128 sv
129 uk
130 zh_CN
131 zh_HK
132 zh_TW
133 EOF
134
135 %build
136 %{__glib_gettextize}
137 %{__intltoolize} --automake
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143
144 # bashisms inside
145 sed -i -e 's@^#! /bin/sh$@#!/bin/bash@' configure
146
147 %configure \
148         %{?with_beryl_mesa:--with-berylmesadir=beryl-mesa} \
149         --disable-static \
150         --enable-gconf
151
152 %{__make}
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 rm -f $RPM_BUILD_ROOT%{_libdir}/beryl/backends/*.la
161
162 # program removed
163 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/beryl-settings-dump.1
164
165 %find_lang %{name}
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files -f %{name}.lang
174 %defattr(644,root,root,755)
175 %doc AUTHORS README TODO
176 %attr(755,root,root) %{_bindir}/beryl
177 %attr(755,root,root) %{_libdir}/libberyldecoration.so.*.*.*
178 %attr(755,root,root) %{_libdir}/libberylsettings.so.*.*.*
179 %dir %{_libdir}/beryl
180 %dir %{_libdir}/beryl/backends
181 %attr(755,root,root) %{_libdir}/beryl/backends/libini.so
182 %{_datadir}/beryl
183 %{_mandir}/man1/beryl.1*
184 %if %{with beryl_mesa}
185 %attr(755,root,root) %{_bindir}/beryl-xgl
186 %{_mandir}/man1/beryl-xgl.1*
187 %endif
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libberyldecoration.so
192 %attr(755,root,root) %{_libdir}/libberylsettings.so
193 %{_libdir}/libberyldecoration.la
194 %{_libdir}/libberylsettings.la
195 %{_includedir}/beryl
196 %{_pkgconfigdir}/beryl.pc
197 %{_pkgconfigdir}/berylsettings.pc
198 %{_pkgconfigdir}/libberyldecoration.pc
199 %{_mandir}/man3/*.3*
200
201 %files gconf
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/beryl/backends/libgconf.so
This page took 0.113482 seconds and 3 git commands to generate.