]> git.pld-linux.org Git - packages/belr.git/blob - belr.spec
- added static patch (fix both shared+static build in cmake)
[packages/belr.git] / belr.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Belledonne Communications' language recognition library
6 Summary(pl.UTF-8):      Biblioteka rozpoznawania języków Belledonne Communications
7 Name:           belr
8 Version:        4.5.15
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 #Source0Download: https://gitlab.linphone.org/BC/public/belr/-/tags
13 Source0:        https://gitlab.linphone.org/BC/public/belr/-/archive/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  2535ccc46f621226d3bc44d7e2dd7f02
15 Patch0:         %{name}-static.patch
16 URL:            https://linphone.org/
17 BuildRequires:  bctoolbox-devel >= 0.0.5
18 BuildRequires:  cmake >= 3.1
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRequires:  pkgconfig
21 BuildRequires:  udev-devel
22 Requires:       bctoolbox >= 0.0.5
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Belr is Belledonne Communications' language recognition library. It
27 aims at parsing any input formatted according to a language defined by
28 an ABNF grammar, such as the protocols standardized at IETF.
29
30 It is based on finite state machine theory and heavily relies on
31 recursivity from an implementation standpoint.
32
33 %description -l pl.UTF-8
34 Belr to biblioteka do rozpoznawania języków Belledonne Communications.
35 Jej celem jest analiza dowolnego wejścia sformatowanego zgodnie z
36 językiem zdefiniowanym przez gramatykę ABNF, np. protokołów
37 standaryzowanych przez IETF.
38
39 Biblioteka jest oparta na teorii automatów skończonych, implementacja
40 znacząco wykorzystuje rekusywność.
41
42 %package devel
43 Summary:        Header files for belr library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki belr
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       bctoolbox-devel >= 0.0.5
48 Requires:       libstdc++-devel >= 6:4.7
49
50 %description devel
51 Header files for belr library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki belr.
55
56 %package static
57 Summary:        Static belr library
58 Summary(pl.UTF-8):      Statyczna biblioteka belr
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static belr library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka belr.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 install -d build
74 cd build
75 %cmake .. \
76         %{!?with_static_libs:-DENABLE_STATIC=OFF} \
77         -DENABLE_TESTS=OFF
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} -C build install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 # disable completeness check incompatible with split packaging
88 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_libdir}/cmake/belr/belrTargets.cmake
89
90 # missing from cmake
91 test ! -f $RPM_BUILD_ROOT%{_pkgconfigdir}/belr.pc
92 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
93 %{__sed} -e 's,@CMAKE_INSTALL_PREFIX@,%{_prefix},' \
94         -e 's,@PROJECT_NAME@,belr,' \
95         -e 's,@PROJECT_VERSION@,%{version},' \
96         -e 's,@CMAKE_INSTALL_FULL_LIBDIR@,%{_libdir},' \
97         -e 's,@LIBS_PRIVATE@,-lbctoolbox,' \
98         -e 's,@CMAKE_INSTALL_FULL_INCLUDEDIR@,%{_includedir},' \
99         belr.pc.in >$RPM_BUILD_ROOT%{_pkgconfigdir}/belr.pc
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc CHANGELOG.md README.md
110 %attr(755,root,root) %{_bindir}/belr-compiler
111 %attr(755,root,root) %{_bindir}/belr-parse
112 %attr(755,root,root) %{_libdir}/libbelr.so.1
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libbelr.so
117 %{_includedir}/belr
118 %{_pkgconfigdir}/belr.pc
119 %{_libdir}/cmake/belr
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libbelr.a
125 %endif
This page took 0.050662 seconds and 3 git commands to generate.