]> git.pld-linux.org Git - packages/belle-sip.git/blame - belle-sip.spec
upstream fix to a free-after-use bug
[packages/belle-sip.git] / belle-sip.spec
CommitLineData
4d971c61
JK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4%bcond_with tests # enable tests
5#
6Summary: SIP (RFC3261) object-oriented implementation in C
7Summary(pl.UTF-8): Implementacja SIP (RFC3261) w C
8Name: belle-sip
9Version: 1.3.0
c33ca48f 10Release: 1
5b7dfe73 11License: GPL v2+
4d971c61
JK
12Group: Libraries
13Source0: http://download-mirror.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
14# Source0-md5: ae9e8be12f62552a5376edd66b0265d9
15Patch0: antlr_jar.patch
a46e337a 16Patch1: use_after_free.patch
4d971c61
JK
17URL: http://www.linphone.org/
18%{?with_tests:BuildRequires: CUnit >= 2.0}
5b7dfe73
JB
19BuildRequires: autoconf >= 2.63
20BuildRequires: automake >= 1:1.11
4d971c61 21BuildRequires: java-antlr3 >= 3.2
5b7dfe73 22BuildRequires: jre
4d971c61 23BuildRequires: libantlr3c-devel >= 3.2
5b7dfe73
JB
24BuildRequires: libstdc++-devel
25BuildRequires: libtool >= 2:2
4d971c61 26BuildRequires: polarssl-devel >= 1.2
5b7dfe73 27BuildRequires: pkgconfig
4d971c61
JK
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Belle-sip is a SIP (RFC3261) implementation written in C, with an
5b7dfe73
JB
32object oriented API.
33
34%description -l pl.UTF-8
35Belle-sip to implementacja SIP (RFC3261) napisana w C z API
36zorientowanym obiektowo.
4d971c61
JK
37
38%package devel
39Summary: Header files for %{name} library
40Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43
44%description devel
45Header files for %{name} library.
46
47%description devel -l pl.UTF-8
48Pliki nagłówkowe biblioteki %{name}.
49
50%package static
51Summary: Static %{name} library
52Summary(pl.UTF-8): Statyczna biblioteka %{name}
53Group: Development/Libraries
54Requires: %{name}-devel = %{version}-%{release}
55
56%description static
57Static %{name} library.
58
59%description static -l pl.UTF-8
60Statyczna biblioteka %{name}.
61
62%prep
63%setup -q
64%patch0 -p1
a46e337a 65%patch1 -p1
4d971c61
JK
66
67%build
68%{__libtoolize}
69%{__aclocal}
70%{__autoconf}
71%{__autoheader}
72%{__automake}
73%configure \
74 CFLAGS="%{rpmcflags} -Wno-error=pragmas" \
5b7dfe73 75 --disable-silent-rules \
4d971c61
JK
76 %{!?with_static_libs:--disable-static}
77
5b7dfe73 78%{__make}
4d971c61
JK
79
80%{?with_tests:%{__make} test}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
5b7dfe73 85%{__make} install \
4d971c61
JK
86 DESTDIR=$RPM_BUILD_ROOT
87
5b7dfe73 88%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbellesip.la
4d971c61
JK
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%files
97%defattr(644,root,root,755)
98%doc AUTHORS NEWS README
99%attr(755,root,root) %{_libdir}/libbellesip.so.*.*.*
100%attr(755,root,root) %ghost %{_libdir}/libbellesip.so.0
101
102%files devel
103%defattr(644,root,root,755)
104%attr(755,root,root) %{_libdir}/libbellesip.so
105%{_includedir}/%{name}
106%{_pkgconfigdir}/%{name}.pc
107
108%if %{with static_libs}
109%files static
110%defattr(644,root,root,755)
111%{_libdir}/libbellesip.a
112%endif
This page took 0.102974 seconds and 4 git commands to generate.