]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- pass CPU tuning to configure scripts, added opt patch to better exploit
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 # _with_javaglue
4 #
5 %define         snap 20030516
6 Summary:        The BeeCrypt Cryptography Library
7 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
8 Name:           beecrypt
9 Version:        3.0.0
10 Release:        0.%{snap}.1
11 Epoch:          2
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sf.net/%{name}/%{name}-%{version}pre.%{snap}.tar.gz
15 Patch0:         %{name}-from_rpm.patch
16 Patch1:         %{name}-opt.patch
17 URL:            http://sourceforge.net/projects/beecrypt/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 BeeCrypt is an open source cryptography library that contains highly
25 optimized C and assembler implementations of many well-known
26 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
27 ElGamal.
28
29 %description -l pl
30 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
31 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
32 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
33
34 %package devel
35 Summary:        The BeeCrypt Cryptography Library - development files
36 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}
39
40 %description devel
41 The BeeCrypt Cryptography Library - development files.
42
43 %description devel -l pl
44 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
45
46 %package static
47 Summary:        The BeeCrypt Cryptography Library - static library
48 Summary(pl):    Biblioteka statyczna BeeCrypt
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}
51
52 %description static
53 The BeeCrypt Cryptography Library - static library.
54
55 %description static -l pl
56 Biblioteka statyczna BeeCrypt.
57
58 %prep
59 %setup  -q -n %{name}-%{version}pre
60 %patch0 -p1
61 %patch1 -p1
62
63 %build
64 rm -f missing
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 %configure \
71         --with%{?!_with_javaglue:out}-javaglue \
72         --with-cpu=%{_target_cpu} \
73         --with-arch=%{_target_cpu}
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
90 %attr(755,root,root) %{_libdir}/lib*.so.*.*
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_libdir}/lib*.so
95 %{_libdir}/lib*.la
96 %{_includedir}/*
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/lib*.a
This page took 1.491018 seconds and 4 git commands to generate.