]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- added -ac_python.patch - fix for python sitedir path
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 # Conditional build:
4 %bcond_with     javaglue        # build with Java support
5 %bcond_without  python          # don't build python module
6 #
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        4.0.0
11 Release:        1
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  f19e060ecc4fc23d8f1268e1b145614f
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-lib64_fix.patch
19 Patch2:         %{name}-ac_python.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 %if %{with python}
25 BuildRequires:  python-devel
26 BuildRequires:  python-modules
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         specflags_alpha          -mno-explicit-relocs 
31
32 %description
33 BeeCrypt is an open source cryptography library that contains highly
34 optimized C and assembler implementations of many well-known
35 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
36 ElGamal.
37
38 %description -l pl
39 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
40 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
41 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
42
43 %package devel
44 Summary:        The BeeCrypt Cryptography Library - development files
45 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
46 Group:          Development/Libraries
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48
49 %description devel
50 The BeeCrypt Cryptography Library - development files.
51
52 %description devel -l pl
53 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
54
55 %package static
56 Summary:        The BeeCrypt Cryptography Library - static library
57 Summary(pl):    Biblioteka statyczna BeeCrypt
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
60
61 %description static
62 The BeeCrypt Cryptography Library - static library.
63
64 %description static -l pl
65 Biblioteka statyczna BeeCrypt.
66
67 %package -n python-beecrypt
68 Summary:        Python interface to BeeCrypt library
69 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
70 Group:          Development/Languages/Python
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72 %pyrequires_eq  python
73
74 %description -n python-beecrypt
75 The python-beecrypt package contains a module which permits applications
76 written in the Python programming language to use the interface
77 supplied by BeeCrypt libraries.
78
79 %description -n python-beecrypt -l pl
80 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
81 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
90 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
91 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         --without-cplusplus \
101         --with%{!?with_javaglue:out}-javaglue \
102         --with-cpu=%{_target_cpu} \
103         --with-arch=%{_target_cpu} \
104         --with-pic \
105         --with%{!?with_python:out}-python
106 %{__make}
107
108 %if %{with python}
109 %{__make} -C python
110 %endif
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %if %{with python}
119 %{__make} install -C python \
120         DESTDIR=$RPM_BUILD_ROOT
121 %endif
122
123 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
134 %attr(755,root,root) %{_libdir}/lib*.so.*.*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/lib*.so
139 %{_libdir}/lib*.la
140 %{_includedir}/*
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/lib*.a
145
146 %if %{with python}
147 %files -n python-beecrypt
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{py_sitedir}/*.so
150 %endif
This page took 0.067795 seconds and 4 git commands to generate.