]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- updated to 20030610 snaps
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 # _with_javaglue
4 #
5 %define         snap 20030610
6 Summary:        The BeeCrypt Cryptography Library
7 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
8 Name:           beecrypt
9 Version:        3.0.0
10 Release:        0.%{snap}.1
11 Epoch:          2
12 License:        LGPL
13 Group:          Libraries
14 #Source0:       http://dl.sf.net/%{name}/%{name}-%{version}pre.%{snap}.tar.gz
15 Source0:        ftp://distfiles.pld-linux.org/src/%{name}-%{version}pre.%{snap}.tar.gz
16 # Source0-md5:  c8659b0005a19606a7e182ff09eb10c2
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-python.patch
19 URL:            http://sourceforge.net/projects/beecrypt/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  libtool
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 BeeCrypt is an open source cryptography library that contains highly
27 optimized C and assembler implementations of many well-known
28 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
29 ElGamal.
30
31 %description -l pl
32 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
33 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
34 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
35
36 %package devel
37 Summary:        The BeeCrypt Cryptography Library - development files
38 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}
41
42 %description devel
43 The BeeCrypt Cryptography Library - development files.
44
45 %description devel -l pl
46 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
47
48 %package static
49 Summary:        The BeeCrypt Cryptography Library - static library
50 Summary(pl):    Biblioteka statyczna BeeCrypt
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}
53
54 %description static
55 The BeeCrypt Cryptography Library - static library.
56
57 %description static -l pl
58 Biblioteka statyczna BeeCrypt.
59
60 %package -n python-beecrypt
61 Summary:        Python interface to BeeCrypt library
62 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
63 Group:          Development/Languages/Python
64 Requires:       %{name} = %{version}
65 %pyrequires_eq  python
66
67 %description -n python-beecrypt
68 The python-beecrypt package contains a module which permits applications
69 written in the Python programming language to use the interface
70 supplied by BeeCrypt libraries.
71
72 %description -n python-beecrypt -l pl
73 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
74 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
75
76 %prep
77 %setup  -q -n %{name}-%{version}pre
78 %patch0 -p1
79 %patch1 -p1
80
81 %build
82 rm -f missing
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --with%{?!_with_javaglue:out}-javaglue \
90         --with-cpu=%{_target_cpu} \
91         --with-arch=%{_target_cpu}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
108 %attr(755,root,root) %{_libdir}/lib*.so.*.*
109
110 %files devel
111 %defattr(644,root,root,755)
112 %{_libdir}/lib*.so
113 %{_libdir}/lib*.la
114 %{_includedir}/*
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/lib*.a
119
120 %files -n python-beecrypt
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.036348 seconds and 4 git commands to generate.