]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- no need for /usr/lib64 to be used... it kills the package on alpha
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 # _with_javaglue
4 #
5 %include        /usr/lib/rpm/macros.python
6 Summary:        The BeeCrypt Cryptography Library
7 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
8 Name:           beecrypt
9 Version:        3.0.0
10 Release:        1
11 Epoch:          2
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
15 # Source0-md5:  18f20c22443f85bd4e285925b56198d9
16 Patch0:         %{name}-opt.patch
17 Patch1:         %{name}-python.patch
18 Patch2:         %{name}-lib64_fix.patch
19 URL:            http://sourceforge.net/projects/beecrypt/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  libtool
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 BeeCrypt is an open source cryptography library that contains highly
27 optimized C and assembler implementations of many well-known
28 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
29 ElGamal.
30
31 %description -l pl
32 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
33 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
34 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
35
36 %package devel
37 Summary:        The BeeCrypt Cryptography Library - development files
38 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
39 Group:          Development/Libraries
40 Requires:       %{name} = %{epoch}:%{version}
41
42 %description devel
43 The BeeCrypt Cryptography Library - development files.
44
45 %description devel -l pl
46 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
47
48 %package static
49 Summary:        The BeeCrypt Cryptography Library - static library
50 Summary(pl):    Biblioteka statyczna BeeCrypt
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{epoch}:%{version}
53
54 %description static
55 The BeeCrypt Cryptography Library - static library.
56
57 %description static -l pl
58 Biblioteka statyczna BeeCrypt.
59
60 %package -n python-beecrypt
61 Summary:        Python interface to BeeCrypt library
62 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
63 Group:          Development/Languages/Python
64 Requires:       %{name} = %{epoch}:%{version}
65 %pyrequires_eq  python
66
67 %description -n python-beecrypt
68 The python-beecrypt package contains a module which permits applications
69 written in the Python programming language to use the interface
70 supplied by BeeCrypt libraries.
71
72 %description -n python-beecrypt -l pl
73 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
74 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
75
76 %prep
77 %setup  -q
78 %patch0 -p1
79 %patch1 -p1
80 %patch2
81
82 %build
83 rm -f missing
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --with%{?!_with_javaglue:out}-javaglue \
91         --with-cpu=%{_target_cpu} \
92         --with-arch=%{_target_cpu}
93 %{__make}
94
95 %{__make} -C python
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %{__make} install -C python \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
115 %attr(755,root,root) %{_libdir}/lib*.so.*.*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %{_libdir}/lib*.so
120 %{_libdir}/lib*.la
121 %{_includedir}/*
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/lib*.a
126
127 %files -n python-beecrypt
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.117806 seconds and 4 git commands to generate.