]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
ebef81a4d470e5e01c384cf17bb27a67f181e670
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 #
4 # Conditional build:
5 %bcond_without  javaglue        # build with Java support
6 %bcond_with     javac           # use javac instead of gcj
7 %bcond_without  python          # don't build python module
8 #
9 Summary:        The BeeCrypt Cryptography Library
10 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
11 Name:           beecrypt
12 Version:        4.1.2
13 Release:        1
14 Epoch:          2
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
18 # Source0-md5:  820d26437843ab0a6a8a5151a73a657c
19 Patch0:         %{name}-opt.patch
20 Patch1:         %{name}-lib64_fix.patch
21 Patch2:         %{name}-ac_python.patch
22 URL:            http://sourceforge.net/projects/beecrypt/
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  doxygen
26 %if %{with javaglue} && !%{with javac}
27 BuildRequires:  gcj
28 %endif
29 BuildRequires:  ghostscript
30 BuildRequires:  graphviz
31 %if %{with javaglue} && %{with javac}
32 BuildRequires:  jdk
33 %endif
34 BuildRequires:  libtool
35 BuildRequires:  libgcj-devel
36 %if %{with python}
37 BuildRequires:  python-devel
38 BuildRequires:  python-modules
39 %endif
40 BuildRequires:  tetex-dvips
41 BuildRequires:  tetex-format-latex
42 BuildRequires:  tetex-latex-dstroke
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         specflags_alpha          -mno-explicit-relocs 
46
47 %description
48 BeeCrypt is an open source cryptography library that contains highly
49 optimized C and assembler implementations of many well-known
50 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
51 ElGamal.
52
53 %description -l pl
54 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
55 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
56 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
57
58 %package devel
59 Summary:        The BeeCrypt Cryptography Library - development files
60 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
61 Group:          Development/Libraries
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63
64 %description devel
65 The BeeCrypt Cryptography Library - development files.
66
67 %description devel -l pl
68 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
69
70 %package static
71 Summary:        The BeeCrypt Cryptography Library - static library
72 Summary(pl):    Biblioteka statyczna BeeCrypt
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
75
76 %description static
77 The BeeCrypt Cryptography Library - static library.
78
79 %description static -l pl
80 Biblioteka statyczna BeeCrypt.
81
82 %package doc
83 Summary:        Development documentation for BeeCrypt
84 Summary(pl):    Dokumentacja programisty dla biblioteki BeeCrypt
85 Group:          Documentation
86
87 %description doc
88 Development documentation for BeeCrypt.
89
90 %description doc -l pl
91 Dokumentacja programisty dla biblioteki BeeCrypt.
92
93 %package java
94 Summary:        BeeCrypt Java glue library
95 Summary(pl):    Biblioteka ³±cz±ca BeeCrypt z Jav±
96 Group:          Libraries
97 Requires:       %{name} = %{epoch}:%{version}-%{release}
98
99 %description java
100 BeeCrypt Java glue library.
101
102 %description java -l pl
103 Biblioteka ³±cz±ca BeeCrypt z Jav±.
104
105 %package java-devel
106 Summary:        Development files for BeeCrypt Java glue library
107 Summary(pl):    Pliki programistyczne biblioteki ³±cz±cej Beecrypt z Jav±
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
110 Requires:       %{name}-java = %{epoch}:%{version}-%{release}
111
112 %description java-devel
113 Development files for BeeCrypt Java glue library.
114
115 %description java-devel -l pl
116 Pliki programistyczne biblioteki ³±cz±cej Beecrypt z Jav±.
117
118 %package java-static
119 Summary:        BeeCrypt Java glue static library
120 Summary(pl):    Statyczna biblioteka ³±cz±ca BeeCrypt z Jav±
121 Group:          Development/Libraries
122 Requires:       %{name}-java-devel = %{epoch}:%{version}-%{release}
123
124 %description java-static
125 BeeCrypt Java glue static library.
126
127 %description java-static -l pl
128 Statyczna biblioteka ³±cz±ca BeeCrypt z Jav±.
129
130 %package -n python-beecrypt
131 Summary:        Python interface to BeeCrypt library
132 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
133 Group:          Development/Languages/Python
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135 %pyrequires_eq  python-libs
136
137 %description -n python-beecrypt
138 The python-beecrypt package contains a module which permits applications
139 written in the Python programming language to use the interface
140 supplied by BeeCrypt libraries.
141
142 %description -n python-beecrypt -l pl
143 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
144 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
145
146 %prep
147 %setup -q
148 %patch0 -p1
149 %patch1 -p1
150 %patch2 -p1
151
152 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
153 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
154 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
155 # only html docs
156 %{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
157
158 %build
159 %{__libtoolize}
160 %{__aclocal}
161 %{__autoconf}
162 %{__autoheader}
163 %{__automake}
164 %configure \
165         %{?with_javac:ac_cv_have_gcj=no} \
166         --without-cplusplus \
167         --with%{!?with_javaglue:out}-javaglue \
168         --with-cpu=%{_target_cpu} \
169         --with-arch=%{_target_cpu} \
170         --with-pic \
171         --with%{!?with_python:out}-python
172 %{__make}
173
174 %if %{with python}
175 %{__make} -C python
176 %endif
177
178 doxygen
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} install \
184         DESTDIR=$RPM_BUILD_ROOT
185
186 %if %{with python}
187 %{__make} install -C python \
188         DESTDIR=$RPM_BUILD_ROOT
189 %endif
190
191 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post   -p /sbin/ldconfig
197 %postun -p /sbin/ldconfig
198
199 %post   java -p /sbin/ldconfig
200 %postun java -p /sbin/ldconfig
201
202 %files
203 %defattr(644,root,root,755)
204 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
205 %attr(755,root,root) %{_libdir}/libbeecrypt.so.*.*.*
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libbeecrypt.so
210 %{_libdir}/libbeecrypt.la
211 %{_includedir}/beecrypt
212
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libbeecrypt.a
216
217 %if %{with javaglue}
218 %files java
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libbeecrypt_java.so.*.*.*
221
222 %files java-devel
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libbeecrypt_java.so
225 %{_libdir}/libbeecrypt_java.la
226
227 %files java-static
228 %defattr(644,root,root,755)
229 %{_libdir}/libbeecrypt_java.a
230 %endif
231
232 %files doc
233 %defattr(644,root,root,755)
234 %doc docs/html/*
235
236 %if %{with python}
237 %files -n python-beecrypt
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{py_sitedir}/*.so
240 %endif
This page took 0.107342 seconds and 3 git commands to generate.