]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- updated for final 3.0.0
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 # _with_javaglue
4 #
5 %include        /usr/lib/rpm/macros.python
6 %define         snap 20030610
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        3.0.0
11 Release:        0.%{snap}.1
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 #Source0:       http://dl.sf.net/%{name}/%{name}-%{version}pre.%{snap}.tar.gz
16 Source0:        ftp://distfiles.pld-linux.org/src/%{name}-%{version}pre.%{snap}.tar.gz
17 # Source0-md5:  c8659b0005a19606a7e182ff09eb10c2
18 Patch0:         %{name}-opt.patch
19 Patch1:         %{name}-python.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 BeeCrypt is an open source cryptography library that contains highly
28 optimized C and assembler implementations of many well-known
29 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
30 ElGamal.
31
32 %description -l pl
33 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
34 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
35 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
36
37 %package devel
38 Summary:        The BeeCrypt Cryptography Library - development files
39 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}
42
43 %description devel
44 The BeeCrypt Cryptography Library - development files.
45
46 %description devel -l pl
47 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
48
49 %package static
50 Summary:        The BeeCrypt Cryptography Library - static library
51 Summary(pl):    Biblioteka statyczna BeeCrypt
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}
54
55 %description static
56 The BeeCrypt Cryptography Library - static library.
57
58 %description static -l pl
59 Biblioteka statyczna BeeCrypt.
60
61 %package -n python-beecrypt
62 Summary:        Python interface to BeeCrypt library
63 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
64 Group:          Development/Languages/Python
65 Requires:       %{name} = %{version}
66 %pyrequires_eq  python
67
68 %description -n python-beecrypt
69 The python-beecrypt package contains a module which permits applications
70 written in the Python programming language to use the interface
71 supplied by BeeCrypt libraries.
72
73 %description -n python-beecrypt -l pl
74 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
75 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
76
77 %prep
78 %setup  -q -n %{name}-%{version}pre
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 rm -f missing
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --with%{?!_with_javaglue:out}-javaglue \
91         --with-cpu=%{_target_cpu} \
92         --with-arch=%{_target_cpu}
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install DESTDIR=$RPM_BUILD_ROOT
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
109 %attr(755,root,root) %{_libdir}/lib*.so.*.*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %{_libdir}/lib*.so
114 %{_libdir}/lib*.la
115 %{_includedir}/*
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/lib*.a
120
121 %files -n python-beecrypt
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.066485 seconds and 3 git commands to generate.