]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- don't move libraries to proper libdir but make them compile and install with proper...
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 %bcond_with     javaglue        # build with Java support
4 %bcond_without  python          # don't build python module
5 #
6 %include        /usr/lib/rpm/macros.python
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        3.1.0
11 Release:        2
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  1472cada46e2ab9f532f984de9740386
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-python.patch
19 Patch2:         %{name}-lib64_fix.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define specflags_alpha         "-mno-explicit-relocs"
27
28 %description
29 BeeCrypt is an open source cryptography library that contains highly
30 optimized C and assembler implementations of many well-known
31 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
32 ElGamal.
33
34 %description -l pl
35 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
36 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
37 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
38
39 %package devel
40 Summary:        The BeeCrypt Cryptography Library - development files
41 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
42 Group:          Development/Libraries
43 Requires:       %{name} = %{epoch}:%{version}
44
45 %description devel
46 The BeeCrypt Cryptography Library - development files.
47
48 %description devel -l pl
49 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
50
51 %package static
52 Summary:        The BeeCrypt Cryptography Library - static library
53 Summary(pl):    Biblioteka statyczna BeeCrypt
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{epoch}:%{version}
56
57 %description static
58 The BeeCrypt Cryptography Library - static library.
59
60 %description static -l pl
61 Biblioteka statyczna BeeCrypt.
62
63 %package -n python-beecrypt
64 Summary:        Python interface to BeeCrypt library
65 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
66 Group:          Development/Languages/Python
67 Requires:       %{name} = %{epoch}:%{version}
68 %pyrequires_eq  python
69
70 %description -n python-beecrypt
71 The python-beecrypt package contains a module which permits applications
72 written in the Python programming language to use the interface
73 supplied by BeeCrypt libraries.
74
75 %description -n python-beecrypt -l pl
76 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
77 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
78
79 %prep
80 %setup  -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2
84
85 %build
86 rm -f missing
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         --with%{!?with_javaglue:out}-javaglue \
94         --with-cpu=%{_target_cpu} \
95         --with-arch=%{_target_cpu} \
96         --with-pic \
97         --with%{!?with_python:out}-python
98 %{__make} \
99         libaltdir=%{_libdir} \
100         pylibdir=%{py_libdir}
101
102 %if %{with python}
103 %{__make} -C python \
104         pylibdir=%{py_libdir}
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT%{_libdir}
110
111 %{__make} install \
112         libaltdir=%{_libdir} \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %if %{with python}
116 %{__make} install -C python \
117         libaltdir=%{_libdir} \
118         pylibdir=%{py_libdir} \
119         DESTDIR=$RPM_BUILD_ROOT
120 %endif
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
131 %attr(755,root,root) %{_libdir}/lib*.so.*.*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/lib*.so
136 %{_libdir}/lib*.la
137 %{_includedir}/*
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/lib*.a
142
143 %if %{with python}
144 %files -n python-beecrypt
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{py_sitedir}/*.so
147 %endif
This page took 0.060882 seconds and 3 git commands to generate.