]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- missing BR
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 # Conditional build:
4 %bcond_with     javaglue        # build with Java support
5 %bcond_without  python          # don't build python module
6 #
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        4.1.1
11 Release:        1
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  b412cb2a692f689bfcd43f29733c3039
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-lib64_fix.patch
19 Patch2:         %{name}-ac_python.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  doxygen
24 BuildRequires:  ghostscript
25 BuildRequires:  graphviz
26 BuildRequires:  libtool
27 BuildRequires:  libgcj-devel
28 %if %{with python}
29 BuildRequires:  python-devel
30 BuildRequires:  python-modules
31 %endif
32 BuildRequires:  tetex-dvips
33 BuildRequires:  tetex-format-latex
34 BuildRequires:  tetex-latex-dstroke
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         specflags_alpha          -mno-explicit-relocs 
38
39 %description
40 BeeCrypt is an open source cryptography library that contains highly
41 optimized C and assembler implementations of many well-known
42 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
43 ElGamal.
44
45 %description -l pl
46 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
47 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
48 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
49
50 %package devel
51 Summary:        The BeeCrypt Cryptography Library - development files
52 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
53 Group:          Development/Libraries
54 Requires:       %{name} = %{epoch}:%{version}-%{release}
55
56 %description devel
57 The BeeCrypt Cryptography Library - development files.
58
59 %description devel -l pl
60 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
61
62 %package static
63 Summary:        The BeeCrypt Cryptography Library - static library
64 Summary(pl):    Biblioteka statyczna BeeCrypt
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
67
68 %description static
69 The BeeCrypt Cryptography Library - static library.
70
71 %description static -l pl
72 Biblioteka statyczna BeeCrypt.
73
74 %package doc
75 Summary:        Development documentation for BeeCrypt
76 Summary(pl):    Dokumentacja programisty dla biblioteki BeeCrypt
77 Group:          Documentation
78
79 %description doc
80 Development documentation for BeeCrypt.
81
82 %description doc -l pl
83 Dokumentacja programisty dla biblioteki BeeCrypt.
84
85 %package -n python-beecrypt
86 Summary:        Python interface to BeeCrypt library
87 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
88 Group:          Development/Languages/Python
89 Requires:       %{name} = %{epoch}:%{version}-%{release}
90 %pyrequires_eq  python
91
92 %description -n python-beecrypt
93 The python-beecrypt package contains a module which permits applications
94 written in the Python programming language to use the interface
95 supplied by BeeCrypt libraries.
96
97 %description -n python-beecrypt -l pl
98 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
99 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106
107 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
108 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
109 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
110 # only html docs
111 %{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         --without-cplusplus \
121         --with%{!?with_javaglue:out}-javaglue \
122         --with-cpu=%{_target_cpu} \
123         --with-arch=%{_target_cpu} \
124         --with-pic \
125         --with%{!?with_python:out}-python
126 %{__make}
127
128 %if %{with python}
129 %{__make} -C python
130 %endif
131
132 doxygen
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %if %{with python}
141 %{__make} install -C python \
142         DESTDIR=$RPM_BUILD_ROOT
143 %endif
144
145 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/lib*.so
161 %{_libdir}/lib*.la
162 %{_includedir}/*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/lib*.a
167
168 %files doc
169 %defattr(644,root,root,755)
170 %doc docs/html/*
171
172 %if %{with python}
173 %files -n python-beecrypt
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{py_sitedir}/*.so
176 %endif
This page took 0.062986 seconds and 3 git commands to generate.