]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- final 3.0.0, updated python patch
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 # _with_javaglue
4 #
5 %include        /usr/lib/rpm/macros.python
6 Summary:        The BeeCrypt Cryptography Library
7 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
8 Name:           beecrypt
9 Version:        3.0.0
10 Release:        1
11 Epoch:          2
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
15 # Source0-md5:  18f20c22443f85bd4e285925b56198d9
16 Patch0:         %{name}-opt.patch
17 Patch1:         %{name}-python.patch
18 URL:            http://sourceforge.net/projects/beecrypt/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 BeeCrypt is an open source cryptography library that contains highly
26 optimized C and assembler implementations of many well-known
27 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
28 ElGamal.
29
30 %description -l pl
31 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
32 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
33 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
34
35 %package devel
36 Summary:        The BeeCrypt Cryptography Library - development files
37 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}
40
41 %description devel
42 The BeeCrypt Cryptography Library - development files.
43
44 %description devel -l pl
45 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
46
47 %package static
48 Summary:        The BeeCrypt Cryptography Library - static library
49 Summary(pl):    Biblioteka statyczna BeeCrypt
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}
52
53 %description static
54 The BeeCrypt Cryptography Library - static library.
55
56 %description static -l pl
57 Biblioteka statyczna BeeCrypt.
58
59 %package -n python-beecrypt
60 Summary:        Python interface to BeeCrypt library
61 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
62 Group:          Development/Languages/Python
63 Requires:       %{name} = %{version}
64 %pyrequires_eq  python
65
66 %description -n python-beecrypt
67 The python-beecrypt package contains a module which permits applications
68 written in the Python programming language to use the interface
69 supplied by BeeCrypt libraries.
70
71 %description -n python-beecrypt -l pl
72 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
73 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
74
75 %prep
76 %setup  -q
77 %patch0 -p1
78 %patch1 -p1
79
80 %build
81 rm -f missing
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --with%{?!_with_javaglue:out}-javaglue \
89         --with-cpu=%{_target_cpu} \
90         --with-arch=%{_target_cpu}
91 %{__make}
92
93 %{__make} -C python
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %{__make} install -C python \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
113 %attr(755,root,root) %{_libdir}/lib*.so.*.*
114
115 %files devel
116 %defattr(644,root,root,755)
117 %{_libdir}/lib*.so
118 %{_libdir}/lib*.la
119 %{_includedir}/*
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/lib*.a
124
125 %files -n python-beecrypt
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.064912 seconds and 3 git commands to generate.