]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- -devel package requires DLLs in main package
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.7
25 Release:        2
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  d4c8e93db23c9b7d06104ce97a182502
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-kill_exec_a.patch
33 Patch3:         %{name}-configure.patch
34 URL:            http://beaglewiki.org/Main_Page
35 BuildRequires:  autoconf >= 2.52
36 BuildRequires:  automake
37 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
38 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.3.2}
39 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
40 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
41 #BuildRequires: dotnet-gst-sharp-devel
42 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.8.2
43 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.15.3}
44 BuildRequires:  gtk+2-devel >= 2:2.9.4
45 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
46 BuildRequires:  libexif-devel >= 0.6.13
47 BuildRequires:  librsvg-devel >= 1:2.15.0
48 BuildRequires:  libpng-devel
49 BuildRequires:  libtool
50 BuildRequires:  libxml2-devel >= 1:2.6.26
51 BuildRequires:  mono-csharp >= 1.1.13.8
52 # not used atm
53 #BuildRequires: mozilla-devel
54 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.9.2}
55 BuildRequires:  pkgconfig
56 BuildRequires:  perl-XML-Parser
57 BuildRequires:  python-devel
58 %if %{with sqlite3}
59 BuildRequires:  sqlite3-devel >= 3.3.4
60 %else
61 BuildRequires:  sqlite-devel
62 %endif
63 BuildRequires:  wv-devel >= 1.2.1
64 BuildRequires:  xorg-lib-libXScrnSaver-devel
65 BuildRequires:  zip
66 # GUI BRs
67 %if %{with gui}
68 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.8.2
69 BuildRequires:  gnome-vfs2-devel >= 2.15.2
70 %endif
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       dotnet-gmime-sharp >= 2.1.19
73 %if %{with sqlite3}
74 Requires:       sqlite3
75 %else
76 Requires:       sqlite
77 %endif
78 ExcludeArch:    alpha i386 sparc sparc64
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Beagle is an indexing sub-system and search aggregator built on top of
83 Lucene.Net.
84
85 %description -l pl
86 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
87 bazie Lucene.Net.
88
89 %package libs
90 Summary:        Beagle libraries
91 Summary(pl):    Bibiloteki Beagle
92 Group:          Libraries
93
94 %description libs
95 Beagle libraries.
96
97 %description libs -l pl
98 Bibiloteki Beagle.
99
100 %package devel
101 Summary:        Beagle development files
102 Summary(pl):    Pliki programistyczne Beagle
103 Group:          Development/Libraries
104 Requires:       %{name}-libs = %{version}-%{release}
105 Requires:       %{name} = %{version}-%{release}
106
107 %description devel
108 Beagle development files.
109
110 %description devel -l pl
111 Pliki programistyczne Beagle.
112
113 %package static
114 Summary:        Beagle static libraries
115 Summary(pl):    Statyczne biblioteki Beagle
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118
119 %description static
120 Beagle static libraries.
121
122 %description static -l pl
123 Statyczne biblioteki Beagle.
124
125 %package crawl-system
126 Summary:        Beagle crawl system
127 Summary(pl):    System przeszukuj±cy beagle-crawl
128 Group:          Applications/System
129 Requires:       crondaemon
130 Provides:       group(beagleindex)
131 Provides:       user(beagleindex)
132
133 %description crawl-system
134 Beagle crawl system.
135
136 %description crawl-system -l pl
137 System przeszukuj±cy beagle-crawl.
138
139 %package evolution
140 Summary:        Beagle Evolution backend
141 Summary(pl):    Backend Beagle dla Evolution
142 Group:          X11/Applications/Networking
143 Requires:       %{name} = %{version}-%{release}
144 Requires:       dotnet-evolution-sharp >= 0.11.1
145 Requires:       evolution >= 2.7.3
146
147 %description
148 Beagle Evolution backend.
149
150 %description evolution -l pl
151 Backend Beagle dla Evolution.
152
153 %package -n epiphany-extension-beagle
154 Summary:        Epiphany extension - beagle
155 Summary(pl):    Rozszerzenie dla Epiphany - beagle
156 Group:          X11/Applications/Networking
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       epiphany-extensions >= 2.15.1
159
160 %description -n epiphany-extension-beagle
161 Epiphany extension that allows Beagle to index every page the user
162 views.
163
164 %description -n epiphany-extension-beagle -l pl
165 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
166 odwiedzan± stronê.
167
168 %package -n python-%{name}
169 Summary:        Beagle Python bindings
170 Summary(pl):    Wi±zania jêzyka Python dla Beagle
171 Group:          Libraries/Python
172 Requires:       %{name} = %{version}-%{release}
173 %pyrequires_eq  python-libs
174
175 %description -n python-%{name}
176 Beagle Python bindings.
177
178 %description -n python-%{name} -l pl
179 Wi±zania jêzyka Python dla Beagle.
180
181 %package search-gui
182 Summary:        GNOME based Beagle GUI
183 Summary(pl):    Bazowane na GNOME GUI dla Beagle
184 Group:          Libraries/Python
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       gtk+2 >= 2:2.9.4
187
188 %description search-gui
189 GNOME based Beagle GUI.
190
191 %description search-gui -l pl
192 Bazowane na GNOME GUI dla Beagle.
193
194 %prep
195 %setup -q
196 %patch0 -p1
197 %patch1 -p1
198 %patch2 -p1
199 %patch3 -p1
200
201 %build
202 %{__libtoolize}
203 %{__aclocal}
204 %{__autoconf}
205 %{__automake}
206 %configure \
207         --enable-static \
208         %{?with_apidocs:--enable-gtk-doc} \
209         --with-html-dir=%{_gtkdocdir} \
210         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
211         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
212         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
213
214 %{__make} \
215         MOZILLA_HOME=%{_libdir}/mozilla \
216         pythondir=%{py_sitedir}
217
218 %install
219 rm -rf $RPM_BUILD_ROOT
220 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
221
222 %{__make} install \
223         DESTDIR=$RPM_BUILD_ROOT \
224         pythondir=%{py_sitedir}
225
226 # Kill useless files
227 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
228         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
229
230 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
231 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
232
233 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
234
235 %find_lang %{name}
236
237 %clean
238 rm -rf $RPM_BUILD_ROOT
239
240 %pre crawl-system
241 %groupadd -g 166 -r -f beagleindex
242 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
243
244 %postun crawl-system
245 if [ "$1" = "0" ]; then
246         %userremove beagleindex
247         %groupremove beagleindex
248 fi
249
250 %post   libs -p /sbin/ldconfig
251 %postun libs -p /sbin/ldconfig
252
253 %files -f %{name}.lang
254 %defattr(644,root,root,755)
255 %doc AUTHORS COPYING ChangeLog NEWS README
256 %attr(755,root,root) %{_bindir}/beagle-config
257 %attr(755,root,root) %{_bindir}/beagled
258 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
259 %attr(755,root,root) %{_bindir}/beagle-extract-content
260 %attr(755,root,root) %{_bindir}/beagle-index-info
261 %attr(755,root,root) %{_bindir}/beagle-index-url
262 %attr(755,root,root) %{_bindir}/beagle-info
263 %attr(755,root,root) %{_bindir}/beagle-ping
264 %attr(755,root,root) %{_bindir}/beagle-query
265 %attr(755,root,root) %{_bindir}/beagle-shutdown
266 %attr(755,root,root) %{_bindir}/beagle-status
267 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
268 %attr(755,root,root) %{_libdir}/%{name}/*.exe
269 %dir %{_libdir}/%{name}
270 %dir %{_libdir}/%{name}/Backends
271 %{_libdir}/%{name}/Filters
272 %{_libdir}/%{name}/*.dll*
273 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
274 %{_mandir}/man*/*
275
276 %files libs
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
279
280 %files devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_libdir}/*.so
283 %{_includedir}/libbeagle
284 %{_libdir}/*.la
285 %{?with_apidocs:%{_gtkdocdir}/beagle}
286 %{_pkgconfigdir}/*
287
288 %files static
289 %defattr(644,root,root,755)
290 %{_libdir}/*.a
291
292 %files crawl-system
293 %defattr(644,root,root,755)
294 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
295 %dir %{_sysconfdir}/beagle
296 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
297 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
298 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
299 %attr(755,root,root) %{_sbindir}/*
300
301 %if %{with evolution}
302 %files evolution
303 %defattr(644,root,root,755)
304 %{_libdir}/%{name}/Backends/Evolution*
305 %endif
306
307 %if %{with epiphany}
308 %files -n epiphany-extension-beagle
309 %defattr(644,root,root,755)
310 %doc epiphany-extension/README
311 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
312 %{_libdir}/epiphany/1.8/extensions/*.xml
313 %endif
314
315 %if %{with python}
316 %files -n python-%{name}
317 %defattr(644,root,root,755)
318 %attr(755,root,root) %{py_sitedir}/*.so
319 %endif
320
321 %if %{with gui}
322 %files search-gui
323 %defattr(644,root,root,755)
324 %attr(755,root,root) %{_bindir}/beagle-search
325 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
326 %attr(755,root,root) %{_bindir}/beagle-settings
327 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
328 %{_pixmapsdir}/*.png
329 %{_desktopdir}/*.desktop
330 %endif
This page took 0.184048 seconds and 4 git commands to generate.