]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- updated for 0.2.4
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.3
25 Release:        2
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  4519156a909e8371c59454cab882c616
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-kill_exec_a.patch
33 URL:            http://beaglewiki.org/Main_Page
34 BuildRequires:  autoconf >= 2.52
35 BuildRequires:  automake
36 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
37 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel}
38 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
39 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
40 #BuildRequires: dotnet-gst-sharp-devel
41 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.3.90
42 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
43 BuildRequires:  gtk+2-devel >= 2:2.6.0
44 %{?with_apidocs:BuildRequires:  gtk-doc}
45 BuildRequires:  libexif-devel >= 0.5.0
46 BuildRequires:  librsvg-devel
47 BuildRequires:  libpng-devel
48 BuildRequires:  libtool
49 BuildRequires:  libxml2-devel >= 2.6.19
50 BuildRequires:  mono-csharp >= 1.1.13.4
51 # not used atm
52 #BuildRequires: mozilla-devel
53 %{?with_python:BuildRequires:   python-pygtk-devel}
54 BuildRequires:  pkgconfig
55 BuildRequires:  perl-XML-Parser
56 BuildRequires:  python-devel
57 %if %{with sqlite3}
58 BuildRequires:  sqlite3-devel >= 3.3.4
59 %else
60 BuildRequires:  sqlite-devel
61 %endif
62 BuildRequires:  wv-devel >= 1.2.1
63 BuildRequires:  zip
64 # GUI BRs
65 %if %{with gui}
66 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
67 BuildRequires:  gnome-vfs2-devel
68 BuildRequires:  libgnome-devel
69 %endif
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       dotnet-gmime-sharp >= 2.1.19
72 %if %{with sqlite3}
73 Requires:       sqlite3
74 %else
75 Requires:       sqlite
76 %endif
77 ExcludeArch:    alpha i386 sparc sparc64
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Beagle is an indexing sub-system and search aggregator built on top of
82 Lucene.Net.
83
84 %description -l pl
85 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
86 bazie Lucene.Net.
87
88 %package libs
89 Summary:        Beagle libraries
90 Summary(pl):    Bibiloteki Beagle
91 Group:          Libraries
92
93 %description libs
94 Beagle libraries.
95
96 %description libs -l pl
97 Bibiloteki Beagle.
98
99 %package devel
100 Summary:        Beagle development files
101 Summary(pl):    Pliki programistyczne Beagle
102 Group:          Development/Libraries
103 Requires:       %{name}-libs = %{version}-%{release}
104
105 %description devel
106 Beagle development files.
107
108 %description devel -l pl
109 Pliki programistyczne Beagle.
110
111 %package static
112 Summary:        Beagle static libraries
113 Summary(pl):    Statyczne biblioteki Beagle
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116
117 %description static
118 Beagle static libraries.
119
120 %description static -l pl
121 Statyczne biblioteki Beagle.
122
123 %package crawl-system
124 Summary:        Beagle crawl system
125 Summary(pl):    System przeszukuj±cy beagle-crawl
126 Group:          Applications/System
127 Requires:       crondaemon
128 Provides:       group(beagleindex)
129 Provides:       user(beagleindex)
130
131 %description crawl-system
132 Beagle crawl system.
133
134 %description crawl-system -l pl
135 System przeszukuj±cy beagle-crawl.
136
137 %package evolution
138 Summary:        Beagle Evolution backend
139 Summary(pl):    Backend Beagle dla Evolution
140 Group:          X11/Applications/Networking
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       dotnet-evolution-sharp >= 0.10.2-4
143 Requires:       evolution
144
145 %description
146 Beagle Evolution backend.
147
148 %description evolution -l pl
149 Backend Beagle dla Evolution.
150
151 %package -n epiphany-extension-beagle
152 Summary:        Epiphany extension - beagle
153 Summary(pl):    Rozszerzenie dla Epiphany - beagle
154 Group:          X11/Applications/Networking
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       epiphany-extensions
157
158 %description -n epiphany-extension-beagle
159 Epiphany extension that allows Beagle to index every page the user
160 views.
161
162 %description -n epiphany-extension-beagle -l pl
163 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
164 odwiedzan± stronê.
165
166 %package -n python-%{name}
167 Summary:        Beagle Python bindings
168 Summary(pl):    Wi±zania jêzyka Python dla Beagle
169 Group:          Libraries/Python
170 Requires:       %{name} = %{version}-%{release}
171 %pyrequires_eq  python-libs
172
173 %description -n python-%{name}
174 Beagle Python bindings.
175
176 %description -n python-%{name} -l pl
177 Wi±zania jêzyka Python dla Beagle.
178
179 %package search-gui
180 Summary:        GNOME based Beagle GUI
181 Summary(pl):    Bazowane na GNOME GUI dla Beagle
182 Group:          Libraries/Python
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       gtk+2 >= 2:2.6.0
185
186 %description search-gui
187 GNOME based Beagle GUI.
188
189 %description search-gui -l pl
190 Bazowane na GNOME GUI dla Beagle.
191
192 %prep
193 %setup -q
194 %patch0 -p1
195 %patch1 -p1
196 %patch2 -p1
197
198 %build
199 %{__libtoolize}
200 %{__aclocal}
201 %{__autoconf}
202 %{__automake}
203 %configure \
204         --enable-static \
205         %{?with_apidocs:--enable-gtk-doc} \
206         --with-html-dir=%{_gtkdocdir} \
207         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
208         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
209         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
210
211 %{__make} \
212         MOZILLA_HOME=%{_libdir}/mozilla \
213         pythondir=%{py_sitedir}
214
215 %install
216 rm -rf $RPM_BUILD_ROOT
217 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
218
219 %{__make} install \
220         DESTDIR=$RPM_BUILD_ROOT \
221         pythondir=%{py_sitedir}
222
223 # Kill useless files
224 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
225         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
226
227 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
228 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
229
230 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
231
232 %find_lang %{name}
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %pre crawl-system
238 %groupadd -g 166 -r -f beagleindex
239 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
240
241 %postun crawl-system
242 if [ "$1" = "0" ]; then
243         %userremove beagleindex
244         %groupremove beagleindex
245 fi
246
247 %post   libs -p /sbin/ldconfig
248 %postun libs -p /sbin/ldconfig
249
250 %files -f %{name}.lang
251 %defattr(644,root,root,755)
252 %doc AUTHORS COPYING ChangeLog NEWS README
253 %attr(755,root,root) %{_bindir}/beagle-config
254 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
255 %attr(755,root,root) %{_bindir}/beagle-index-info
256 %attr(755,root,root) %{_bindir}/beagle-index-url
257 %attr(755,root,root) %{_bindir}/beagle-info
258 %attr(755,root,root) %{_bindir}/beagle-ping
259 %attr(755,root,root) %{_bindir}/beagle-query
260 %attr(755,root,root) %{_bindir}/beagle-shutdown
261 %attr(755,root,root) %{_bindir}/beagle-status
262 %attr(755,root,root) %{_bindir}/beagled
263 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
264 %attr(755,root,root) %{_libdir}/%{name}/*.exe
265 %dir %{_libdir}/%{name}
266 %dir %{_libdir}/%{name}/Backends
267 %{_libdir}/%{name}/Filters
268 %{_libdir}/%{name}/*.dll*
269 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
270 %{_mandir}/man*/*
271
272 %files libs
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
275
276 %files devel
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_libdir}/*.so
279 %{_includedir}/libbeagle
280 %{_libdir}/*.la
281 %{?with_apidocs:%{_gtkdocdir}/beagle}
282 %{_pkgconfigdir}/*
283
284 %files static
285 %defattr(644,root,root,755)
286 %{_libdir}/*.a
287
288 %files crawl-system
289 %defattr(644,root,root,755)
290 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
291 %dir %{_sysconfdir}/beagle
292 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
293 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
294 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
295 %attr(755,root,root) %{_sbindir}/*
296 %attr(755,root,root) %{_libdir}/beagle-crawl-system
297
298 %if %{with evolution}
299 %files evolution
300 %defattr(644,root,root,755)
301 %{_libdir}/%{name}/Backends/Evolution*
302 %endif
303
304 %if %{with epiphany}
305 %files -n epiphany-extension-beagle
306 %defattr(644,root,root,755)
307 %doc epiphany-extension/README
308 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
309 %{_libdir}/epiphany/1.8/extensions/*.xml
310 %endif
311
312 %if %{with python}
313 %files -n python-%{name}
314 %defattr(644,root,root,755)
315 %attr(755,root,root) %{py_sitedir}/*.so
316 %endif
317
318 %if %{with gui}
319 %files search-gui
320 %defattr(644,root,root,755)
321 %attr(755,root,root) %{_bindir}/beagle-search
322 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
323 %attr(755,root,root) %{_bindir}/beagle-settings
324 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
325 %{_pixmapsdir}/*.png
326 %{_desktopdir}/*.desktop
327 %endif
This page took 0.092597 seconds and 3 git commands to generate.