]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- release 7
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - add qyoto based settings (requires new packages)
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_without  apidocs         # don't build API documentation
10 %bcond_with     avahi           # enable Avahi support
11 %bcond_without  evolution       # don't include evolution support
12 %bcond_without  galago          # build without galago support
13 %bcond_without  gsf             # build without libgsf support
14 %bcond_without  gui             # don't build GNOME based GUI
15 %bcond_without  epiphany        # don't build epiphany extension
16 %bcond_without  thunderbird     # use Thunderbird backend
17 #
18 %if !%{with gui}
19 %undefine       with_evolution
20 %endif
21 #
22 Summary:        Beagle - An indexing subsystem
23 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
24 Name:           beagle
25 Version:        0.3.8
26 Release:        7
27 License:        Various
28 Group:          Libraries
29 Source0:        http://ftp.gnome.org/pub/GNOME/sources/beagle/0.3/%{name}-%{version}.tar.bz2
30 # Source0-md5:  fcafad26efa65a3bf06a019268ae6230
31 Patch0:         %{name}-desktop.patch
32 Patch1:         %{name}-crawl.patch
33 Patch2:         %{name}-configure.patch
34 Patch3:         %{name}-use-xdg-open.patch
35 Patch4:         %{name}-epiphany.patch
36 Patch5:         %{name}-gmime-2.4.patch
37 URL:            http://beagle-project.org/Main_Page
38 BuildRequires:  autoconf >= 2.52
39 BuildRequires:  automake
40 BuildRequires:  chmlib-devel
41 %{?with_avahi:BuildRequires:    dotnet-avahi-devel >= 0.6.10}
42 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.13.3}
43 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
44 BuildRequires:  dotnet-gmime-sharp-devel >= 2.3.5
45 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
46 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
47 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3.0
48 BuildRequires:  dotnet-ndesk-dbus-sharp-devel >= 0.6.0
49 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.22.0}
50 BuildRequires:  gettext-devel
51 BuildRequires:  gtk+2-devel >= 2:2.10.10
52 BuildRequires:  intltool >= 0.40.0
53 BuildRequires:  libtool
54 BuildRequires:  mono-csharp >= 1.2.4
55 BuildRequires:  mono-devel >= 1.2.4
56 BuildRequires:  pkgconfig
57 BuildRequires:  sqlite3-devel >= 3.3.9
58 BuildRequires:  taglib-sharp-devel
59 BuildRequires:  wv-devel >= 1.2.4
60 BuildRequires:  xorg-lib-libXScrnSaver-devel
61 BuildRequires:  zip
62 # GUI BRs
63 %if %{with gui}
64 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
65 BuildRequires:  librsvg-devel >= 1:2.16.1
66 %endif
67 Requires:       dotnet-gmime-sharp >= 2.3.5
68 Requires:       dotnet-gsf-sharp
69 Requires:       shared-mime-info
70 Requires:       sqlite3
71 Requires:       xdg-utils
72 Obsoletes:      beagle-libs
73 Obsoletes:      beagle-static
74 # sr@Latn vs. sr@latin
75 Conflicts:      glibc-misc < 6:2.7
76 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
77 ExcludeArch:    i386
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Beagle is an indexing sub-system and search aggregator built on top of
82 Lucene.Net.
83
84 %description -l pl.UTF-8
85 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
86 bazie Lucene.Net.
87
88 %package debug
89 Summary:        Debug files for the Mono part of Beagle
90 Summary(pl.UTF-8):      Pliki debugujące dla części Mono Beagle'a
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93
94 %description debug
95 Debug files for the Mono part of Beagle.
96
97 %description -l pl.UTF-8
98 Pliki debugujące dla części Mono Beagle'a.
99
100 %package devel
101 Summary:        Beagle development files
102 Summary(pl.UTF-8):      Pliki programistyczne Beagle
103 Group:          Development/Libraries
104 Requires:       %{name} = %{version}-%{release}
105
106 %description devel
107 Beagle development files.
108
109 %description devel -l pl.UTF-8
110 Pliki programistyczne Beagle.
111
112 %package apidocs
113 Summary:        libbeagle API documentation
114 Summary(pl.UTF-8):      Dokumentacja API libbeagle
115 Group:          Documentation
116 Requires:       gtk-doc-common
117
118 %description apidocs
119 libbeagle API documentation.
120
121 %description apidocs -l pl.UTF-8
122 Dokumentacja API libbeagle.
123
124 %package crawl-system
125 Summary:        Beagle crawl system
126 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
127 Group:          Applications/System
128 Requires:       crondaemon
129 Provides:       group(beagleindex)
130 Provides:       user(beagleindex)
131
132 %description crawl-system
133 Beagle crawl system.
134
135 %description crawl-system -l pl.UTF-8
136 System przeszukujący beagle-crawl.
137
138 %package search-gui
139 Summary:        GNOME based Beagle GUI
140 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
141 Group:          Libraries/Python
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       gtk+2 >= 2:2.10.10
144
145 %description search-gui
146 GNOME based Beagle GUI.
147
148 %description search-gui -l pl.UTF-8
149 Oparty na GNOME graficzny interfejs dla Beagle.
150
151 %package startup
152 Summary:        Automatic startup integration for Beagle
153 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
154 Group:          X11/Applications
155 Requires:       %{name} = %{version}-%{release}
156 Obsoletes:      beagle-gnome
157
158 %description startup
159 Automatic session startup integration for Beagle.
160
161 %description startup -l pl.UTF-8
162 Integracja funkcji automatycznego startu Beagle.
163
164 %package webinterface
165 Summary:        A web interface for Beagle
166 Summary(pl.UTF-8):      Interfejs sieciowy dla Beagle
167 Group:          Applications
168 Requires:       %{name} = %{version}-%{release}
169
170 %description webinterface
171 An AJAX interface that allows users to search for data through their
172 web browser.
173
174 %description webinterface -l pl.UTF-8
175 AJAX-owy interfejs pozwalający użytkownikom wyszukiwać dane za pomocą
176 przeglądarki internetowej.
177
178 %package evolution
179 Summary:        Beagle Evolution backend
180 Summary(pl.UTF-8):      Backend Beagle dla Evolution
181 Group:          X11/Applications/Networking
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       dotnet-evolution-sharp >= 0.11.1
184 Requires:       evolution >= 2.10.0
185
186 %description evolution
187 Beagle Evolution backend.
188
189 %description evolution -l pl.UTF-8
190 Backend Beagle dla Evolution.
191
192 %package icedove
193 Summary:        Beagle Icedove backend
194 Summary(pl.UTF-8):      Backend Beagle dla Icedove
195 Group:          X11/Applications/Networking
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       icedove
198 Provides:       beagle-thunderbird
199 Obsoletes:      beagle-thunderbird
200
201 %description icedove
202 Beagle Icedove backend.
203
204 %description icedove -l pl.UTF-8
205 Backend Beagle dla Icedove.
206
207 %package -n epiphany-extension-beagle
208 Summary:        Epiphany extension - beagle
209 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
210 Group:          X11/Applications/Networking
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       epiphany-extensions >= 2.22.0
213
214 %description -n epiphany-extension-beagle
215 Epiphany extension that allows Beagle to index every page the user
216 views.
217
218 %description -n epiphany-extension-beagle -l pl.UTF-8
219 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
220 odwiedzaną stronę.
221
222 %package -n iceweasel-extension-beagle
223 Summary:        Iceweasel extension - beagle
224 Summary(pl.UTF-8):      Rozszerzenie dla przeglądarki Iceweasel - beagle
225 Group:          X11/Applications/Networking
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       iceweasel
228 Provides:       mozilla-firefox-extension-beagle
229 Obsoletes:      mozilla-firefox-extension-beagle
230
231 %description -n iceweasel-extension-beagle
232 Iceweasel extension that allows Beagle to index every page the user
233 views.
234
235 %description -n iceweasel-extension-beagle -l pl.UTF-8
236 Rozszerzenie dla przeglądarki Iceweasel sprawiające, że Beagle
237 indeksuje każdą odwiedzaną stronę.
238
239 %prep
240 %setup -q
241 %patch0 -p1
242 %patch1 -p1
243 %patch2 -p1
244 %patch3 -p1
245 %patch4 -p1
246 %patch5 -p1
247
248 %build
249 %{__intltoolize}
250 %{__libtoolize}
251 %{__aclocal}
252 %{__autoconf}
253 %{__autoheader}
254 %{__automake}
255 %configure \
256         --disable-static \
257         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
258         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution \
259         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
260         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird \
261         --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi
262
263 %{__make}
264
265 %install
266 rm -rf $RPM_BUILD_ROOT
267 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
268
269 %{__make} install \
270         DESTDIR=$RPM_BUILD_ROOT \
271         monodocdir=%{_libdir}/monodoc/sources
272
273 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*glue.la
274
275 dest=$RPM_BUILD_ROOT%{_datadir}/iceweasel/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
276 install -d $dest $dest/chrome
277 install firefox-extension/{chrome.manifest,install.rdf} $dest
278 cp -r firefox-extension/chrome/* $dest/chrome
279
280 %if %{with thunderbird}
281 tdest=$RPM_BUILD_ROOT%{_libdir}/icedove/extensions/\{b656ef18-fd76-45e6-95cc-8043f26361e7\}
282 install -d $tdest
283 install thunderbird-extension/{chrome.manifest,install.rdf} $tdest
284 cp -r thunderbird-extension/{chrome,components,defaults} $tdest
285 %endif
286
287 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
288         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
289 %find_lang %{name}
290
291 %clean
292 rm -rf $RPM_BUILD_ROOT
293
294 %pre crawl-system
295 %groupadd -g 166 -r -f beagleindex
296 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
297
298 %postun crawl-system
299 if [ "$1" = "0" ]; then
300         %userremove beagleindex
301         %groupremove beagleindex
302 fi
303
304 %files -f %{name}.lang
305 %defattr(644,root,root,755)
306 %doc AUTHORS COPYING ChangeLog NEWS README
307 %attr(755,root,root) %{_bindir}/beagle-config
308 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
309 %attr(755,root,root) %{_bindir}/beagle-extract-content
310 %attr(755,root,root) %{_bindir}/beagle-index-info
311 %attr(755,root,root) %{_bindir}/beagle-info
312 %attr(755,root,root) %{_bindir}/beagle-ping
313 %attr(755,root,root) %{_bindir}/beagle-query
314 %attr(755,root,root) %{_bindir}/beagle-shutdown
315 %attr(755,root,root) %{_bindir}/beagle-static-query
316 %attr(755,root,root) %{_bindir}/beagle-status
317 %attr(755,root,root) %{_bindir}/beagled
318 %attr(755,root,root) %{_bindir}/blocate
319 %attr(755,root,root) %{_libdir}/%{name}/*.exe
320 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
321 %dir %{_sysconfdir}/beagle
322 %dir %{_sysconfdir}/beagle/config-files
323 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/blocate.conf
324 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/query-mapping.xml
325 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/BeagleSearch.xml
326 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Daemon.xml
327 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/FilesQueryable.xml
328 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/GoogleBackends.xml
329 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Networking.xml
330 %dir %{_libdir}/%{name}
331 %dir %{_libdir}/%{name}/Backends
332 %dir %{_libdir}/%{name}/Filters
333 %{_libdir}/%{name}/*.dll
334 %{_libdir}/%{name}/*.dll.config
335 %{_libdir}/%{name}/Backends/GoogleBackends*.dll
336 %{_libdir}/%{name}/Filters/*.dll
337 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
338 %{_mandir}/man1/beagle-config.1*
339 %{_mandir}/man1/beagle-info.1*
340 %{_mandir}/man1/beagle-ping.1*
341 %{_mandir}/man1/beagle-query.1*
342 %{_mandir}/man1/beagle-search.1*
343 %{_mandir}/man1/beagle-shutdown.1*
344 %{_mandir}/man1/beagle-status.1*
345 %{_mandir}/man1/beagled.1*
346 %{_mandir}/man8/beagle-doc-extractor.8*
347 %{_mandir}/man8/beagle-index-info.8*
348
349 %files debug
350 %defattr(644,root,root,755)
351 %{_libdir}/%{name}/Backends/*.mdb
352 %{_libdir}/%{name}/Filters/*.mdb
353 %{_libdir}/%{name}/*.mdb
354
355 %files devel
356 %defattr(644,root,root,755)
357 %{_pkgconfigdir}/beagle-0.0.pc
358 %{_pkgconfigdir}/beagle-ui-0.0.pc
359 %{_pkgconfigdir}/beagle-daemon.pc
360
361 %if %{with apidocs}
362 %files apidocs
363 %defattr(644,root,root,755)
364 %{_libdir}/monodoc/sources/*
365 %endif
366
367 %files crawl-system
368 %defattr(644,root,root,755)
369 %dir %{_sysconfdir}/beagle/crawl-rules
370 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-applications
371 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-documentation
372 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-executables
373 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-manpages
374 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-monodoc
375 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-windows
376 # XXX: samples not here
377 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/external-filters.xml.sample
378 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/beagle-crawl-system
379 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
380 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
381 %attr(755,root,root) %{_sbindir}/beagle-build-index
382 %attr(755,root,root) %{_sbindir}/beagle-dump-index
383 %attr(755,root,root) %{_sbindir}/beagle-manage-index
384 %attr(755,root,root) %{_sbindir}/beagle-master-delete-button
385 %attr(755,root,root) %{_sbindir}/beagle-removable-index
386 %{_mandir}/man8/beagle-dump-index.8*
387 %{_mandir}/man8/beagle-build-index.8*
388 %{_mandir}/man8/beagle-extract-content.8*
389 %{_mandir}/man8/beagle-manage-index.8*
390
391 %if %{with gui}
392 %files search-gui
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
395 %attr(755,root,root) %{_bindir}/beagle-search
396 %attr(755,root,root) %{_bindir}/beagle-settings
397 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
398 %attr(755,root,root) %{_libdir}/%{name}/keygrabber.py
399 %{_mandir}/man1/beagle-settings.1*
400 %{_mandir}/man8/beagle-imlogviewer.8*
401 %{_desktopdir}/*.desktop
402 %endif
403
404 %files startup
405 %defattr(644,root,root,755)
406 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
407 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
408
409 %files webinterface
410 %defattr(644,root,root,755)
411 %{_datadir}/%{name}
412
413 %if %{with evolution}
414 %files evolution
415 %defattr(644,root,root,755)
416 %{_libdir}/%{name}/Backends/Evolution*.dll
417 %endif
418
419 %if %{with thunderbird}
420 %files icedove
421 %defattr(644,root,root,755)
422 %{_libdir}/%{name}/Backends/Thunderbird*.dll
423 %{_libdir}/icedove/extensions/{b656ef18-fd76-45e6-95cc-8043f26361e7}
424 %endif
425
426 %if %{with epiphany}
427 %files -n epiphany-extension-beagle
428 %defattr(644,root,root,755)
429 %attr(755,root,root) %{_libdir}/epiphany/2.24/extensions/beagle.py
430 %{_libdir}/epiphany/2.24/extensions/*.ephy-extension
431 %endif
432
433 %files -n iceweasel-extension-beagle
434 %defattr(644,root,root,755)
435 %{_datadir}/iceweasel/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
This page took 0.100595 seconds and 3 git commands to generate.