]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- fix duplicate %descriptions
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - mozilla extension?
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_without  apidocs         # don't build API documentation
10 %bcond_without  evolution       # don't include evolution support
11 %bcond_without  galago          # build without galago support
12 %bcond_without  gsf             # build without libgsf support
13 %bcond_without  gui             # don't build GNOME based GUI
14 %bcond_without  python          # don't build python libraries
15 %bcond_without  epiphany        # don't build epiphany extension
16 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
17 #
18 %if !%{with gui}
19 %undefine       with_evolution
20 %endif
21 #
22 Summary:        Beagle - An indexing subsystem
23 Summary(pl):    Beagle - podsystem indeksuj±cy
24 Name:           beagle
25 Version:        0.2.14
26 Release:        1
27 License:        Various
28 Group:          Libraries
29 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
30 # Source0-md5:  c3eeccdafc030a7d283bf85b75f5c0bb
31 Patch0:         %{name}-desktop.patch
32 Patch1:         %{name}-crawl.patch
33 Patch2:         %{name}-kill_exec_a.patch
34 Patch3:         %{name}-configure.patch
35 URL:            http://beaglewiki.org/Main_Page
36 BuildRequires:  autoconf >= 2.52
37 BuildRequires:  automake
38 BuildRequires:  chmlib-devel
39 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
40 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
41 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
42 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
43 #BuildRequires: dotnet-gst-sharp-devel
44 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
45 %if %{with epiphany} 
46 BuildRequires:  epiphany-devel >= 2.16.1
47 %endif
48 BuildRequires:  gtk+2-devel >= 2:2.10.6
49 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
50 BuildRequires:  libexif-devel >= 0.6.13
51 BuildRequires:  librsvg-devel >= 1:2.16.0
52 BuildRequires:  libpng-devel
53 BuildRequires:  libtool
54 BuildRequires:  libxml2-devel >= 1:2.6.26
55 BuildRequires:  mono-csharp >= 1.1.16.1
56 # not used atm
57 #BuildRequires: mozilla-devel
58 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.10.3}
59 BuildRequires:  pkgconfig
60 BuildRequires:  perl-XML-Parser
61 BuildRequires:  python-devel
62 %if %{with sqlite3}
63 BuildRequires:  sqlite3-devel >= 3.3.4
64 %else
65 BuildRequires:  sqlite-devel
66 %endif
67 BuildRequires:  wv-devel >= 1.2.1
68 BuildRequires:  xorg-lib-libXScrnSaver-devel
69 BuildRequires:  zip
70 # GUI BRs
71 %if %{with gui}
72 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
73 BuildRequires:  gnome-vfs2-devel >= 2.16.1
74 %endif
75 Requires:       %{name}-libs = %{version}-%{release}
76 Requires:       dotnet-gmime-sharp >= 2.2.3
77 %if %{with sqlite3}
78 Requires:       sqlite3
79 %else
80 Requires:       sqlite
81 %endif
82 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
83 ExcludeArch:    i386
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 Beagle is an indexing sub-system and search aggregator built on top of
88 Lucene.Net.
89
90 %description -l pl
91 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
92 bazie Lucene.Net.
93
94 %package libs
95 Summary:        Beagle libraries
96 Summary(pl):    Bibiloteki Beagle
97 Group:          Libraries
98
99 %description libs
100 Beagle libraries.
101
102 %description libs -l pl
103 Bibiloteki Beagle.
104
105 %package devel
106 Summary:        Beagle development files
107 Summary(pl):    Pliki programistyczne Beagle
108 Group:          Development/Libraries
109 Requires:       %{name}-libs = %{version}-%{release}
110
111 %description devel
112 Beagle development files.
113
114 %description devel -l pl
115 Pliki programistyczne Beagle.
116
117 %package static
118 Summary:        Beagle static libraries
119 Summary(pl):    Statyczne biblioteki Beagle
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description static
124 Beagle static libraries.
125
126 %description static -l pl
127 Statyczne biblioteki Beagle.
128
129 %package apidocs
130 Summary:        libbeagle API documentation
131 Summary(pl):    Dokumentacja API libbeagle
132 Group:          Documentation
133 Requires:       gtk-doc-common
134
135 %description apidocs
136 libbeagle API documentation.
137
138 %description apidocs -l pl
139 Dokumentacja API libbeagle.
140
141 %package crawl-system
142 Summary:        Beagle crawl system
143 Summary(pl):    System przeszukuj±cy beagle-crawl
144 Group:          Applications/System
145 Requires:       crondaemon
146 Provides:       group(beagleindex)
147 Provides:       user(beagleindex)
148
149 %description crawl-system
150 Beagle crawl system.
151
152 %description crawl-system -l pl
153 System przeszukuj±cy beagle-crawl.
154
155 %package evolution
156 Summary:        Beagle Evolution backend
157 Summary(pl):    Backend Beagle dla Evolution
158 Group:          X11/Applications/Networking
159 Requires:       %{name} = %{version}-%{release}
160 Requires:       dotnet-evolution-sharp >= 0.11.1
161 Requires:       evolution >= 2.8.0
162
163 %description evolution
164 Beagle Evolution backend.
165
166 %description evolution -l pl
167 Backend Beagle dla Evolution.
168
169 %package thunderbird
170 Summary:        Beagle Mozilla Thunderbird backend
171 Summary(pl):    Backend Beagle dla Mozilli Thunderbird
172 Group:          X11/Applications/Networking
173 Requires:       %{name} = %{version}-%{release}
174
175 %description thunderbird
176 Beagle Mozilla Thunderbird backend.
177
178 %description thunderbird -l pl
179 Backend Beagle dla Mozilli Thunderbird.
180
181 %package -n epiphany-extension-beagle
182 Summary:        Epiphany extension - beagle
183 Summary(pl):    Rozszerzenie dla Epiphany - beagle
184 Group:          X11/Applications/Networking
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       epiphany-extensions >= 2.16.1
187
188 %description -n epiphany-extension-beagle
189 Epiphany extension that allows Beagle to index every page the user
190 views.
191
192 %description -n epiphany-extension-beagle -l pl
193 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
194 odwiedzan± stronê.
195
196 %package -n python-%{name}
197 Summary:        Beagle Python bindings
198 Summary(pl):    Wi±zania jêzyka Python dla Beagle
199 Group:          Libraries/Python
200 Requires:       %{name} = %{version}-%{release}
201 %pyrequires_eq  python-libs
202
203 %description -n python-%{name}
204 Beagle Python bindings.
205
206 %description -n python-%{name} -l pl
207 Wi±zania jêzyka Python dla Beagle.
208
209 %package search-gui
210 Summary:        GNOME based Beagle GUI
211 Summary(pl):    Oparty na GNOME graficzny interfejs dla Beagle
212 Group:          Libraries/Python
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       gtk+2 >= 2:2.10.6
215
216 %description search-gui
217 GNOME based Beagle GUI.
218
219 %description search-gui -l pl
220 Oparty na GNOME graficzny interfejs dla Beagle.
221
222 %package startup
223 Summary:        Automatic startup integration for Beagle
224 Summary(pl):    Integracja funkcji automatycznego startu Beagle
225 Group:          X11/Applications
226 Requires:       %{name} = %{version}-%{release}
227 Obsoletes:      beagle-gnome
228
229 %description startup
230 Automatic session startup integration for Beagle.
231
232 %description startup -l pl
233 Integracja funkcji automatycznego startu Beagle.
234
235 %prep
236 %setup -q
237 %patch0 -p1
238 %patch1 -p1
239 %patch2 -p1
240 %patch3 -p1
241
242 %build
243 %{__libtoolize}
244 %{__aclocal}
245 %{__autoconf}
246 %{__automake}
247 %configure \
248         --enable-static \
249         %{?with_apidocs:--enable-gtk-doc} \
250         --with-html-dir=%{_gtkdocdir} \
251         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
252         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
253         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
254
255 %{__make} \
256         MOZILLA_HOME=%{_libdir}/mozilla \
257         pythondir=%{py_sitedir}
258
259 %install
260 rm -rf $RPM_BUILD_ROOT
261 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
262
263 %{__make} install \
264         DESTDIR=$RPM_BUILD_ROOT \
265         pythondir=%{py_sitedir}
266
267 # Kill useless files
268 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.16/extensions/*.{la,a} \
269         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
270
271 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
272 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
273
274 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
275
276 %find_lang %{name}
277
278 %clean
279 rm -rf $RPM_BUILD_ROOT
280
281 %pre crawl-system
282 %groupadd -g 166 -r -f beagleindex
283 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
284
285 %postun crawl-system
286 if [ "$1" = "0" ]; then
287         %userremove beagleindex
288         %groupremove beagleindex
289 fi
290
291 %post   libs -p /sbin/ldconfig
292 %postun libs -p /sbin/ldconfig
293
294 %files -f %{name}.lang
295 %defattr(644,root,root,755)
296 %doc AUTHORS COPYING ChangeLog NEWS README
297 %attr(755,root,root) %{_bindir}/beagle-config
298 %attr(755,root,root) %{_bindir}/beagled
299 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
300 %attr(755,root,root) %{_bindir}/beagle-extract-content
301 %attr(755,root,root) %{_bindir}/beagle-index-info
302 %attr(755,root,root) %{_bindir}/beagle-index-url
303 %attr(755,root,root) %{_bindir}/beagle-info
304 %attr(755,root,root) %{_bindir}/beagle-ping
305 %attr(755,root,root) %{_bindir}/beagle-query
306 %attr(755,root,root) %{_bindir}/beagle-shutdown
307 %attr(755,root,root) %{_bindir}/beagle-status
308 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
309 %attr(755,root,root) %{_libdir}/%{name}/*.exe
310 %dir %{_libdir}/%{name}
311 %dir %{_libdir}/%{name}/Backends
312 %dir %{_libdir}/%{name}/Filters
313 %{_libdir}/%{name}/*.dll
314 %{_libdir}/%{name}/*.dll.config
315 %{_libdir}/%{name}/Filters/*.dll
316 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
317 %{_mandir}/man*/*
318
319 %files libs
320 %defattr(644,root,root,755)
321 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
322
323 %files devel
324 %defattr(644,root,root,755)
325 %attr(755,root,root) %{_libdir}/*.so
326 %{_includedir}/libbeagle
327 %{_libdir}/*.la
328 %{_pkgconfigdir}/*
329
330 %files static
331 %defattr(644,root,root,755)
332 %{_libdir}/*.a
333
334 %if %{with apidocs}
335 %files apidocs
336 %defattr(644,root,root,755)
337 %{_gtkdocdir}/beagle
338 %endif
339
340 %files crawl-system
341 %defattr(644,root,root,755)
342 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
343 %dir %{_sysconfdir}/beagle
344 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
345 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
346 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
347 %attr(755,root,root) %{_sbindir}/*
348
349 %if %{with evolution}
350 %files evolution
351 %defattr(644,root,root,755)
352 %{_libdir}/%{name}/Backends/Evolution*.dll
353 %endif
354
355 %files thunderbird
356 %defattr(644,root,root,755)
357 %{_libdir}/%{name}/Backends/Thunderbird*.dll
358
359 %if %{with epiphany}
360 %files -n epiphany-extension-beagle
361 %defattr(644,root,root,755)
362 %doc epiphany-extension/README
363 %attr(755,root,root) %{_libdir}/epiphany/2.16/extensions/libbeagleextension.so*
364 %{_libdir}/epiphany/2.16/extensions/*.xml
365 %endif
366
367 %if %{with python}
368 %files -n python-%{name}
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{py_sitedir}/*.so
371 %endif
372
373 %if %{with gui}
374 %files search-gui
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{_bindir}/beagle-contactviewer
377 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
378 %attr(755,root,root) %{_bindir}/beagle-search
379 %attr(755,root,root) %{_bindir}/beagle-settings
380 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
381 %{_pixmapsdir}/*.png
382 %{_desktopdir}/*.desktop
383 %endif
384
385 %files startup
386 %defattr(644,root,root,755)
387 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
388 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
This page took 0.10442 seconds and 3 git commands to generate.