]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- added gtk-sharp patch (fixes build with gtk-sharp 2.9.x)
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.7
25 Release:        2
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  d4c8e93db23c9b7d06104ce97a182502
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-kill_exec_a.patch
33 Patch3:         %{name}-configure.patch
34 Patch4:         %{name}-gtk-sharp.patch
35 URL:            http://beaglewiki.org/Main_Page
36 BuildRequires:  autoconf >= 2.52
37 BuildRequires:  automake
38 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
39 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.3.2}
40 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
41 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
42 #BuildRequires: dotnet-gst-sharp-devel
43 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.9.0
44 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.15.3}
45 BuildRequires:  gtk+2-devel >= 2:2.9.4
46 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
47 BuildRequires:  libexif-devel >= 0.6.13
48 BuildRequires:  librsvg-devel >= 1:2.15.0
49 BuildRequires:  libpng-devel
50 BuildRequires:  libtool
51 BuildRequires:  libxml2-devel >= 1:2.6.26
52 BuildRequires:  mono-csharp >= 1.1.13.8
53 # not used atm
54 #BuildRequires: mozilla-devel
55 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.9.2}
56 BuildRequires:  pkgconfig
57 BuildRequires:  perl-XML-Parser
58 BuildRequires:  python-devel
59 %if %{with sqlite3}
60 BuildRequires:  sqlite3-devel >= 3.3.4
61 %else
62 BuildRequires:  sqlite-devel
63 %endif
64 BuildRequires:  wv-devel >= 1.2.1
65 BuildRequires:  xorg-lib-libXScrnSaver-devel
66 BuildRequires:  zip
67 # GUI BRs
68 %if %{with gui}
69 BuildRequires:  dotnet-gnome-sharp-devel >= 2.15.0
70 BuildRequires:  gnome-vfs2-devel >= 2.15.2
71 %endif
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       dotnet-gmime-sharp >= 2.2.3
74 %if %{with sqlite3}
75 Requires:       sqlite3
76 %else
77 Requires:       sqlite
78 %endif
79 ExcludeArch:    alpha i386 sparc sparc64
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Beagle is an indexing sub-system and search aggregator built on top of
84 Lucene.Net.
85
86 %description -l pl
87 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
88 bazie Lucene.Net.
89
90 %package libs
91 Summary:        Beagle libraries
92 Summary(pl):    Bibiloteki Beagle
93 Group:          Libraries
94
95 %description libs
96 Beagle libraries.
97
98 %description libs -l pl
99 Bibiloteki Beagle.
100
101 %package devel
102 Summary:        Beagle development files
103 Summary(pl):    Pliki programistyczne Beagle
104 Group:          Development/Libraries
105 Requires:       %{name}-libs = %{version}-%{release}
106 Requires:       %{name} = %{version}-%{release}
107
108 %description devel
109 Beagle development files.
110
111 %description devel -l pl
112 Pliki programistyczne Beagle.
113
114 %package static
115 Summary:        Beagle static libraries
116 Summary(pl):    Statyczne biblioteki Beagle
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119
120 %description static
121 Beagle static libraries.
122
123 %description static -l pl
124 Statyczne biblioteki Beagle.
125
126 %package crawl-system
127 Summary:        Beagle crawl system
128 Summary(pl):    System przeszukuj±cy beagle-crawl
129 Group:          Applications/System
130 Requires:       crondaemon
131 Provides:       group(beagleindex)
132 Provides:       user(beagleindex)
133
134 %description crawl-system
135 Beagle crawl system.
136
137 %description crawl-system -l pl
138 System przeszukuj±cy beagle-crawl.
139
140 %package evolution
141 Summary:        Beagle Evolution backend
142 Summary(pl):    Backend Beagle dla Evolution
143 Group:          X11/Applications/Networking
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       dotnet-evolution-sharp >= 0.11.1
146 Requires:       evolution >= 2.7.3
147
148 %description
149 Beagle Evolution backend.
150
151 %description evolution -l pl
152 Backend Beagle dla Evolution.
153
154 %package -n epiphany-extension-beagle
155 Summary:        Epiphany extension - beagle
156 Summary(pl):    Rozszerzenie dla Epiphany - beagle
157 Group:          X11/Applications/Networking
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       epiphany-extensions >= 2.15.1
160
161 %description -n epiphany-extension-beagle
162 Epiphany extension that allows Beagle to index every page the user
163 views.
164
165 %description -n epiphany-extension-beagle -l pl
166 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
167 odwiedzan± stronê.
168
169 %package -n python-%{name}
170 Summary:        Beagle Python bindings
171 Summary(pl):    Wi±zania jêzyka Python dla Beagle
172 Group:          Libraries/Python
173 Requires:       %{name} = %{version}-%{release}
174 %pyrequires_eq  python-libs
175
176 %description -n python-%{name}
177 Beagle Python bindings.
178
179 %description -n python-%{name} -l pl
180 Wi±zania jêzyka Python dla Beagle.
181
182 %package search-gui
183 Summary:        GNOME based Beagle GUI
184 Summary(pl):    Bazowane na GNOME GUI dla Beagle
185 Group:          Libraries/Python
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       gtk+2 >= 2:2.9.4
188
189 %description search-gui
190 GNOME based Beagle GUI.
191
192 %description search-gui -l pl
193 Bazowane na GNOME GUI dla Beagle.
194
195 %prep
196 %setup -q
197 %patch0 -p1
198 %patch1 -p1
199 %patch2 -p1
200 %patch3 -p1
201 %patch4 -p1
202
203 %build
204 %{__libtoolize}
205 %{__aclocal}
206 %{__autoconf}
207 %{__automake}
208 %configure \
209         --enable-static \
210         %{?with_apidocs:--enable-gtk-doc} \
211         --with-html-dir=%{_gtkdocdir} \
212         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
213         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
214         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
215
216 %{__make} \
217         MOZILLA_HOME=%{_libdir}/mozilla \
218         pythondir=%{py_sitedir}
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
223
224 %{__make} install \
225         DESTDIR=$RPM_BUILD_ROOT \
226         pythondir=%{py_sitedir}
227
228 # Kill useless files
229 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
230         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
231
232 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
233 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
234
235 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
236
237 %find_lang %{name}
238
239 %clean
240 rm -rf $RPM_BUILD_ROOT
241
242 %pre crawl-system
243 %groupadd -g 166 -r -f beagleindex
244 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
245
246 %postun crawl-system
247 if [ "$1" = "0" ]; then
248         %userremove beagleindex
249         %groupremove beagleindex
250 fi
251
252 %post   libs -p /sbin/ldconfig
253 %postun libs -p /sbin/ldconfig
254
255 %files -f %{name}.lang
256 %defattr(644,root,root,755)
257 %doc AUTHORS COPYING ChangeLog NEWS README
258 %attr(755,root,root) %{_bindir}/beagle-config
259 %attr(755,root,root) %{_bindir}/beagled
260 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
261 %attr(755,root,root) %{_bindir}/beagle-extract-content
262 %attr(755,root,root) %{_bindir}/beagle-index-info
263 %attr(755,root,root) %{_bindir}/beagle-index-url
264 %attr(755,root,root) %{_bindir}/beagle-info
265 %attr(755,root,root) %{_bindir}/beagle-ping
266 %attr(755,root,root) %{_bindir}/beagle-query
267 %attr(755,root,root) %{_bindir}/beagle-shutdown
268 %attr(755,root,root) %{_bindir}/beagle-status
269 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
270 %attr(755,root,root) %{_libdir}/%{name}/*.exe
271 %dir %{_libdir}/%{name}
272 %dir %{_libdir}/%{name}/Backends
273 %{_libdir}/%{name}/Filters
274 %{_libdir}/%{name}/*.dll*
275 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
276 %{_mandir}/man*/*
277
278 %files libs
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
281
282 %files devel
283 %defattr(644,root,root,755)
284 %attr(755,root,root) %{_libdir}/*.so
285 %{_includedir}/libbeagle
286 %{_libdir}/*.la
287 %{?with_apidocs:%{_gtkdocdir}/beagle}
288 %{_pkgconfigdir}/*
289
290 %files static
291 %defattr(644,root,root,755)
292 %{_libdir}/*.a
293
294 %files crawl-system
295 %defattr(644,root,root,755)
296 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
297 %dir %{_sysconfdir}/beagle
298 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
299 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
300 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
301 %attr(755,root,root) %{_sbindir}/*
302
303 %if %{with evolution}
304 %files evolution
305 %defattr(644,root,root,755)
306 %{_libdir}/%{name}/Backends/Evolution*
307 %endif
308
309 %if %{with epiphany}
310 %files -n epiphany-extension-beagle
311 %defattr(644,root,root,755)
312 %doc epiphany-extension/README
313 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
314 %{_libdir}/epiphany/1.8/extensions/*.xml
315 %endif
316
317 %if %{with python}
318 %files -n python-%{name}
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{py_sitedir}/*.so
321 %endif
322
323 %if %{with gui}
324 %files search-gui
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_bindir}/beagle-search
327 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
328 %attr(755,root,root) %{_bindir}/beagle-settings
329 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
330 %{_pixmapsdir}/*.png
331 %{_desktopdir}/*.desktop
332 %endif
This page took 3.555442 seconds and 3 git commands to generate.