]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
cf9d0084a15483bb3bfb6c2a7096efcde06acb46
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.7
25 Release:        3
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  d4c8e93db23c9b7d06104ce97a182502
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-kill_exec_a.patch
33 Patch3:         %{name}-configure.patch
34 Patch4:         %{name}-gtk-sharp.patch
35 Patch5:         %{name}-galago05.patch
36 URL:            http://beaglewiki.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
40 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
41 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
42 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
43 #BuildRequires: dotnet-gst-sharp-devel
44 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.9.0
45 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.15.3}
46 BuildRequires:  gtk+2-devel >= 2:2.9.4
47 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
48 BuildRequires:  libexif-devel >= 0.6.13
49 BuildRequires:  librsvg-devel >= 1:2.15.0
50 BuildRequires:  libpng-devel
51 BuildRequires:  libtool
52 BuildRequires:  libxml2-devel >= 1:2.6.26
53 BuildRequires:  mono-csharp >= 1.1.13.8
54 # not used atm
55 #BuildRequires: mozilla-devel
56 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.9.2}
57 BuildRequires:  pkgconfig
58 BuildRequires:  perl-XML-Parser
59 BuildRequires:  python-devel
60 %if %{with sqlite3}
61 BuildRequires:  sqlite3-devel >= 3.3.4
62 %else
63 BuildRequires:  sqlite-devel
64 %endif
65 BuildRequires:  wv-devel >= 1.2.1
66 BuildRequires:  xorg-lib-libXScrnSaver-devel
67 BuildRequires:  zip
68 # GUI BRs
69 %if %{with gui}
70 BuildRequires:  dotnet-gnome-sharp-devel >= 2.15.0
71 BuildRequires:  gnome-vfs2-devel >= 2.15.2
72 %endif
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       dotnet-gmime-sharp >= 2.2.3
75 %if %{with sqlite3}
76 Requires:       sqlite3
77 %else
78 Requires:       sqlite
79 %endif
80 ExcludeArch:    alpha i386 sparc sparc64
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 Beagle is an indexing sub-system and search aggregator built on top of
85 Lucene.Net.
86
87 %description -l pl
88 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
89 bazie Lucene.Net.
90
91 %package libs
92 Summary:        Beagle libraries
93 Summary(pl):    Bibiloteki Beagle
94 Group:          Libraries
95
96 %description libs
97 Beagle libraries.
98
99 %description libs -l pl
100 Bibiloteki Beagle.
101
102 %package devel
103 Summary:        Beagle development files
104 Summary(pl):    Pliki programistyczne Beagle
105 Group:          Development/Libraries
106 Requires:       %{name}-libs = %{version}-%{release}
107 Requires:       %{name} = %{version}-%{release}
108
109 %description devel
110 Beagle development files.
111
112 %description devel -l pl
113 Pliki programistyczne Beagle.
114
115 %package static
116 Summary:        Beagle static libraries
117 Summary(pl):    Statyczne biblioteki Beagle
118 Group:          Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120
121 %description static
122 Beagle static libraries.
123
124 %description static -l pl
125 Statyczne biblioteki Beagle.
126
127 %package apidocs
128 Summary:        libbeagle API documentation
129 Summary(pl):    Dokumentacja API libbeagle
130 Group:          Documentation
131 Requires:       gtk-doc-common
132
133 %description apidocs
134 libbeagle API documentation.
135
136 %description apidocs -l pl
137 Dokumentacja API libbeagle.
138
139 %package crawl-system
140 Summary:        Beagle crawl system
141 Summary(pl):    System przeszukuj±cy beagle-crawl
142 Group:          Applications/System
143 Requires:       crondaemon
144 Provides:       group(beagleindex)
145 Provides:       user(beagleindex)
146
147 %description crawl-system
148 Beagle crawl system.
149
150 %description crawl-system -l pl
151 System przeszukuj±cy beagle-crawl.
152
153 %package evolution
154 Summary:        Beagle Evolution backend
155 Summary(pl):    Backend Beagle dla Evolution
156 Group:          X11/Applications/Networking
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       dotnet-evolution-sharp >= 0.11.1
159 Requires:       evolution >= 2.7.3
160
161 %description
162 Beagle Evolution backend.
163
164 %description evolution -l pl
165 Backend Beagle dla Evolution.
166
167 %package -n epiphany-extension-beagle
168 Summary:        Epiphany extension - beagle
169 Summary(pl):    Rozszerzenie dla Epiphany - beagle
170 Group:          X11/Applications/Networking
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       epiphany-extensions >= 2.15.1
173
174 %description -n epiphany-extension-beagle
175 Epiphany extension that allows Beagle to index every page the user
176 views.
177
178 %description -n epiphany-extension-beagle -l pl
179 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
180 odwiedzan± stronê.
181
182 %package -n python-%{name}
183 Summary:        Beagle Python bindings
184 Summary(pl):    Wi±zania jêzyka Python dla Beagle
185 Group:          Libraries/Python
186 Requires:       %{name} = %{version}-%{release}
187 %pyrequires_eq  python-libs
188
189 %description -n python-%{name}
190 Beagle Python bindings.
191
192 %description -n python-%{name} -l pl
193 Wi±zania jêzyka Python dla Beagle.
194
195 %package search-gui
196 Summary:        GNOME based Beagle GUI
197 Summary(pl):    Bazowane na GNOME GUI dla Beagle
198 Group:          Libraries/Python
199 Requires:       %{name} = %{version}-%{release}
200 Requires:       gtk+2 >= 2:2.9.4
201
202 %description search-gui
203 GNOME based Beagle GUI.
204
205 %description search-gui -l pl
206 Bazowane na GNOME GUI dla Beagle.
207
208 %prep
209 %setup -q
210 %patch0 -p1
211 %patch1 -p1
212 %patch2 -p1
213 %patch3 -p1
214 %patch4 -p1
215 %patch5 -p1
216
217 %build
218 %{__libtoolize}
219 %{__aclocal}
220 %{__autoconf}
221 %{__automake}
222 %configure \
223         --enable-static \
224         %{?with_apidocs:--enable-gtk-doc} \
225         --with-html-dir=%{_gtkdocdir} \
226         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
227         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
228         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
229
230 %{__make} \
231         MOZILLA_HOME=%{_libdir}/mozilla \
232         pythondir=%{py_sitedir}
233
234 %install
235 rm -rf $RPM_BUILD_ROOT
236 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
237
238 %{__make} install \
239         DESTDIR=$RPM_BUILD_ROOT \
240         pythondir=%{py_sitedir}
241
242 # Kill useless files
243 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
244         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
245
246 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
247 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
248
249 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
250
251 %find_lang %{name}
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %pre crawl-system
257 %groupadd -g 166 -r -f beagleindex
258 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
259
260 %postun crawl-system
261 if [ "$1" = "0" ]; then
262         %userremove beagleindex
263         %groupremove beagleindex
264 fi
265
266 %post   libs -p /sbin/ldconfig
267 %postun libs -p /sbin/ldconfig
268
269 %files -f %{name}.lang
270 %defattr(644,root,root,755)
271 %doc AUTHORS COPYING ChangeLog NEWS README
272 %attr(755,root,root) %{_bindir}/beagle-config
273 %attr(755,root,root) %{_bindir}/beagled
274 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
275 %attr(755,root,root) %{_bindir}/beagle-extract-content
276 %attr(755,root,root) %{_bindir}/beagle-index-info
277 %attr(755,root,root) %{_bindir}/beagle-index-url
278 %attr(755,root,root) %{_bindir}/beagle-info
279 %attr(755,root,root) %{_bindir}/beagle-ping
280 %attr(755,root,root) %{_bindir}/beagle-query
281 %attr(755,root,root) %{_bindir}/beagle-shutdown
282 %attr(755,root,root) %{_bindir}/beagle-status
283 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
284 %attr(755,root,root) %{_libdir}/%{name}/*.exe
285 %dir %{_libdir}/%{name}
286 %dir %{_libdir}/%{name}/Backends
287 %{_libdir}/%{name}/Filters
288 %{_libdir}/%{name}/*.dll*
289 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
290 %{_mandir}/man*/*
291
292 %files libs
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
295
296 %files devel
297 %defattr(644,root,root,755)
298 %attr(755,root,root) %{_libdir}/*.so
299 %{_includedir}/libbeagle
300 %{_libdir}/*.la
301 %{_pkgconfigdir}/*
302
303 %files static
304 %defattr(644,root,root,755)
305 %{_libdir}/*.a
306
307 %if %{with apidocs}
308 %files apidocs
309 %defattr(644,root,root,755)
310 %{_gtkdocdir}/beagle
311 %endif
312
313 %files crawl-system
314 %defattr(644,root,root,755)
315 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
316 %dir %{_sysconfdir}/beagle
317 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
318 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
319 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
320 %attr(755,root,root) %{_sbindir}/*
321
322 %if %{with evolution}
323 %files evolution
324 %defattr(644,root,root,755)
325 %{_libdir}/%{name}/Backends/Evolution*
326 %endif
327
328 %if %{with epiphany}
329 %files -n epiphany-extension-beagle
330 %defattr(644,root,root,755)
331 %doc epiphany-extension/README
332 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
333 %{_libdir}/epiphany/1.8/extensions/*.xml
334 %endif
335
336 %if %{with python}
337 %files -n python-%{name}
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{py_sitedir}/*.so
340 %endif
341
342 %if %{with gui}
343 %files search-gui
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_bindir}/beagle-search
346 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
347 %attr(755,root,root) %{_bindir}/beagle-settings
348 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
349 %{_pixmapsdir}/*.png
350 %{_desktopdir}/*.desktop
351 %endif
This page took 0.186518 seconds and 2 git commands to generate.