]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
bf04062a4bfd85afa1fcd2a38018c0bf9f80aace
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - add qyoto based settings (requires new packages)
5 #       - replace epiphany-extension hack
6 #
7 %include        /usr/lib/rpm/macros.mono
8 #
9 # Conditional build:
10 %bcond_without  apidocs         # don't build API documentation
11 %bcond_with     avahi           # enable Avahi support
12 %bcond_without  evolution       # don't include evolution support
13 %bcond_without  galago          # build without galago support
14 %bcond_without  gsf             # build without libgsf support
15 %bcond_without  gui             # don't build GNOME based GUI
16 %bcond_without  python          # don't build python libraries
17 %bcond_without  epiphany        # don't build epiphany extension
18 %bcond_without  thunderbird     # use Thunderbird backend
19 #
20 %if !%{with gui}
21 %undefine       with_evolution
22 %endif
23 #
24 Summary:        Beagle - An indexing subsystem
25 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
26 Name:           beagle
27 Version:        0.3.3
28 Release:        1
29 License:        Various
30 Group:          Libraries
31 Source0:        http://ftp.gnome.org/pub/GNOME/sources/beagle/0.3/%{name}-%{version}.tar.bz2
32 # Source0-md5:  c1b6c340c72a70e33212c85513bc23f2
33 Patch0:         %{name}-desktop.patch
34 Patch1:         %{name}-crawl.patch
35 Patch2:         %{name}-configure.patch
36 URL:            http://beagle-project.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  chmlib-devel
40 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.13.3}
41 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
42 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
43 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
44 #BuildRequires: dotnet-gst-sharp-devel
45 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
46 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3.0
47 BuildRequires:  dotnet-ndesk-dbus-sharp-devel >= 0.6.0
48 %if %{with epiphany}
49 BuildRequires:  epiphany-devel >= 2.20.0
50 %endif
51 BuildRequires:  gtk+2-devel >= 2:2.10.10
52 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
53 BuildRequires:  libexif-devel >= 0.6.13
54 BuildRequires:  libpng-devel
55 BuildRequires:  librsvg-devel >= 1:2.16.1
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel >= 1:2.6.27
58 BuildRequires:  mono-csharp >= 1.1.13.5
59 BuildRequires:  perl-XML-Parser
60 BuildRequires:  pkgconfig
61 BuildRequires:  python-devel
62 %{?with_python:BuildRequires:   python-pygtk-devel >= 2:2.10.4}
63 BuildRequires:  sqlite3-devel >= 3.3.4
64 BuildRequires:  wv-devel >= 1.2.4
65 BuildRequires:  xorg-lib-libXScrnSaver-devel
66 BuildRequires:  zip
67 # GUI BRs
68 %if %{with gui}
69 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
70 BuildRequires:  gnome-vfs2-devel >= 2.18.0.1
71 %endif
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       dotnet-gmime-sharp >= 2.2.3
74 Requires:       dotnet-gsf-sharp
75 Requires:       sqlite3
76 # sr@Latn vs. sr@latin
77 Conflicts:      glibc-misc < 6:2.7
78 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
79 ExcludeArch:    i386
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Beagle is an indexing sub-system and search aggregator built on top of
84 Lucene.Net.
85
86 %description -l pl.UTF-8
87 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
88 bazie Lucene.Net.
89
90 %package libs
91 Summary:        Beagle libraries
92 Summary(pl.UTF-8):      Bibiloteki Beagle
93 Group:          Libraries
94
95 %description libs
96 Beagle libraries.
97
98 %description libs -l pl.UTF-8
99 Bibiloteki Beagle.
100
101 %package debug
102 Summary:        Debug files for the Mono part of Beagle
103 Summary(pl.UTF-8):      Pliki debugujące dla części Mono Beagle'a
104 Group:          Development/Libraries
105 Requires:       %{name} = %{version}-%{release}
106
107 %description debug
108 Debug files for the Mono part of Beagle.
109
110 %description -l pl.UTF-8
111 Pliki debugujące dla części Mono Beagle'a.
112
113 %package devel
114 Summary:        Beagle development files
115 Summary(pl.UTF-8):      Pliki programistyczne Beagle
116 Group:          Development/Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118
119 %description devel
120 Beagle development files.
121
122 %description devel -l pl.UTF-8
123 Pliki programistyczne Beagle.
124
125 %package static
126 Summary:        Beagle static libraries
127 Summary(pl.UTF-8):      Statyczne biblioteki Beagle
128 Group:          Development/Libraries
129 Requires:       %{name}-devel = %{version}-%{release}
130
131 %description static
132 Beagle static libraries.
133
134 %description static -l pl.UTF-8
135 Statyczne biblioteki Beagle.
136
137 %package apidocs
138 Summary:        libbeagle API documentation
139 Summary(pl.UTF-8):      Dokumentacja API libbeagle
140 Group:          Documentation
141 Requires:       gtk-doc-common
142
143 %description apidocs
144 libbeagle API documentation.
145
146 %description apidocs -l pl.UTF-8
147 Dokumentacja API libbeagle.
148
149 %package crawl-system
150 Summary:        Beagle crawl system
151 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
152 Group:          Applications/System
153 Requires:       crondaemon
154 Provides:       group(beagleindex)
155 Provides:       user(beagleindex)
156
157 %description crawl-system
158 Beagle crawl system.
159
160 %description crawl-system -l pl.UTF-8
161 System przeszukujący beagle-crawl.
162
163 %package evolution
164 Summary:        Beagle Evolution backend
165 Summary(pl.UTF-8):      Backend Beagle dla Evolution
166 Group:          X11/Applications/Networking
167 Requires:       %{name} = %{version}-%{release}
168 Requires:       dotnet-evolution-sharp >= 0.11.1
169 Requires:       evolution >= 2.10.0
170
171 %description evolution
172 Beagle Evolution backend.
173
174 %description evolution -l pl.UTF-8
175 Backend Beagle dla Evolution.
176
177 %package thunderbird
178 Summary:        Beagle Mozilla Thunderbird backend
179 Summary(pl.UTF-8):      Backend Beagle dla Mozilli Thunderbird
180 Group:          X11/Applications/Networking
181 Requires:       %{name} = %{version}-%{release}
182
183 %description thunderbird
184 Beagle Mozilla Thunderbird backend.
185
186 %description thunderbird -l pl.UTF-8
187 Backend Beagle dla Mozilli Thunderbird.
188
189 %package -n mozilla-firefox-extension-beagle
190 Summary:        Mozilla Firefox extension - beagle
191 Summary(pl.UTF-8):      Rozszerzenie dla Mozilla Firefox - beagle
192 Group:          X11/Applications/Networking
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       mozilla-firefox >= 2.0.0.1-2
195
196 %description -n mozilla-firefox-extension-beagle
197 Mozilla Firefox extension that allows Beagle to index every page the
198 user views.
199
200 %description -n mozilla-firefox-extension-beagle -l pl.UTF-8
201 Rozszerzenie dla Mozilla Firefox sprawiające, że Beagle indeksuje
202 każdą odwiedzaną stronę.
203
204 %package -n epiphany-extension-beagle
205 Summary:        Epiphany extension - beagle
206 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
207 Group:          X11/Applications/Networking
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       epiphany-extensions >= 2.20.0
210
211 %description -n epiphany-extension-beagle
212 Epiphany extension that allows Beagle to index every page the user
213 views.
214
215 %description -n epiphany-extension-beagle -l pl.UTF-8
216 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
217 odwiedzaną stronę.
218
219 %package -n python-%{name}
220 Summary:        Beagle Python bindings
221 Summary(pl.UTF-8):      Wiązania języka Python dla Beagle
222 Group:          Libraries/Python
223 Requires:       %{name} = %{version}-%{release}
224 %pyrequires_eq  python-libs
225
226 %description -n python-%{name}
227 Beagle Python bindings.
228
229 %description -n python-%{name} -l pl.UTF-8
230 Wiązania języka Python dla Beagle.
231
232 %package search-gui
233 Summary:        GNOME based Beagle GUI
234 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
235 Group:          Libraries/Python
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       gtk+2 >= 2:2.10.10
238
239 %description search-gui
240 GNOME based Beagle GUI.
241
242 %description search-gui -l pl.UTF-8
243 Oparty na GNOME graficzny interfejs dla Beagle.
244
245 %package startup
246 Summary:        Automatic startup integration for Beagle
247 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
248 Group:          X11/Applications
249 Requires:       %{name} = %{version}-%{release}
250 Obsoletes:      beagle-gnome
251
252 %description startup
253 Automatic session startup integration for Beagle.
254
255 %description startup -l pl.UTF-8
256 Integracja funkcji automatycznego startu Beagle.
257
258 %package webinterface
259 Summary:        A web interface for Beagle
260 Summary(pl.UTF-8):      Interfejs sieciowy dla Beagle
261 Group:          Applications
262 Requires:       %{name} = %{version}-%{release}
263
264 %description webinterface
265 An AJAX interface that allows users to search for data through their
266 web browser.
267
268 %description webinterface -l pl.UTF-8
269 AJAX-owy interfejs pozwalający użytkownikom wyszukiwać dane za pomocą
270 przeglądarki internetowej.
271
272 %prep
273 %setup -q
274 %patch0 -p1
275 %patch1 -p1
276 %patch2 -p1
277
278 %build
279 %{__intltoolize}
280 %{__libtoolize}
281 %{__aclocal}
282 %{__autoconf}
283 %{__automake}
284 %configure \
285         --enable-static \
286         %{?with_apidocs:--enable-gtk-doc} \
287         --with-html-dir=%{_gtkdocdir} \
288         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
289         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
290         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
291         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird \
292         --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi
293
294 %{__make} \
295         MOZILLA_HOME=%{_libdir}/mozilla \
296         pythondir=%{py_sitedir}
297
298 %install
299 rm -rf $RPM_BUILD_ROOT
300 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
301
302 %{__make} install \
303         DESTDIR=$RPM_BUILD_ROOT \
304         pythondir=%{py_sitedir} \
305         monodocdir=%{_libdir}/monodoc/sources
306
307 dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
308 install -d $dest $dest/chrome
309 install firefox-extension/{chrome.manifest,install.rdf} $dest
310 cp -r firefox-extension/chrome/* $dest/chrome
311
312 %if %{with epiphany}
313 install -d $RPM_BUILD_ROOT%{_libdir}/epiphany/2.20/extensions
314 sed -e "s|\@localedir\@|\%{_localedir}|g" \
315         < epiphany-extension/beagle.py.in > epiphany-extension/beagle.py
316 install epiphany-extension/beagle.py $RPM_BUILD_ROOT%{_libdir}/epiphany/2.20/extensions/beagle.py
317 install epiphany-extension/beagle.ephy-extension.in $RPM_BUILD_ROOT%{_libdir}/epiphany/2.20/extensions/beagle.ephy-extension
318 %endif
319
320 %if %{with thunderbird}
321 tdest=$RPM_BUILD_ROOT%{_libdir}/mozilla-thunderbird/extensions/\{b656ef18-fd76-45e6-95cc-8043f26361e7\}
322 install -d $tdest
323 install thunderbird-extension/{chrome.manifest,install.rdf} $tdest
324 cp -r thunderbird-extension/{chrome,components,defaults} $tdest
325 %endif
326
327 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
328         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
329 %find_lang %{name}
330
331 %clean
332 rm -rf $RPM_BUILD_ROOT
333
334 %pre crawl-system
335 %groupadd -g 166 -r -f beagleindex
336 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
337
338 %postun crawl-system
339 if [ "$1" = "0" ]; then
340         %userremove beagleindex
341         %groupremove beagleindex
342 fi
343
344 %post   libs -p /sbin/ldconfig
345 %postun libs -p /sbin/ldconfig
346
347 %files -f %{name}.lang
348 %defattr(644,root,root,755)
349 %doc AUTHORS COPYING ChangeLog NEWS README
350 %attr(755,root,root) %{_bindir}/beagle-config
351 %attr(755,root,root) %{_bindir}/beagled
352 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
353 %attr(755,root,root) %{_bindir}/beagle-extract-content
354 %attr(755,root,root) %{_bindir}/beagle-index-info
355 %attr(755,root,root) %{_bindir}/beagle-info
356 %attr(755,root,root) %{_bindir}/beagle-ping
357 %attr(755,root,root) %{_bindir}/beagle-query
358 %attr(755,root,root) %{_bindir}/beagle-shutdown
359 %attr(755,root,root) %{_bindir}/beagle-status
360 %attr(755,root,root) %{_libdir}/%{name}/*.exe
361 %dir %{_libdir}/%{name}
362 %dir %{_libdir}/%{name}/Backends
363 %dir %{_libdir}/%{name}/Filters
364 %{_libdir}/%{name}/*.dll
365 %{_libdir}/%{name}/*.dll.config
366 %{_libdir}/%{name}/Filters/*.dll
367 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
368 %{_mandir}/man*/*
369
370 %files libs
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_libdir}/%{name}/lib*.so.*.*.*
373
374 %files debug
375 %defattr(644,root,root,755)
376 %{_libdir}/%{name}/Backends/*.mdb
377 %{_libdir}/%{name}/Filters/*.mdb
378 %{_libdir}/%{name}/*.mdb
379
380 %files devel
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/%{name}/*.so
383 %attr(755,root,root) %ghost %{_libdir}/%{name}/*.so.0
384 %{_libdir}/%{name}/*.la
385 %{_pkgconfigdir}/*
386
387 %files crawl-system
388 %defattr(644,root,root,755)
389 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
390 %dir %{_sysconfdir}/beagle
391 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
392 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
393 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
394 %attr(755,root,root) %{_sbindir}/*
395
396 %if %{with apidocs}
397 %files apidocs
398 %defattr(644,root,root,755)
399 %{_libdir}/monodoc/sources/*
400 %endif
401
402 %if %{with evolution}
403 %files evolution
404 %defattr(644,root,root,755)
405 %{_libdir}/%{name}/Backends/Evolution*.dll
406 %endif
407
408 %if %{with thunderbird}
409 %files thunderbird
410 %defattr(644,root,root,755)
411 %{_libdir}/%{name}/Backends/Thunderbird*.dll
412 %{_libdir}/mozilla-thunderbird/extensions/{b656ef18-fd76-45e6-95cc-8043f26361e7}
413 %endif
414
415 %files -n mozilla-firefox-extension-beagle
416 %defattr(644,root,root,755)
417 %{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
418
419 %if %{with epiphany}
420 %files -n epiphany-extension-beagle
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{_libdir}/epiphany/2.20/extensions/beagle.py
423 %{_libdir}/epiphany/2.20/extensions/*.ephy-extension
424 %endif
425
426 %if %{with gui}
427 %files search-gui
428 %defattr(644,root,root,755)
429 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
430 %attr(755,root,root) %{_bindir}/beagle-search
431 %attr(755,root,root) %{_bindir}/beagle-settings
432 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
433 %{_desktopdir}/*.desktop
434 %endif
435
436 %files static
437 %defattr(644,root,root,755)
438 %{_libdir}/%{name}/*.a
439
440 %files startup
441 %defattr(644,root,root,755)
442 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
443 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
444
445 %files webinterface
446 %defattr(644,root,root,755)
447 %{_datadir}/%{name}
This page took 0.06928 seconds and 2 git commands to generate.