]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- updated for 0.2.11
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_without  epiphany        # don't build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.11
25 Release:        1
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  d44521a1c321407ba3a3de8bd625ff1f
30 Source1:        %{name}-autostart.desktop
31 Patch0:         %{name}-desktop.patch
32 Patch1:         %{name}-crawl.patch
33 Patch2:         %{name}-kill_exec_a.patch
34 Patch3:         %{name}-configure.patch
35 URL:            http://beaglewiki.org/Main_Page
36 BuildRequires:  autoconf >= 2.52
37 BuildRequires:  automake
38 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
39 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
40 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
41 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
42 #BuildRequires: dotnet-gst-sharp-devel
43 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
44 %if %{with epiphany} 
45 BuildRequires:  epiphany-devel >= 2.16.1
46 %endif
47 BuildRequires:  gtk+2-devel >= 2:2.10.6
48 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
49 BuildRequires:  libexif-devel >= 0.6.13
50 BuildRequires:  librsvg-devel >= 1:2.16.0
51 BuildRequires:  libpng-devel
52 BuildRequires:  libtool
53 BuildRequires:  libxml2-devel >= 1:2.6.26
54 BuildRequires:  mono-csharp >= 1.1.16.1
55 # not used atm
56 #BuildRequires: mozilla-devel
57 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.10.3}
58 BuildRequires:  pkgconfig
59 BuildRequires:  perl-XML-Parser
60 BuildRequires:  python-devel
61 %if %{with sqlite3}
62 BuildRequires:  sqlite3-devel >= 3.3.4
63 %else
64 BuildRequires:  sqlite-devel
65 %endif
66 BuildRequires:  wv-devel >= 1.2.1
67 BuildRequires:  xorg-lib-libXScrnSaver-devel
68 BuildRequires:  zip
69 # GUI BRs
70 %if %{with gui}
71 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
72 BuildRequires:  gnome-vfs2-devel >= 2.16.1
73 %endif
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       dotnet-gmime-sharp >= 2.2.3
76 %if %{with sqlite3}
77 Requires:       sqlite3
78 %else
79 Requires:       sqlite
80 %endif
81 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
82 ExcludeArch:    i386
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %description
86 Beagle is an indexing sub-system and search aggregator built on top of
87 Lucene.Net.
88
89 %description -l pl
90 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
91 bazie Lucene.Net.
92
93 %package libs
94 Summary:        Beagle libraries
95 Summary(pl):    Bibiloteki Beagle
96 Group:          Libraries
97
98 %description libs
99 Beagle libraries.
100
101 %description libs -l pl
102 Bibiloteki Beagle.
103
104 %package devel
105 Summary:        Beagle development files
106 Summary(pl):    Pliki programistyczne Beagle
107 Group:          Development/Libraries
108 Requires:       %{name}-libs = %{version}-%{release}
109
110 %description devel
111 Beagle development files.
112
113 %description devel -l pl
114 Pliki programistyczne Beagle.
115
116 %package static
117 Summary:        Beagle static libraries
118 Summary(pl):    Statyczne biblioteki Beagle
119 Group:          Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121
122 %description static
123 Beagle static libraries.
124
125 %description static -l pl
126 Statyczne biblioteki Beagle.
127
128 %package apidocs
129 Summary:        libbeagle API documentation
130 Summary(pl):    Dokumentacja API libbeagle
131 Group:          Documentation
132 Requires:       gtk-doc-common
133
134 %description apidocs
135 libbeagle API documentation.
136
137 %description apidocs -l pl
138 Dokumentacja API libbeagle.
139
140 %package crawl-system
141 Summary:        Beagle crawl system
142 Summary(pl):    System przeszukuj±cy beagle-crawl
143 Group:          Applications/System
144 Requires:       crondaemon
145 Provides:       group(beagleindex)
146 Provides:       user(beagleindex)
147
148 %description crawl-system
149 Beagle crawl system.
150
151 %description crawl-system -l pl
152 System przeszukuj±cy beagle-crawl.
153
154 %package evolution
155 Summary:        Beagle Evolution backend
156 Summary(pl):    Backend Beagle dla Evolution
157 Group:          X11/Applications/Networking
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       dotnet-evolution-sharp >= 0.11.1
160 Requires:       evolution >= 2.8.0
161
162 %description
163 Beagle Evolution backend.
164
165 %description evolution -l pl
166 Backend Beagle dla Evolution.
167
168 %package thunderbird
169 Summary:        Beagle Mozilla Thunderbird backend
170 Summary(pl):    Backend Beagle dla Mozilli Thunderbird
171 Group:          X11/Applications/Networking
172 Requires:       %{name} = %{version}-%{release}
173
174 %description thunderbird
175 Beagle Mozilla Thunderbird backend.
176
177 %description thunderbird -l pl
178 Backend Beagle dla Mozilli Thunderbird.
179
180 %package -n epiphany-extension-beagle
181 Summary:        Epiphany extension - beagle
182 Summary(pl):    Rozszerzenie dla Epiphany - beagle
183 Group:          X11/Applications/Networking
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       epiphany-extensions >= 2.16.1
186
187 %description -n epiphany-extension-beagle
188 Epiphany extension that allows Beagle to index every page the user
189 views.
190
191 %description -n epiphany-extension-beagle -l pl
192 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
193 odwiedzan± stronê.
194
195 %package -n python-%{name}
196 Summary:        Beagle Python bindings
197 Summary(pl):    Wi±zania jêzyka Python dla Beagle
198 Group:          Libraries/Python
199 Requires:       %{name} = %{version}-%{release}
200 %pyrequires_eq  python-libs
201
202 %description -n python-%{name}
203 Beagle Python bindings.
204
205 %description -n python-%{name} -l pl
206 Wi±zania jêzyka Python dla Beagle.
207
208 %package search-gui
209 Summary:        GNOME based Beagle GUI
210 Summary(pl):    Oparty na GNOME graficzny interfejs dla Beagle
211 Group:          Libraries/Python
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       gtk+2 >= 2:2.10.6
214
215 %description search-gui
216 GNOME based Beagle GUI.
217
218 %description search-gui -l pl
219 Oparty na GNOME graficzny interfejs dla Beagle.
220
221 %package startup
222 Summary:        Automatic startup integration for Beagle
223 Summary(pl):    Integracja funkcji automatycznego startu Beagle
224 Group:          X11/Applications
225 Requires:       %{name} = %{version}-%{release}
226 Obsoletes:      beagle-gnome
227
228 %description startup
229 Automatic session startup integration for Beagle.
230
231 %description startup -l pl
232 Integracja funkcji automatycznego startu Beagle.
233
234 %prep
235 %setup -q
236 %patch0 -p1
237 %patch1 -p1
238 %patch2 -p1
239 %patch3 -p1
240
241 %build
242 %{__libtoolize}
243 %{__aclocal}
244 %{__autoconf}
245 %{__automake}
246 %configure \
247         --enable-static \
248         %{?with_apidocs:--enable-gtk-doc} \
249         --with-html-dir=%{_gtkdocdir} \
250         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
251         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
252         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
253
254 %{__make} \
255         MOZILLA_HOME=%{_libdir}/mozilla \
256         pythondir=%{py_sitedir}
257
258 %install
259 rm -rf $RPM_BUILD_ROOT
260 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
261 install -d $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart
262
263 %{__make} install \
264         DESTDIR=$RPM_BUILD_ROOT \
265         pythondir=%{py_sitedir}
266
267 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart
268
269 # Kill useless files
270 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.16/extensions/*.{la,a} \
271         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
272
273 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
274 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
275
276 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
277
278 %find_lang %{name}
279
280 %clean
281 rm -rf $RPM_BUILD_ROOT
282
283 %pre crawl-system
284 %groupadd -g 166 -r -f beagleindex
285 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
286
287 %postun crawl-system
288 if [ "$1" = "0" ]; then
289         %userremove beagleindex
290         %groupremove beagleindex
291 fi
292
293 %post   libs -p /sbin/ldconfig
294 %postun libs -p /sbin/ldconfig
295
296 %files -f %{name}.lang
297 %defattr(644,root,root,755)
298 %doc AUTHORS COPYING ChangeLog NEWS README
299 %attr(755,root,root) %{_bindir}/beagle-config
300 %attr(755,root,root) %{_bindir}/beagled
301 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
302 %attr(755,root,root) %{_bindir}/beagle-extract-content
303 %attr(755,root,root) %{_bindir}/beagle-index-info
304 %attr(755,root,root) %{_bindir}/beagle-index-url
305 %attr(755,root,root) %{_bindir}/beagle-info
306 %attr(755,root,root) %{_bindir}/beagle-ping
307 %attr(755,root,root) %{_bindir}/beagle-query
308 %attr(755,root,root) %{_bindir}/beagle-shutdown
309 %attr(755,root,root) %{_bindir}/beagle-status
310 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
311 %attr(755,root,root) %{_libdir}/%{name}/*.exe
312 %dir %{_libdir}/%{name}
313 %dir %{_libdir}/%{name}/Backends
314 %dir %{_libdir}/%{name}/Filters
315 %{_libdir}/%{name}/*.dll
316 %{_libdir}/%{name}/*.dll.config
317 %{_libdir}/%{name}/Filters/*.dll
318 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
319 %{_mandir}/man*/*
320
321 %files libs
322 %defattr(644,root,root,755)
323 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
324
325 %files devel
326 %defattr(644,root,root,755)
327 %attr(755,root,root) %{_libdir}/*.so
328 %{_includedir}/libbeagle
329 %{_libdir}/*.la
330 %{_pkgconfigdir}/*
331
332 %files static
333 %defattr(644,root,root,755)
334 %{_libdir}/*.a
335
336 %if %{with apidocs}
337 %files apidocs
338 %defattr(644,root,root,755)
339 %{_gtkdocdir}/beagle
340 %endif
341
342 %files crawl-system
343 %defattr(644,root,root,755)
344 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
345 %dir %{_sysconfdir}/beagle
346 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
347 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
348 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
349 %attr(755,root,root) %{_sbindir}/*
350
351 %if %{with evolution}
352 %files evolution
353 %defattr(644,root,root,755)
354 %{_libdir}/%{name}/Backends/Evolution*.dll
355 %endif
356
357 %files thunderbird
358 %defattr(644,root,root,755)
359 %{_libdir}/%{name}/Backends/Thunderbird*.dll
360
361 %if %{with epiphany}
362 %files -n epiphany-extension-beagle
363 %defattr(644,root,root,755)
364 %doc epiphany-extension/README
365 %attr(755,root,root) %{_libdir}/epiphany/2.16/extensions/libbeagleextension.so*
366 %{_libdir}/epiphany/2.16/extensions/*.xml
367 %endif
368
369 %if %{with python}
370 %files -n python-%{name}
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{py_sitedir}/*.so
373 %endif
374
375 %if %{with gui}
376 %files search-gui
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_bindir}/beagle-contactviewer
379 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
380 %attr(755,root,root) %{_bindir}/beagle-search
381 %attr(755,root,root) %{_bindir}/beagle-settings
382 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
383 %{_pixmapsdir}/*.png
384 %{_desktopdir}/*.desktop
385 %endif
386
387 %files startup
388 %defattr(644,root,root,755)
389 %{_sysconfdir}/xdg/autostart/beagle-autostart.desktop
This page took 0.089679 seconds and 3 git commands to generate.