]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - add qyoto based settings (requires new packages)
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # don't build API documentation
8 %bcond_with     avahi           # enable Avahi support
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 # required epiphany with python support (2009.06.06 removed permanently from epiphany)
14 %bcond_with     epiphany        # don't build epiphany extension
15 %bcond_without  thunderbird     # use Thunderbird backend
16 #
17 %if !%{with gui}
18 %undefine       with_evolution
19 %endif
20
21 %include        /usr/lib/rpm/macros.mono
22 Summary:        Beagle - An indexing subsystem
23 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
24 Name:           beagle
25 Version:        0.3.9
26 Release:        7
27 License:        Various
28 Group:          Libraries
29 Source0:        http://ftp.gnome.org/pub/GNOME/sources/beagle/0.3/%{name}-%{version}.tar.bz2
30 # Source0-md5:  b73c12423d2d67133dbb05933f4c8fe1
31 Patch0:         %{name}-desktop.patch
32 Patch1:         %{name}-crawl.patch
33 Patch2:         %{name}-configure.patch
34 Patch3:         %{name}-use-xdg-open.patch
35 Patch4:         %{name}-epiphany.patch
36 Patch5:         %{name}-gmime-2.4.patch
37 Patch6:         %{name}-sqlite.patch
38 Patch7:         %{name}-mono28.patch
39 URL:            http://beagle-project.org/Main_Page
40 BuildRequires:  autoconf >= 2.52
41 BuildRequires:  automake
42 BuildRequires:  chmlib-devel
43 %{?with_avahi:BuildRequires:    dotnet-avahi-devel >= 0.6.10}
44 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.13.3}
45 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
46 BuildRequires:  dotnet-gmime-sharp-devel >= 2.3.5
47 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
48 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
49 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3.0
50 BuildRequires:  dotnet-ndesk-dbus-sharp-devel >= 0.6.0
51 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.22.0}
52 BuildRequires:  gettext-tools
53 BuildRequires:  intltool >= 0.40.0
54 BuildRequires:  libtool
55 BuildRequires:  mono-csharp >= 1.2.4
56 BuildRequires:  mono-devel >= 1.2.4
57 BuildRequires:  pkgconfig
58 BuildRequires:  sqlite3-devel >= 3.3.9
59 BuildRequires:  taglib-sharp-devel
60 BuildRequires:  wv-devel >= 1.2.4
61 BuildRequires:  xorg-lib-libXScrnSaver-devel
62 BuildRequires:  zip
63 # GUI BRs
64 %if %{with gui}
65 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
66 BuildRequires:  gtk+2-devel >= 2:2.10.10
67 BuildRequires:  librsvg-devel >= 1:2.16.1
68 BuildRequires:  rpm-pythonprov
69 %endif
70 Requires:       dotnet-gmime-sharp >= 2.3.5
71 Requires:       dotnet-gsf-sharp
72 Requires:       shared-mime-info
73 Requires:       sqlite3
74 Requires:       xdg-utils
75 Obsoletes:      beagle-libs
76 Obsoletes:      beagle-static
77 # sr@Latn vs. sr@latin
78 Conflicts:      glibc-misc < 6:2.7
79 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
80 ExcludeArch:    i386
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 Beagle is an indexing sub-system and search aggregator built on top of
85 Lucene.Net.
86
87 %description -l pl.UTF-8
88 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
89 bazie Lucene.Net.
90
91 %package debug
92 Summary:        Debug files for the Mono part of Beagle
93 Summary(pl.UTF-8):      Pliki debugujące dla części Mono Beagle'a
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96
97 %description debug
98 Debug files for the Mono part of Beagle.
99
100 %description debug -l pl.UTF-8
101 Pliki debugujące dla części Mono Beagle'a.
102
103 %package devel
104 Summary:        Beagle development files
105 Summary(pl.UTF-8):      Pliki programistyczne Beagle
106 Group:          Development/Libraries
107 Requires:       %{name} = %{version}-%{release}
108
109 %description devel
110 Beagle development files.
111
112 %description devel -l pl.UTF-8
113 Pliki programistyczne Beagle.
114
115 %package apidocs
116 Summary:        libbeagle API documentation
117 Summary(pl.UTF-8):      Dokumentacja API libbeagle
118 Group:          Documentation
119 Requires:       gtk-doc-common
120
121 %description apidocs
122 libbeagle API documentation.
123
124 %description apidocs -l pl.UTF-8
125 Dokumentacja API libbeagle.
126
127 %package crawl-system
128 Summary:        Beagle crawl system
129 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
130 Group:          Applications/System
131 Requires:       crondaemon
132 Provides:       group(beagleindex)
133 Provides:       user(beagleindex)
134
135 %description crawl-system
136 Beagle crawl system.
137
138 %description crawl-system -l pl.UTF-8
139 System przeszukujący beagle-crawl.
140
141 %package search-gui
142 Summary:        GNOME based Beagle GUI
143 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
144 Group:          Libraries/Python
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       gtk+2 >= 2:2.10.10
147
148 %description search-gui
149 GNOME based Beagle GUI.
150
151 %description search-gui -l pl.UTF-8
152 Oparty na GNOME graficzny interfejs dla Beagle.
153
154 %package startup
155 Summary:        Automatic startup integration for Beagle
156 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
157 Group:          X11/Applications
158 Requires:       %{name} = %{version}-%{release}
159 Obsoletes:      beagle-gnome
160
161 %description startup
162 Automatic session startup integration for Beagle.
163
164 %description startup -l pl.UTF-8
165 Integracja funkcji automatycznego startu Beagle.
166
167 %package webinterface
168 Summary:        A web interface for Beagle
169 Summary(pl.UTF-8):      Interfejs sieciowy dla Beagle
170 Group:          Applications
171 Requires:       %{name} = %{version}-%{release}
172
173 %description webinterface
174 An AJAX interface that allows users to search for data through their
175 web browser.
176
177 %description webinterface -l pl.UTF-8
178 AJAX-owy interfejs pozwalający użytkownikom wyszukiwać dane za pomocą
179 przeglądarki internetowej.
180
181 %package evolution
182 Summary:        Beagle Evolution backend
183 Summary(pl.UTF-8):      Backend Beagle dla Evolution
184 Group:          X11/Applications/Networking
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       dotnet-evolution-sharp >= 0.11.1
187 Requires:       evolution >= 2.10.0
188
189 %description evolution
190 Beagle Evolution backend.
191
192 %description evolution -l pl.UTF-8
193 Backend Beagle dla Evolution.
194
195 %package icedove
196 Summary:        Beagle Icedove backend
197 Summary(pl.UTF-8):      Backend Beagle dla Icedove
198 Group:          X11/Applications/Networking
199 Requires:       %{name} = %{version}-%{release}
200 Requires:       icedove
201 Provides:       beagle-thunderbird
202 Obsoletes:      beagle-thunderbird
203
204 %description icedove
205 Beagle Icedove backend.
206
207 %description icedove -l pl.UTF-8
208 Backend Beagle dla Icedove.
209
210 %package -n epiphany-extension-beagle
211 Summary:        Epiphany extension - beagle
212 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
213 Group:          X11/Applications/Networking
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       epiphany-extensions >= 2.22.0
216
217 %description -n epiphany-extension-beagle
218 Epiphany extension that allows Beagle to index every page the user
219 views.
220
221 %description -n epiphany-extension-beagle -l pl.UTF-8
222 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
223 odwiedzaną stronę.
224
225 %package -n iceweasel-extension-beagle
226 Summary:        Iceweasel extension - beagle
227 Summary(pl.UTF-8):      Rozszerzenie dla przeglądarki Iceweasel - beagle
228 Group:          X11/Applications/Networking
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       iceweasel
231 Provides:       mozilla-firefox-extension-beagle
232 Obsoletes:      mozilla-firefox-extension-beagle
233
234 %description -n iceweasel-extension-beagle
235 Iceweasel extension that allows Beagle to index every page the user
236 views.
237
238 %description -n iceweasel-extension-beagle -l pl.UTF-8
239 Rozszerzenie dla przeglądarki Iceweasel sprawiające, że Beagle
240 indeksuje każdą odwiedzaną stronę.
241
242 %prep
243 %setup -q
244 %patch0 -p1
245 %patch1 -p1
246 %patch2 -p1
247 %patch3 -p1
248 %patch4 -p1
249 %patch5 -p1
250 %patch6 -p1
251 %patch7 -p1
252
253 %build
254 %{__intltoolize}
255 %{__libtoolize}
256 %{__aclocal}
257 %{__autoconf}
258 %{__autoheader}
259 %{__automake}
260 %configure \
261         --disable-static \
262         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
263         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution \
264         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
265         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird \
266         --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi
267
268 %{__make} -j1
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
273
274 %{__make} install \
275         DESTDIR=$RPM_BUILD_ROOT
276
277 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*glue.la
278
279 dest=$RPM_BUILD_ROOT%{_datadir}/iceweasel/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
280 install -d $dest $dest/chrome
281 install firefox-extension/{chrome.manifest,install.rdf} $dest
282 cp -r firefox-extension/chrome/* $dest/chrome
283
284 %if %{with thunderbird}
285 tdest=$RPM_BUILD_ROOT%{_libdir}/icedove/extensions/\{b656ef18-fd76-45e6-95cc-8043f26361e7\}
286 install -d $tdest
287 install thunderbird-extension/{chrome.manifest,install.rdf} $tdest
288 cp -r thunderbird-extension/{chrome,components,defaults} $tdest
289 %endif
290
291 %if %{with gui}
292 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
293         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
294 %find_lang %{name}
295 %else
296 touch %{name}.lang
297 %endif
298
299 %clean
300 rm -rf $RPM_BUILD_ROOT
301
302 %pre crawl-system
303 %groupadd -g 166 -r -f beagleindex
304 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
305
306 %postun crawl-system
307 if [ "$1" = "0" ]; then
308         %userremove beagleindex
309         %groupremove beagleindex
310 fi
311
312 %files -f %{name}.lang
313 %defattr(644,root,root,755)
314 %doc AUTHORS COPYING ChangeLog NEWS README
315 %attr(755,root,root) %{_bindir}/beagle-config
316 %{?with_gsf:%attr(755,root,root) %{_bindir}/beagle-doc-extractor}
317 %attr(755,root,root) %{_bindir}/beagle-extract-content
318 %attr(755,root,root) %{_bindir}/beagle-index-info
319 %attr(755,root,root) %{_bindir}/beagle-info
320 %attr(755,root,root) %{_bindir}/beagle-ping
321 %attr(755,root,root) %{_bindir}/beagle-query
322 %attr(755,root,root) %{_bindir}/beagle-shutdown
323 %attr(755,root,root) %{_bindir}/beagle-static-query
324 %attr(755,root,root) %{_bindir}/beagle-status
325 %attr(755,root,root) %{_bindir}/beagled
326 %attr(755,root,root) %{_bindir}/blocate
327 %attr(755,root,root) %{_libdir}/%{name}/*.exe
328 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
329 %dir %{_sysconfdir}/beagle
330 %dir %{_sysconfdir}/beagle/config-files
331 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/blocate.conf
332 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/query-mapping.xml
333 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/BeagleSearch.xml
334 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Daemon.xml
335 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/FilesQueryable.xml
336 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/GoogleBackends.xml
337 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Networking.xml
338 %dir %{_libdir}/%{name}
339 %dir %{_libdir}/%{name}/Backends
340 %dir %{_libdir}/%{name}/Filters
341 %{_libdir}/%{name}/*.dll
342 %{_libdir}/%{name}/*.dll.config
343 %{_libdir}/%{name}/Backends/GoogleBackends*.dll
344 %{_libdir}/%{name}/Filters/*.dll
345 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
346 %{_mandir}/man1/beagle-config.1*
347 %{_mandir}/man1/beagle-info.1*
348 %{_mandir}/man1/beagle-ping.1*
349 %{_mandir}/man1/beagle-query.1*
350 %{_mandir}/man1/beagle-shutdown.1*
351 %{_mandir}/man1/beagle-status.1*
352 %{_mandir}/man1/beagled.1*
353 %{_mandir}/man8/beagle-doc-extractor.8*
354 %{_mandir}/man8/beagle-index-info.8*
355
356 %files debug
357 %defattr(644,root,root,755)
358 %{_libdir}/%{name}/Backends/*.mdb
359 %{_libdir}/%{name}/Filters/*.mdb
360 %{_libdir}/%{name}/*.mdb
361
362 %files devel
363 %defattr(644,root,root,755)
364 %{_pkgconfigdir}/beagle-0.0.pc
365 %{?with_gui:%{_pkgconfigdir}/beagle-ui-0.0.pc}
366 %{_pkgconfigdir}/beagle-daemon.pc
367
368 %if %{with apidocs}
369 %files apidocs
370 %defattr(644,root,root,755)
371 %{_prefix}/lib/monodoc/sources/*
372 %endif
373
374 %files crawl-system
375 %defattr(644,root,root,755)
376 %dir %{_sysconfdir}/beagle/crawl-rules
377 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-applications
378 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-documentation
379 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-executables
380 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-manpages
381 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-monodoc
382 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-windows
383 # XXX: samples not here
384 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/external-filters.xml.sample
385 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/beagle-crawl-system
386 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
387 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
388 %attr(755,root,root) %{_sbindir}/beagle-build-index
389 %attr(755,root,root) %{_sbindir}/beagle-dump-index
390 %attr(755,root,root) %{_sbindir}/beagle-manage-index
391 %attr(755,root,root) %{_sbindir}/beagle-master-delete-button
392 %attr(755,root,root) %{_sbindir}/beagle-removable-index
393 %{_mandir}/man8/beagle-dump-index.8*
394 %{_mandir}/man8/beagle-build-index.8*
395 %{_mandir}/man8/beagle-extract-content.8*
396 %{_mandir}/man8/beagle-manage-index.8*
397
398 %if %{with gui}
399 %files search-gui
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
402 %attr(755,root,root) %{_bindir}/beagle-search
403 %attr(755,root,root) %{_bindir}/beagle-settings
404 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
405 %attr(755,root,root) %{_libdir}/%{name}/keygrabber.py
406 %{_mandir}/man1/beagle-search.1*
407 %{_mandir}/man1/beagle-settings.1*
408 %{_mandir}/man8/beagle-imlogviewer.8*
409 %{_desktopdir}/*.desktop
410 %endif
411
412 %files startup
413 %defattr(644,root,root,755)
414 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
415 %{?with_gui:%{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop}
416
417 %files webinterface
418 %defattr(644,root,root,755)
419 %{_datadir}/%{name}
420
421 %if %{with evolution}
422 %files evolution
423 %defattr(644,root,root,755)
424 %{_libdir}/%{name}/Backends/Evolution*.dll
425 %endif
426
427 %if %{with thunderbird}
428 %files icedove
429 %defattr(644,root,root,755)
430 %{_libdir}/%{name}/Backends/Thunderbird*.dll
431 %{_libdir}/icedove/extensions/{b656ef18-fd76-45e6-95cc-8043f26361e7}
432 %endif
433
434 %if %{with epiphany}
435 %files -n epiphany-extension-beagle
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/epiphany/2.26/extensions/beagle.py
438 %{_libdir}/epiphany/2.26/extensions/*.ephy-extension
439 %endif
440
441 %files -n iceweasel-extension-beagle
442 %defattr(644,root,root,755)
443 %{_datadir}/iceweasel/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
This page took 0.066333 seconds and 3 git commands to generate.