]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- glue libraries are dlopened by mono; no point in -libs and -static
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - add qyoto based settings (requires new packages)
5 #       - replace epiphany-extension hack
6 #
7 %include        /usr/lib/rpm/macros.mono
8 #
9 # Conditional build:
10 %bcond_without  apidocs         # don't build API documentation
11 %bcond_with     avahi           # enable Avahi support
12 %bcond_without  evolution       # don't include evolution support
13 %bcond_without  galago          # build without galago support
14 %bcond_without  gsf             # build without libgsf support
15 %bcond_without  gui             # don't build GNOME based GUI
16 %bcond_without  python          # don't build python libraries
17 %bcond_without  epiphany        # don't build epiphany extension
18 %bcond_without  thunderbird     # use Thunderbird backend
19 #
20 %if !%{with gui}
21 %undefine       with_evolution
22 %endif
23 #
24 Summary:        Beagle - An indexing subsystem
25 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
26 Name:           beagle
27 Version:        0.3.3
28 Release:        1
29 License:        Various
30 Group:          Libraries
31 Source0:        http://ftp.gnome.org/pub/GNOME/sources/beagle/0.3/%{name}-%{version}.tar.bz2
32 # Source0-md5:  c1b6c340c72a70e33212c85513bc23f2
33 Patch0:         %{name}-desktop.patch
34 Patch1:         %{name}-crawl.patch
35 Patch2:         %{name}-configure.patch
36 URL:            http://beagle-project.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  chmlib-devel
40 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.13.3}
41 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
42 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
43 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
44 #BuildRequires: dotnet-gst-sharp-devel
45 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
46 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3.0
47 BuildRequires:  dotnet-ndesk-dbus-sharp-devel >= 0.6.0
48 %if %{with epiphany}
49 BuildRequires:  epiphany-devel >= 2.20.0
50 %endif
51 BuildRequires:  gtk+2-devel >= 2:2.10.10
52 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
53 BuildRequires:  libexif-devel >= 0.6.13
54 BuildRequires:  libpng-devel
55 BuildRequires:  librsvg-devel >= 1:2.16.1
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel >= 1:2.6.27
58 BuildRequires:  mono-csharp >= 1.1.13.5
59 BuildRequires:  perl-XML-Parser
60 BuildRequires:  pkgconfig
61 BuildRequires:  python-devel
62 %{?with_python:BuildRequires:   python-pygtk-devel >= 2:2.10.4}
63 BuildRequires:  sqlite3-devel >= 3.3.4
64 BuildRequires:  wv-devel >= 1.2.4
65 BuildRequires:  xorg-lib-libXScrnSaver-devel
66 BuildRequires:  zip
67 # GUI BRs
68 %if %{with gui}
69 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
70 BuildRequires:  gnome-vfs2-devel >= 2.18.0.1
71 %endif
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       dotnet-gmime-sharp >= 2.2.3
74 Requires:       dotnet-gsf-sharp
75 Requires:       sqlite3
76 Obsoletes:      beagle-libs
77 Obsoletes:      beagle-static
78 Obsoletes:      python-beagle
79 # sr@Latn vs. sr@latin
80 Conflicts:      glibc-misc < 6:2.7
81 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
82 ExcludeArch:    i386
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %description
86 Beagle is an indexing sub-system and search aggregator built on top of
87 Lucene.Net.
88
89 %description -l pl.UTF-8
90 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
91 bazie Lucene.Net.
92
93 %package debug
94 Summary:        Debug files for the Mono part of Beagle
95 Summary(pl.UTF-8):      Pliki debugujące dla części Mono Beagle'a
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description debug
100 Debug files for the Mono part of Beagle.
101
102 %description -l pl.UTF-8
103 Pliki debugujące dla części Mono Beagle'a.
104
105 %package devel
106 Summary:        Beagle development files
107 Summary(pl.UTF-8):      Pliki programistyczne Beagle
108 Group:          Development/Libraries
109 Requires:       %{name}-libs = %{version}-%{release}
110
111 %description devel
112 Beagle development files.
113
114 %description devel -l pl.UTF-8
115 Pliki programistyczne Beagle.
116
117 %package apidocs
118 Summary:        libbeagle API documentation
119 Summary(pl.UTF-8):      Dokumentacja API libbeagle
120 Group:          Documentation
121 Requires:       gtk-doc-common
122
123 %description apidocs
124 libbeagle API documentation.
125
126 %description apidocs -l pl.UTF-8
127 Dokumentacja API libbeagle.
128
129 %package crawl-system
130 Summary:        Beagle crawl system
131 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
132 Group:          Applications/System
133 Requires:       crondaemon
134 Provides:       group(beagleindex)
135 Provides:       user(beagleindex)
136
137 %description crawl-system
138 Beagle crawl system.
139
140 %description crawl-system -l pl.UTF-8
141 System przeszukujący beagle-crawl.
142
143 %package search-gui
144 Summary:        GNOME based Beagle GUI
145 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
146 Group:          Libraries/Python
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       gtk+2 >= 2:2.10.10
149
150 %description search-gui
151 GNOME based Beagle GUI.
152
153 %description search-gui -l pl.UTF-8
154 Oparty na GNOME graficzny interfejs dla Beagle.
155
156 %package startup
157 Summary:        Automatic startup integration for Beagle
158 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
159 Group:          X11/Applications
160 Requires:       %{name} = %{version}-%{release}
161 Obsoletes:      beagle-gnome
162
163 %description startup
164 Automatic session startup integration for Beagle.
165
166 %description startup -l pl.UTF-8
167 Integracja funkcji automatycznego startu Beagle.
168
169 %package webinterface
170 Summary:        A web interface for Beagle
171 Summary(pl.UTF-8):      Interfejs sieciowy dla Beagle
172 Group:          Applications
173 Requires:       %{name} = %{version}-%{release}
174
175 %description webinterface
176 An AJAX interface that allows users to search for data through their
177 web browser.
178
179 %description webinterface -l pl.UTF-8
180 AJAX-owy interfejs pozwalający użytkownikom wyszukiwać dane za pomocą
181 przeglądarki internetowej.
182
183 %package evolution
184 Summary:        Beagle Evolution backend
185 Summary(pl.UTF-8):      Backend Beagle dla Evolution
186 Group:          X11/Applications/Networking
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       dotnet-evolution-sharp >= 0.11.1
189 Requires:       evolution >= 2.10.0
190
191 %description evolution
192 Beagle Evolution backend.
193
194 %description evolution -l pl.UTF-8
195 Backend Beagle dla Evolution.
196
197 %package thunderbird
198 Summary:        Beagle Mozilla Thunderbird backend
199 Summary(pl.UTF-8):      Backend Beagle dla Mozilli Thunderbird
200 Group:          X11/Applications/Networking
201 Requires:       %{name} = %{version}-%{release}
202
203 %description thunderbird
204 Beagle Mozilla Thunderbird backend.
205
206 %description thunderbird -l pl.UTF-8
207 Backend Beagle dla Mozilli Thunderbird.
208
209 %package -n epiphany-extension-beagle
210 Summary:        Epiphany extension - beagle
211 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
212 Group:          X11/Applications/Networking
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       epiphany-extensions >= 2.20.0
215
216 %description -n epiphany-extension-beagle
217 Epiphany extension that allows Beagle to index every page the user
218 views.
219
220 %description -n epiphany-extension-beagle -l pl.UTF-8
221 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
222 odwiedzaną stronę.
223
224 %package -n mozilla-firefox-extension-beagle
225 Summary:        Mozilla Firefox extension - beagle
226 Summary(pl.UTF-8):      Rozszerzenie dla przeglądarki Mozilla Firefox - beagle
227 Group:          X11/Applications/Networking
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       mozilla-firefox >= 2.0.0.1-2
230
231 %description -n mozilla-firefox-extension-beagle
232 Mozilla Firefox extension that allows Beagle to index every page the
233 user views.
234
235 %description -n mozilla-firefox-extension-beagle -l pl.UTF-8
236 Rozszerzenie dla przeglądarki Mozilla Firefox sprawiające, że Beagle
237 indeksuje każdą odwiedzaną stronę.
238
239 %prep
240 %setup -q
241 %patch0 -p1
242 %patch1 -p1
243 %patch2 -p1
244
245 %build
246 %{__intltoolize}
247 %{__libtoolize}
248 %{__aclocal}
249 %{__autoconf}
250 %{__automake}
251 %configure \
252         --disable-static \
253         %{?with_apidocs:--enable-gtk-doc} \
254         --with-html-dir=%{_gtkdocdir} \
255         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
256         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
257         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
258         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird \
259         --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi
260
261 %{__make}
262
263 %install
264 rm -rf $RPM_BUILD_ROOT
265 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
266
267 %{__make} install \
268         DESTDIR=$RPM_BUILD_ROOT \
269         pythondir=%{py_sitedir} \
270         monodocdir=%{_libdir}/monodoc/sources
271
272 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*glue.la
273
274 dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
275 install -d $dest $dest/chrome
276 install firefox-extension/{chrome.manifest,install.rdf} $dest
277 cp -r firefox-extension/chrome/* $dest/chrome
278
279 %if %{with epiphany}
280 install -d $RPM_BUILD_ROOT%{_libdir}/epiphany/2.20/extensions
281 sed -e "s|\@localedir\@|\%{_localedir}|g" \
282         < epiphany-extension/beagle.py.in > epiphany-extension/beagle.py
283 install epiphany-extension/beagle.py $RPM_BUILD_ROOT%{_libdir}/epiphany/2.20/extensions/beagle.py
284 install epiphany-extension/beagle.ephy-extension.in $RPM_BUILD_ROOT%{_libdir}/epiphany/2.20/extensions/beagle.ephy-extension
285 %endif
286
287 %if %{with thunderbird}
288 tdest=$RPM_BUILD_ROOT%{_libdir}/mozilla-thunderbird/extensions/\{b656ef18-fd76-45e6-95cc-8043f26361e7\}
289 install -d $tdest
290 install thunderbird-extension/{chrome.manifest,install.rdf} $tdest
291 cp -r thunderbird-extension/{chrome,components,defaults} $tdest
292 %endif
293
294 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
295         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
296 %find_lang %{name}
297
298 %clean
299 rm -rf $RPM_BUILD_ROOT
300
301 %pre crawl-system
302 %groupadd -g 166 -r -f beagleindex
303 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
304
305 %postun crawl-system
306 if [ "$1" = "0" ]; then
307         %userremove beagleindex
308         %groupremove beagleindex
309 fi
310
311 %files -f %{name}.lang
312 %defattr(644,root,root,755)
313 %doc AUTHORS COPYING ChangeLog NEWS README
314 %attr(755,root,root) %{_bindir}/beagle-config
315 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
316 %attr(755,root,root) %{_bindir}/beagle-extract-content
317 %attr(755,root,root) %{_bindir}/beagle-index-info
318 %attr(755,root,root) %{_bindir}/beagle-info
319 %attr(755,root,root) %{_bindir}/beagle-ping
320 %attr(755,root,root) %{_bindir}/beagle-query
321 %attr(755,root,root) %{_bindir}/beagle-shutdown
322 %attr(755,root,root) %{_bindir}/beagle-status
323 %attr(755,root,root) %{_bindir}/beagled
324 %attr(755,root,root) %{_libdir}/%{name}/*.exe
325 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
326 %dir %{_libdir}/%{name}
327 %dir %{_libdir}/%{name}/Backends
328 %dir %{_libdir}/%{name}/Filters
329 %{_libdir}/%{name}/*.dll
330 %{_libdir}/%{name}/*.dll.config
331 %{_libdir}/%{name}/Filters/*.dll
332 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
333 %{_mandir}/man1/beagle-config.1*
334 %{_mandir}/man1/beagle-query.1*
335 %{_mandir}/man1/beagle-search.1*
336 %{_mandir}/man1/beagle-shutdown.1*
337 %{_mandir}/man1/beagle-status.1*
338 %{_mandir}/man1/beagled.1*
339
340 %files debug
341 %defattr(644,root,root,755)
342 %{_libdir}/%{name}/Backends/*.mdb
343 %{_libdir}/%{name}/Filters/*.mdb
344 %{_libdir}/%{name}/*.mdb
345
346 %files devel
347 %defattr(644,root,root,755)
348 %{_pkgconfigdir}/beagle-0.0.pc
349 %{_pkgconfigdir}/beagle-ui-0.0.pc
350 %{_pkgconfigdir}/beagle-daemon.pc
351
352 %if %{with apidocs}
353 %files apidocs
354 %defattr(644,root,root,755)
355 %{_libdir}/monodoc/sources/*
356 %endif
357
358 %files crawl-system
359 %defattr(644,root,root,755)
360 %dir %{_sysconfdir}/beagle
361 %dir %{_sysconfdir}/beagle/config-files
362 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/BeagleSearch.xml
363 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Daemon.xml
364 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/FilesQueryable.xml
365 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Networking.xml
366 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-applications
367 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-documentation
368 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-manpages
369 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-monodoc
370 # XXX: samples not here
371 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/external-filters.xml.sample
372 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/beagle-crawl-system
373 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
374 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
375 %attr(755,root,root) %{_sbindir}/beagle-build-index
376 %attr(755,root,root) %{_sbindir}/beagle-dump-index
377 %attr(755,root,root) %{_sbindir}/beagle-manage-index
378 %attr(755,root,root) %{_sbindir}/beagle-master-delete-button
379 %{_mandir}/man1/beagle-dump-index.1*
380 %{_mandir}/man8/beagle-build-index.8*
381 %{_mandir}/man8/beagle-extract-content.8*
382 %{_mandir}/man8/beagle-manage-index.8*
383
384 %if %{with gui}
385 %files search-gui
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
388 %attr(755,root,root) %{_bindir}/beagle-search
389 %attr(755,root,root) %{_bindir}/beagle-settings
390 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
391 %{_mandir}/man8/beagle-imlogviewer.8*
392 %{_desktopdir}/*.desktop
393 %endif
394
395 %files startup
396 %defattr(644,root,root,755)
397 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
398 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
399
400 %files webinterface
401 %defattr(644,root,root,755)
402 %{_datadir}/%{name}
403
404 %if %{with evolution}
405 %files evolution
406 %defattr(644,root,root,755)
407 %{_libdir}/%{name}/Backends/Evolution*.dll
408 %endif
409
410 %if %{with thunderbird}
411 %files thunderbird
412 %defattr(644,root,root,755)
413 %{_libdir}/%{name}/Backends/Thunderbird*.dll
414 %{_libdir}/mozilla-thunderbird/extensions/{b656ef18-fd76-45e6-95cc-8043f26361e7}
415 %endif
416
417 %if %{with epiphany}
418 %files -n epiphany-extension-beagle
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_libdir}/epiphany/2.20/extensions/beagle.py
421 %{_libdir}/epiphany/2.20/extensions/*.ephy-extension
422 %endif
423
424 %files -n mozilla-firefox-extension-beagle
425 %defattr(644,root,root,755)
426 %{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
This page took 0.087365 seconds and 3 git commands to generate.