]> git.pld-linux.org Git - packages/bctoolbox.git/blob - bctoolbox.spec
- updated to 4.5.15
[packages/bctoolbox.git] / bctoolbox.spec
1 #
2 # Conditional build:
3 %bcond_without  dtls_srtp       # DTLS SRTP support
4 %bcond_without  static_libs     # static libraries
5
6 %if %{with dtls_srtp}
7 %define         mbedtls_ver     2.26.0-2
8 %else
9 %define         mbedtls_ver     2
10 %endif
11 Summary:        Utility library for software from Belledonne Communications
12 Summary(pl.UTF-8):      Biblioteka narzędziowa dla oprogramowania firmy Belledonne Communications
13 Name:           bctoolbox
14 Version:        4.5.15
15 Release:        1
16 License:        GPL v3+
17 Group:          Libraries
18 #Source0Download: https://gitlab.linphone.org/BC/public/bctoolbox/tags
19 Source0:        https://gitlab.linphone.org/BC/public/bctoolbox/-/archive/%{version}/%{name}-%{version}.tar.bz2
20 # Source0-md5:  479fd5eaa6242d8622f957744794f541
21 URL:            https://linphone.org/
22 # with junit xml support
23 BuildRequires:  bcunit-devel >= 3.0.2-3.20200822
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  libdecaf-devel
26 BuildRequires:  libstdc++-devel >= 6:4.7
27 BuildRequires:  mbedtls-devel >= %{mbedtls_ver}
28 BuildRequires:  sed >= 4.0
29 Requires:       mbedtls >= %{mbedtls_ver}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Utilities library used by Belledonne Communications softwares like
34 belle-sip, mediastreamer2 and linphone.
35
36 %description -l pl.UTF-8
37 Biblioteka narzędziowa używana w oprogramowaniu firmy Belledonne
38 Communications, takim jak belle-sip, mediastreamer2 czy linphone.
39
40 %package devel
41 Summary:        Header files for bctoolbox libraries
42 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek bctoolbox
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       libdecaf-devel
46 Requires:       mbedtls-devel >= %{mbedtls_ver}
47
48 %description devel
49 Header files for bctoolbox libraries.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe bibliotek bctoolbox.
53
54 %package static
55 Summary:        Static bctoolbox libraries
56 Summary(pl.UTF-8):      Statyczne biblioteki bctoolbox
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static bctoolbox libraries.
62
63 %description static -l pl.UTF-8
64 Statyczne biblioteki bctoolbox.
65
66 %prep
67 %setup -q
68
69 %build
70 install -d build
71 cd build
72 %cmake .. \
73         %{!?with_static_libs:-DENABLE_STATIC=OFF}
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # disable completeness check incompatible with split packaging
84 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_datadir}/bctoolbox/cmake/bctoolboxTargets.cmake
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc CHANGELOG.md README.md
95 %attr(755,root,root) %{_libdir}/libbctoolbox.so.1
96 %attr(755,root,root) %{_libdir}/libbctoolbox-tester.so.1
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/libbctoolbox.so
101 %attr(755,root,root) %{_libdir}/libbctoolbox-tester.so
102 %{_includedir}/bctoolbox
103 %{_pkgconfigdir}/bctoolbox.pc
104 %{_pkgconfigdir}/bctoolbox-tester.pc
105 %dir %{_datadir}/bctoolbox
106 %{_datadir}/bctoolbox/cmake
107
108 %if %{with static_libs}
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libbctoolbox.a
112 %{_libdir}/libbctoolbox-tester.a
113 %endif
This page took 0.121583 seconds and 3 git commands to generate.