]> git.pld-linux.org Git - packages/bcg729.git/blame - bcg729.spec
- added mediastreamer bcond
[packages/bcg729.git] / bcg729.spec
CommitLineData
a4520443
JB
1#
2# Conditional build:
3%bcond_without mediastreamer # mediastreamer plugin
4
0d00f4af
JB
5Summary: ITU G729 Annex A speech codec library
6Summary(pl.UTF-8): Biblioteka kodeka mowy ITU G729 Annex A
7Name: bcg729
e733dc87 8Version: 1.0.2
8660d09c 9Release: 2
0d00f4af
JB
10License: GPL v2+, ITU G729 patent license may be required
11Group: Libraries
12Source0: http://download-mirror.savannah.gnu.org/releases/linphone/plugins/sources/%{name}-%{version}.tar.gz
e733dc87 13# Source0-md5: 2a3d9b422912024f97a41e56e9e3d357
87915a50 14Patch0: %{name}-lib.patch
0d00f4af 15URL: http://www.linphone.org/eng/documentation/dev/bcg729.html
87915a50
JB
16BuildRequires: autoconf >= 2.63
17BuildRequires: automake
18BuildRequires: libtool >= 2:2
a4520443
JB
19%{?with_mediastreamer:BuildRequires: mediastreamer-devel >= 2.9.0}
20%{?with_mediastreamer:BuildRequires: ortp-devel >= 0.21.0}
0d00f4af
JB
21BuildRequires: pkgconfig
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25bcg729 is an opensource implementation of both encoder and decoder of
26the ITU G729 Annex A speech codec. The library written in C99 is fully
27portable and can be executed on many platforms including both ARM
28processor and x86. libbcg729 supports concurrent channels
29encoding/decoding for multi call application such conferencing. This
30project was initially developed as part of Mediastreamer2, the
31Linphone's media processing engine. So there is also available the
32glue to be integrated in Linphone/Mediastreamer2.
33
34%description -l pl.UTF-8
35bcg729 to implementacja o otwartych źródłach kodera oraz dekorera
36kodeka mowy ITU G729 Annex A. Biblioteka napisana w dialekcie C99 jest
37w pełni przenośna i może być uruchamiana na wielu platformach, w tym
38procesorach ARM i x86. libbcg729 obsługuje jednoczesne
39kodowanie/dekodowanie wielu kanałów dla zastosowań z wieloma
40rozmowami,takich jak konferencje. Ten projekt początkowo był częścią
41Mediastreamera2 - silnika przetwarzania multimediów programu Linphone.
42Dlatego jest też dostępny kod łączący z Linphonem/Mediastreamerem2.
43
44%package devel
45Summary: Header files for bcg729 library
46Summary(pl.UTF-8): Pliki nagłówkowe biblioteki bcg729
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description devel
51Header files for bcg729 library.
52
53%description devel -l pl.UTF-8
54Pliki nagłówkowe biblioteki bcg729.
55
56%package static
57Summary: Static bcg729 library
58Summary(pl.UTF-8): Statyczna biblioteka bcg729
59Group: Development/Libraries
60Requires: %{name}-devel = %{version}-%{release}
61
62%description static
63Static bcg729 library.
64
65%description static -l pl.UTF-8
66Statyczna biblioteka bcg729.
67
68%package -n mediastreamer-plugin-msbcg729
69Summary: ITU G729 Annex A speech codec for mediastreamer
70Summary(pl.UTF-8): Kodek mowy ITU G729 Annex A dla mediastreamera
71Group: Libraries
72Requires: %{name} = %{version}-%{release}
87915a50 73Requires: mediastreamer >= 2.9.0
0d00f4af
JB
74
75%description -n mediastreamer-plugin-msbcg729
76This package supplies the mediastreamer plugin for the ITU G729 Annex
77A speech codec.
78
79%description -n mediastreamer-plugin-msbcg729 -l pl.UTF-8
80Ten pakiet udostępnia wtyczkę mediastreamera do kodeka mowy ITU G729
81Annex A.
82
83%prep
84%setup -q
87915a50 85%patch0 -p1
0d00f4af
JB
86
87%build
87915a50
JB
88%{__libtoolize}
89%{__aclocal} -I m4
90%{__autoconf}
91%{__autoheader}
92%{__automake}
0d00f4af 93%configure \
a4520443 94 %{!?with_mediastreamer:--disable-msplugin} \
0d00f4af
JB
95 --disable-silent-rules
96
97%{__make}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
105# dlopened plugin
106%{__rm} $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins/libmsbcg729.{la,a}
107# obsoleted by pkg-config
108%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbcg729.la
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
118%doc AUTHORS README
119%attr(755,root,root) %{_libdir}/libbcg729.so.*.*.*
120%attr(755,root,root) %ghost %{_libdir}/libbcg729.so.0
121
122%files devel
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_libdir}/libbcg729.so
125%{_includedir}/bcg729
126%{_pkgconfigdir}/libbcg729.pc
127
128%files static
129%defattr(644,root,root,755)
130%{_libdir}/libbcg729.a
131
a4520443 132%if %{with mediastreamer}
0d00f4af
JB
133%files -n mediastreamer-plugin-msbcg729
134%defattr(644,root,root,755)
135%attr(755,root,root) %{_libdir}/mediastreamer/plugins/libmsbcg729.so*
a4520443 136%endif
This page took 0.137357 seconds and 4 git commands to generate.