]> git.pld-linux.org Git - packages/bcfg2.git/blob - bcfg2.spec
- more Requires and BuildRequires
[packages/bcfg2.git] / bcfg2.spec
1 Summary:        Configuration management system
2 Name:           bcfg2
3 Version:        1.0.1
4 Release:        0.1
5 License:        BSD
6 Group:          Applications/System
7 URL:            http://trac.mcs.anl.gov/projects/bcfg2
8 Source0:        ftp://ftp.mcs.anl.gov/pub/bcfg/%{name}-%{version}.tar.gz
9 # Source0-md5:  6fbf36acc5cc58b2504a25c25cad3921
10 BuildRequires:  python-devel
11 BuildRequires:  rpm-pythonprov
12 BuildRequires:  rpmbuild(macros) >= 1.219
13 Requires:       python-modules
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Bcfg2 helps system administrators produce a consistent, reproducible,
19 and verifiable description of their environment, and offers
20 visualization and reporting tools to aid in day-to-day administrative
21 tasks. It is the fifth generation of configuration management tools
22 developed in the Mathematics and Computer Science Division of Argonne
23 National Laboratory.
24
25 It is based on an operational model in which the specification can be
26 used to validate and optionally change the state of clients, but in a
27 feature unique to bcfg2 the client's response to the specification can
28 also be used to assess the completeness of the specification. Using
29 this feature, bcfg2 provides an objective measure of how good a job an
30 administrator has done in specifying the configuration of client
31 systems. Bcfg2 is therefore built to help administrators construct an
32 accurate, comprehensive specification.
33
34 Bcfg2 has been designed from the ground up to support gentle
35 reconciliation between the specification and current client states. It
36 is designed to gracefully cope with manual system modifications.
37
38 Finally, due to the rapid pace of updates on modern networks, client
39 systems are constantly changing; if required in your environment,
40 Bcfg2 can enable the construction of complex change management and
41 deployment strategies.
42
43 %package -n bcfg2-server
44 Summary:        Bcfg2 Server
45 Group:          Networking/Daemons
46 Requires:       bcfg2
47 Requires:       pydoc
48 Requires:       python-lxml
49 Requires:       python-pyOpenSSL
50
51 %description -n bcfg2-server
52 Bcfg2 helps system administrators produce a consistent, reproducible,
53 and verifiable description of their environment, and offers
54 visualization and reporting tools to aid in day-to-day administrative
55 tasks. It is the fifth generation of configuration management tools
56 developed in the Mathematics and Computer Science Division of Argonne
57 National Laboratory.
58
59 It is based on an operational model in which the specification can be
60 used to validate and optionally change the state of clients, but in a
61 feature unique to bcfg2 the client's response to the specification can
62 also be used to assess the completeness of the specification. Using
63 this feature, bcfg2 provides an objective measure of how good a job an
64 administrator has done in specifying the configuration of client
65 systems. Bcfg2 is therefore built to help administrators construct an
66 accurate, comprehensive specification.
67
68 Bcfg2 has been designed from the ground up to support gentle
69 reconciliation between the specification and current client states. It
70 is designed to gracefully cope with manual system modifications.
71
72 Finally, due to the rapid pace of updates on modern networks, client
73 systems are constantly changing; if required in your environment,
74 Bcfg2 can enable the construction of complex change management and
75 deployment strategies.
76
77 %prep
78 %setup -q
79
80 %build
81 export CFLAGS="%{rpmcflags}"
82 %{__python} setup.py build
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 %{__python} setup.py install \
87         --optimize=2 \
88         --root=$RPM_BUILD_ROOT
89
90 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
91 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
92 %py_postclean
93
94 install -d $RPM_BUILD_ROOT%{_bindir}
95 install -d $RPM_BUILD_ROOT%{_sbindir}
96 install -d $RPM_BUILD_ROOT%{_initrddir}
97 install -d $RPM_BUILD_ROOT%{_sysconfdir}/default
98 install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
99 install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
100 install -d $RPM_BUILD_ROOT%{_libdir}/bcfg2
101 %{__mv} $RPM_BUILD_ROOT%{_bindir}/bcfg2* $RPM_BUILD_ROOT%{_sbindir}
102 install debian/bcfg2.init $RPM_BUILD_ROOT/etc/rc.d/init.d/bcfg2
103 install debian/bcfg2-server.init $RPM_BUILD_ROOT/etc/rc.d/init.d/bcfg2-server
104 install debian/bcfg2.default $RPM_BUILD_ROOT%{_sysconfdir}/default/bcfg2
105 install debian/bcfg2-server.default $RPM_BUILD_ROOT%{_sysconfdir}/default/bcfg2-server
106 install debian/bcfg2.cron.daily $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/bcfg2
107 install debian/bcfg2.cron.hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/bcfg2
108 install tools/bcfg2-cron $RPM_BUILD_ROOT%{_libdir}/bcfg2/bcfg2-cron
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post -n bcfg2-server
114 /sbin/chkconfig --add bcfg2-server
115
116 %files -n bcfg2
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_sbindir}/bcfg2
119 %dir %{py_sitescriptdir}/Bcfg2
120 %{py_sitescriptdir}/Bcfg2/*.py[co]
121 %dir %{py_sitescriptdir}/Bcfg2/Client
122 %{py_sitescriptdir}/Bcfg2/Client/*
123 %{_mandir}/man1/*
124 %{_mandir}/man5/*
125 %{_initrddir}/bcfg2
126 %config(noreplace) %{_sysconfdir}/default/bcfg2
127 %{_sysconfdir}/cron.hourly/bcfg2
128 /etc/cron.daily/bcfg2
129 %{_libdir}/bcfg2/bcfg2-cron
130
131 %files -n bcfg2-server
132 %defattr(644,root,root,755)
133 %attr(754,root,root)  /etc/rc.d/init.d/bcfg2-server
134 %{py_sitescriptdir}/Bcfg2/Server
135 %{_datadir}/bcfg2
136 %config(noreplace) %{_sysconfdir}/default/bcfg2-server
137 %attr(755,root,root) %{_sbindir}/bcfg2-admin
138 %attr(755,root,root) %{_sbindir}/bcfg2-build-reports
139 %attr(755,root,root) %{_sbindir}/bcfg2-info
140 %attr(755,root,root) %{_sbindir}/bcfg2-ping-sweep
141 %attr(755,root,root) %{_sbindir}/bcfg2-repo-validate
142 %attr(755,root,root) %{_sbindir}/bcfg2-reports
143 %attr(755,root,root) %{_sbindir}/bcfg2-server
144 %{_mandir}/man8/*.8*
145 %dir %{_libdir}/bcfg2
This page took 0.1042 seconds and 3 git commands to generate.