]> git.pld-linux.org Git - packages/bcc.git/blobdiff - bcc.spec
- slightly polished
[packages/bcc.git] / bcc.spec
index 82e8dfd9091a4a134be29747ac7f2ea2c6f0d259..f057026496ae22e99d58cbf79bc149b5a451920c 100644 (file)
--- a/bcc.spec
+++ b/bcc.spec
@@ -1,19 +1,21 @@
 Summary:       Bruce's C compiler
-Summary(pl):   Kompiler C Bruce'a
+Summary(pl):   Kompilator C Bruce'a
 Name:          bcc
-Version:       0.16.0
-Release:       2
+Version:       0.16.10
+Release:       1
 License:       GPL
 Group:         Development/Languages
-Group(de):     Entwicklung/Sprachen
-Group(pl):     Programowanie/Jêzyki
-Source0:       http://www.cix.co.uk/~mayday/Dev86src-%{version}.tar.gz
+Source0:       http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
 Patch0:                Dev86src-noroot.patch
 Patch1:                Dev86src-nobcc.patch
-Patch2:                Dev86src-bccpaths.patch
-Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-ExclusiveArch: %{ix86}
+Patch2:                Dev86src-opt.patch
+URL:           http://www.cix.co.uk/~mayday/
 Requires:      bin86
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+ExclusiveArch: %{ix86}
+
+# don't try to strip Linux-8086 objects
+%define                no_install_post_strip   1
 
 %description
 Bcc is a simple C compiler that produces 8086 assembler, in addition
@@ -22,19 +24,19 @@ compiler understands traditional K&R C with just the restriction that
 bit fields are mapped to one of the other integer types.
 
 %description -l pl
-Bcc jest prostym kompilatorem C produkuj±cym pliki asemblerowe 8086,
+Bcc jest prostym kompilatorem C tworz±cym pliki asemblerowe 8086,
 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
-rozumie tradycyjne K&R C z takim ograniczeniem, ¿e pola bitowe
+rozumie tradycyjne C K&R z takim ograniczeniem, ¿e pola bitowe
 s± odwzorowywane do jednego z innych typów ca³kowitych.
 
 %prep
 %setup -q -n dev86-%{version}
-%patch0 -b .oot -p1
-%patch1 -b .djb -p1
-%patch2 -b .bccpaths -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
-CC="%{__cc}" %{__make} <<!FooBar!
+CC="%{__cc}" %{__make} all other OPT="%{rpmcflags}" <<!FooBar!
 5
 quit
 !FooBar!
@@ -42,49 +44,57 @@ quit
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} DIST=${RPM_BUILD_ROOT} install
+%{__make} install-all \
+       DIST=$RPM_BUILD_ROOT
 
-install -m 755 $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
-#rm -rf ${RPM_BUILD_ROOT}/lib/
-cp -R libc/kinclude ${RPM_BUILD_ROOT}%{_libdir}/bcc
+install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
+#rm -rf $RPM_BUILD_ROOT/lib/
+cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
 
-cd ${RPM_BUILD_ROOT}%{_bindir}
-rm -f nm86 size86
-ln -s objdump86 nm86
-ln -s objdump86 size86
+ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
+ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
 
 # move header files out of %{_includedir} and into %{_libdir}/bcc/include
-mv ${RPM_BUILD_ROOT}%{_includedir} ${RPM_BUILD_ROOT}%{_libdir}/bcc
+mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
 
 # move man pages where they belong
-install -d ${RPM_BUILD_ROOT}%{_mandir}
-mv ${RPM_BUILD_ROOT}/usr/man/* ${RPM_BUILD_ROOT}%{_mandir}
+install -d $RPM_BUILD_ROOT%{_mandir}
+rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
+mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
+# these are separated in bin86 package
+rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
+
+%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
+%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
+
+mv -f bootblocks/README README.bootblocks
+mv -f copt/README README.copt
+mv -f dis88/README README.dis88
+mv -f elksemu/README README.elksemu
+mv -f unproto/README README.unproto
 
 %clean
-rm -rf ${RPM_BUILD_ROOT}
+rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README MAGIC Contributors bootblocks/README copt/README dis88/README
-%doc elksemu/README unproto/README bin86/README-0.4 bin86/README bin86/ChangeLog
-%dir %{_libdir}/bcc
-%dir %{_libdir}/bcc/i86
-%dir %{_libdir}/bcc/i386
-%dir %{_libdir}/bcc/include
+%doc Changes Contributors README*
 %attr(755,root,root) %{_bindir}/bcc
-#%attr(755,root,root) %{_bindir}/as86
+%attr(755,root,root) %{_bindir}/ar86
 %attr(755,root,root) %{_bindir}/as86_encap
-#%attr(755,root,root) %{_bindir}/ld86
+%attr(755,root,root) %{_bindir}/dis86
 %attr(755,root,root) %{_bindir}/objdump86
 %attr(755,root,root) %{_bindir}/nm86
 %attr(755,root,root) %{_bindir}/size86
+%{_libdir}/liberror.txt
+%dir %{_libdir}/bcc
+%attr(755,root,root) %{_libdir}/bcc/bcc-cpp
 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
 %attr(755,root,root) %{_libdir}/bcc/copt
 %attr(755,root,root) %{_libdir}/bcc/unproto
-%{_libdir}/bcc/i86/*
-%{_libdir}/bcc/i386/*
-%{_libdir}/liberror.txt
-%{_libdir}/bcc/include/*
-%{_libdir}/bcc/kinclude/*
+%{_libdir}/bcc/i86
+%{_libdir}/bcc/i386
+%{_libdir}/bcc/include
+%{_libdir}/bcc/kinclude
 %attr(755,root,root) %{_bindir}/elksemu
 %{_mandir}/man1/*
This page took 0.359042 seconds and 4 git commands to generate.