]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
82e8dfd9091a4a134be29747ac7f2ea2c6f0d259
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompiler C Bruce'a
3 Name:           bcc
4 Version:        0.16.0
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        http://www.cix.co.uk/~mayday/Dev86src-%{version}.tar.gz
11 Patch0:         Dev86src-noroot.patch
12 Patch1:         Dev86src-nobcc.patch
13 Patch2:         Dev86src-bccpaths.patch
14 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 ExclusiveArch:  %{ix86}
16 Requires:       bin86
17
18 %description
19 Bcc is a simple C compiler that produces 8086 assembler, in addition
20 compiler compile time options allow 80386 or 6809 versions. The
21 compiler understands traditional K&R C with just the restriction that
22 bit fields are mapped to one of the other integer types.
23
24 %description -l pl
25 Bcc jest prostym kompilatorem C produkuj±cym pliki asemblerowe 8086,
26 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
27 rozumie tradycyjne K&R C z takim ograniczeniem, ¿e pola bitowe
28 s± odwzorowywane do jednego z innych typów ca³kowitych.
29
30 %prep
31 %setup -q -n dev86-%{version}
32 %patch0 -b .oot -p1
33 %patch1 -b .djb -p1
34 %patch2 -b .bccpaths -p1
35
36 %build
37 CC="%{__cc}" %{__make} <<!FooBar!
38 5
39 quit
40 !FooBar!
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} DIST=${RPM_BUILD_ROOT} install
46
47 install -m 755 $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
48 #rm -rf ${RPM_BUILD_ROOT}/lib/
49 cp -R libc/kinclude ${RPM_BUILD_ROOT}%{_libdir}/bcc
50
51 cd ${RPM_BUILD_ROOT}%{_bindir}
52 rm -f nm86 size86
53 ln -s objdump86 nm86
54 ln -s objdump86 size86
55
56 # move header files out of %{_includedir} and into %{_libdir}/bcc/include
57 mv ${RPM_BUILD_ROOT}%{_includedir} ${RPM_BUILD_ROOT}%{_libdir}/bcc
58
59 # move man pages where they belong
60 install -d ${RPM_BUILD_ROOT}%{_mandir}
61 mv ${RPM_BUILD_ROOT}/usr/man/* ${RPM_BUILD_ROOT}%{_mandir}
62
63 %clean
64 rm -rf ${RPM_BUILD_ROOT}
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README MAGIC Contributors bootblocks/README copt/README dis88/README
69 %doc elksemu/README unproto/README bin86/README-0.4 bin86/README bin86/ChangeLog
70 %dir %{_libdir}/bcc
71 %dir %{_libdir}/bcc/i86
72 %dir %{_libdir}/bcc/i386
73 %dir %{_libdir}/bcc/include
74 %attr(755,root,root) %{_bindir}/bcc
75 #%attr(755,root,root) %{_bindir}/as86
76 %attr(755,root,root) %{_bindir}/as86_encap
77 #%attr(755,root,root) %{_bindir}/ld86
78 %attr(755,root,root) %{_bindir}/objdump86
79 %attr(755,root,root) %{_bindir}/nm86
80 %attr(755,root,root) %{_bindir}/size86
81 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
82 %attr(755,root,root) %{_libdir}/bcc/copt
83 %attr(755,root,root) %{_libdir}/bcc/unproto
84 %{_libdir}/bcc/i86/*
85 %{_libdir}/bcc/i386/*
86 %{_libdir}/liberror.txt
87 %{_libdir}/bcc/include/*
88 %{_libdir}/bcc/kinclude/*
89 %attr(755,root,root) %{_bindir}/elksemu
90 %{_mandir}/man1/*
This page took 0.325752 seconds and 3 git commands to generate.