]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- noted new URL
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.21
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages
8 # see also https://github.com/lkundrak/dev86/releases
9 Source0:        http://v3.sk/~lkundrak/dev86/Dev86src-%{version}.tar.gz
10 # Source0-md5:  6b96fe9d2d1c546842a4d1c7ef387e4c
11 Patch0:         Dev86src-noroot.patch
12 Patch1:         Dev86src-opt.patch
13 Patch2:         dev86-0.16.17-fortify.patch
14 Patch3:         dev86-pic.patch
15 Patch4:         %{name}-lib64.patch
16 Patch5:         dev86-noelks.patch
17 Patch6:         dev86-nostrip.patch
18 Patch7:         dev86-make.patch
19 Patch8:         %{name}-libx32.patch
20 URL:            http://v3.sk/~lkundrak/dev86/
21 Requires:       bin86 >= %{version}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # don't try to strip Linux-8086 objects
25 %define         _noautostrip    .*%{_libdir}/bcc/.*\\.[ao]
26
27 %description
28 Bcc is a simple C compiler that produces 8086 assembler, in addition
29 compiler compile time options allow 80386 or 6809 versions. The
30 compiler understands traditional K&R C with just the restriction that
31 bit fields are mapped to one of the other integer types.
32
33 %description -l pl.UTF-8
34 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
35 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
36 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
37 są odwzorowywane do jednego z innych typów całkowitych.
38
39 %prep
40 %setup -q -n dev86-%{version}
41 %patch0 -p1
42 %patch1 -p1
43 %patch2 -p1
44 %patch3 -p0
45 %if "%{_lib}" == "lib64"
46 %patch4 -p1
47 %endif
48 %ifnarch %{ix86}
49 %patch5 -p1
50 %endif
51 %patch6 -p1
52 %patch7 -p1
53 %if "%{_lib}" == "libx32"
54 %patch8 -p1
55 %endif
56
57 %{__mv} bootblocks/README README.bootblocks
58 %{__mv} copt/README README.copt
59 %{__mv} dis88/README README.dis88
60 %{__mv} elksemu/README README.elksemu
61 %{__mv} unproto/README README.unproto
62
63 %build
64 CC="%{__cc}" \
65 %{__make} -j1 all other \
66         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
67 5
68 quit
69 !FooBar!
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -j1 install-all \
75         DIST=$RPM_BUILD_ROOT \
76         LIBDIR=%{_libdir}/bcc \
77         INCLDIR=%{_libdir}/bcc \
78         LOCALPREFIX=%{_prefix} \
79         MANDIR=%{_mandir}
80
81 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
82
83 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
84 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
85
86 # these are separated in bin86 package
87 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
88 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{as,ld}86.1*
89
90 %ifnarch %{ix86}
91 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/elks*.1
92 %endif
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc Changes Contributors README*
100 %attr(755,root,root) %{_bindir}/ar86
101 %attr(755,root,root) %{_bindir}/bcc
102 %attr(755,root,root) %{_bindir}/dis86
103 %ifarch %{ix86}
104 %attr(755,root,root) %{_bindir}/elksemu
105 %endif
106 %attr(755,root,root) %{_bindir}/makeboot
107 %attr(755,root,root) %{_bindir}/nm86
108 %attr(755,root,root) %{_bindir}/objdump86
109 %attr(755,root,root) %{_bindir}/size86
110 %dir %{_libdir}/bcc
111 %attr(755,root,root) %{_libdir}/bcc/as86_encap
112 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
113 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
114 %attr(755,root,root) %{_libdir}/bcc/copt
115 %attr(755,root,root) %{_libdir}/bcc/unproto
116 %{_libdir}/bcc/i386
117 %{_libdir}/bcc/include
118 %{_libdir}/bcc/kinclude
119 %{_libdir}/bcc/crt*.o
120 %{_libdir}/bcc/lib*.a
121 %{_libdir}/bcc/rules.*
122 %{_mandir}/man1/bcc.1*
123 %{_mandir}/man1/dis86.1*
124 %ifarch %{ix86}
125 %{_mandir}/man1/elks.1*
126 %{_mandir}/man1/elksemu.1*
127 %endif
This page took 1.445136 seconds and 3 git commands to generate.