]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- updated to 0.16.15
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.15
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  c3266fa6530b472e1d3e98d826db6409
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-opt.patch
12 URL:            http://www.cix.co.uk/~mayday/
13 Requires:       bin86
14 ExclusiveArch:  %{ix86}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # don't try to strip Linux-8086 objects
18 %define         no_install_post_strip   1
19
20 %description
21 Bcc is a simple C compiler that produces 8086 assembler, in addition
22 compiler compile time options allow 80386 or 6809 versions. The
23 compiler understands traditional K&R C with just the restriction that
24 bit fields are mapped to one of the other integer types.
25
26 %description -l pl
27 Bcc jest prostym kompilatorem C tworz±cym pliki asemblerowe 8086,
28 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
29 rozumie tradycyjne C K&R z takim ograniczeniem, ¿e pola bitowe
30 s± odwzorowywane do jednego z innych typów ca³kowitych.
31
32 %prep
33 %setup -q -n dev86-%{version}
34 %patch0 -p1
35 %patch1 -p1
36
37 %build
38 CC="%{__cc}" \
39 %{__make} all other \
40         OPT="%{rpmcflags}" <<!FooBar!
41 5
42 quit
43 !FooBar!
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install-all \
49         DIST=$RPM_BUILD_ROOT
50
51 # FFU (dis88/Makefile is not ready)
52 #       MANDIR=%{_mandir}
53
54 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
55
56 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
57 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
58
59 # these are separated in bin86 package
60 rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
61 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
62 # move man pages where they belong
63 install -d $RPM_BUILD_ROOT%{_mandir}
64 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
65
66 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
67 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
68
69 mv -f bootblocks/README README.bootblocks
70 mv -f copt/README README.copt
71 mv -f dis88/README README.dis88
72 mv -f elksemu/README README.elksemu
73 mv -f unproto/README README.unproto
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc Changes Contributors README*
81 %attr(755,root,root) %{_bindir}/ar86
82 %attr(755,root,root) %{_bindir}/bcc
83 %attr(755,root,root) %{_bindir}/dis86
84 %attr(755,root,root) %{_bindir}/elksemu
85 %attr(755,root,root) %{_bindir}/makeboot
86 %attr(755,root,root) %{_bindir}/nm86
87 %attr(755,root,root) %{_bindir}/objdump86
88 %attr(755,root,root) %{_bindir}/size86
89 %dir %{_libdir}/bcc
90 %attr(755,root,root) %{_libdir}/bcc/as86_encap
91 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
92 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
93 %attr(755,root,root) %{_libdir}/bcc/copt
94 %attr(755,root,root) %{_libdir}/bcc/unproto
95 %{_libdir}/bcc/i386
96 %{_libdir}/bcc/include
97 %{_libdir}/bcc/kinclude
98 %{_libdir}/bcc/crt*.o
99 %{_libdir}/bcc/lib*.a
100 %{_libdir}/bcc/rules.*
101 %{_mandir}/man1/*
This page took 0.027243 seconds and 3 git commands to generate.