]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
a1ca058a65693ce5d70bc2d6c3471126e5e55f58
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompiler C Bruce'a
3 Name:           bcc
4 Version:        0.16.0
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        http://www.cix.co.uk/~mayday/Dev86src-%{version}.tar.gz
11 Patch0:         Dev86src-noroot.patch
12 Patch1:         Dev86src-nobcc.patch
13 Patch2:         Dev86src-bccpaths.patch
14 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 ExclusiveArch:  %{ix86}
16
17 %description
18 Bcc is a simple C compiler that produces 8086 assembler, in addition
19 compiler compile time options allow 80386 or 6809 versions. The
20 compiler understands traditional K&R C with just the restriction that
21 bit fields are mapped to one of the other integer types.
22
23 %description -l pl
24 Bcc jest prostym kompilatorem C produkuj±cym pliki asemblerowe 8086,
25 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
26 rozumie tradycyjne K&R C z takim ograniczeniem, ¿e pola bitowe
27 s± odwzorowywane do jednego z innych typów ca³kowitych.
28
29 %prep
30 %setup -q -n dev86-%{version}
31 %patch0 -b .oot -p1
32 %patch1 -b .djb -p1
33 %patch2 -b .bccpaths -p1
34
35 %build
36 CC="%{__cc}" %{__make} <<!FooBar!
37 5
38 quit
39 !FooBar!
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} DIST=${RPM_BUILD_ROOT} install
45
46 install -m 755 $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
47 #rm -rf ${RPM_BUILD_ROOT}/lib/
48 cp -R libc/kinclude ${RPM_BUILD_ROOT}%{_libdir}/bcc
49
50 cd ${RPM_BUILD_ROOT}%{_bindir}
51 rm -f nm86 size86
52 ln -s objdump86 nm86
53 ln -s objdump86 size86
54
55 # move header files out of %{_includedir} and into %{_libdir}/bcc/include
56 mv ${RPM_BUILD_ROOT}%{_includedir} ${RPM_BUILD_ROOT}%{_libdir}/bcc
57
58 # move man pages where they belong
59 install -d ${RPM_BUILD_ROOT}%{_mandir}
60 mv ${RPM_BUILD_ROOT}/usr/man/* ${RPM_BUILD_ROOT}%{_mandir}
61
62 %clean
63 rm -rf ${RPM_BUILD_ROOT}
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README MAGIC Contributors bootblocks/README copt/README dis88/README
68 %doc elksemu/README unproto/README bin86/README-0.4 bin86/README bin86/ChangeLog
69 %dir %{_libdir}/bcc
70 %dir %{_libdir}/bcc/i86
71 %dir %{_libdir}/bcc/i386
72 %dir %{_libdir}/bcc/include
73 %attr(755,root,root) %{_bindir}/bcc
74 #%attr(755,root,root) %{_bindir}/as86
75 %attr(755,root,root) %{_bindir}/as86_encap
76 #%attr(755,root,root) %{_bindir}/ld86
77 %attr(755,root,root) %{_bindir}/objdump86
78 %attr(755,root,root) %{_bindir}/nm86
79 %attr(755,root,root) %{_bindir}/size86
80 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
81 %attr(755,root,root) %{_libdir}/bcc/copt
82 %attr(755,root,root) %{_libdir}/bcc/unproto
83 %{_libdir}/bcc/i86/*
84 %{_libdir}/bcc/i386/*
85 %{_libdir}/liberror.txt
86 %{_libdir}/bcc/include/*
87 %{_libdir}/bcc/kinclude/*
88 %attr(755,root,root) %{_bindir}/elksemu
89 %{_mandir}/man1/*
This page took 0.054883 seconds and 2 git commands to generate.