]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- new URLs, updated to 0.16.21
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.21
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://v3.sk/~lkundrak/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  6b96fe9d2d1c546842a4d1c7ef387e4c
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-opt.patch
12 Patch2:         dev86-0.16.17-fortify.patch
13 Patch3:         dev86-pic.patch
14 Patch4:         dev86-64bit.patch
15 Patch5:         dev86-noelks.patch
16 Patch6:         dev86-nostrip.patch
17 Patch7:         dev86-make.patch
18 URL:            http://v3.sk/~lkundrak/dev86/
19 Requires:       bin86 >= %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # don't try to strip Linux-8086 objects
23 %define         _noautostrip    .*%{_libdir}/bcc/.*\\.[ao]
24
25 %description
26 Bcc is a simple C compiler that produces 8086 assembler, in addition
27 compiler compile time options allow 80386 or 6809 versions. The
28 compiler understands traditional K&R C with just the restriction that
29 bit fields are mapped to one of the other integer types.
30
31 %description -l pl.UTF-8
32 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
33 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
34 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
35 są odwzorowywane do jednego z innych typów całkowitych.
36
37 %prep
38 %setup -q -n dev86-%{version}
39 %patch0 -p1
40 %patch1 -p1
41 %patch2 -p1
42 %patch3 -p0
43 %if "%{_lib}" == "lib64"
44 %patch4 -p1
45 %endif
46 %ifnarch %{ix86}
47 %patch5 -p1
48 %endif
49 %patch6 -p1
50 %patch7 -p1
51
52 %{__mv} bootblocks/README README.bootblocks
53 %{__mv} copt/README README.copt
54 %{__mv} dis88/README README.dis88
55 %{__mv} elksemu/README README.elksemu
56 %{__mv} unproto/README README.unproto
57
58 %build
59 CC="%{__cc}" \
60 %{__make} -j1 all other \
61         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
62 5
63 quit
64 !FooBar!
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} -j1 install-all \
70         DIST=$RPM_BUILD_ROOT \
71         LIBDIR=%{_libdir}/bcc \
72         INCLDIR=%{_libdir}/bcc \
73         LOCALPREFIX=%{_prefix} \
74         MANDIR=%{_mandir}
75
76 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
77
78 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
79 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
80
81 # these are separated in bin86 package
82 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
83 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{as,ld}86.1*
84
85 %ifnarch %{ix86}
86 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/elks*.1
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc Changes Contributors README*
95 %attr(755,root,root) %{_bindir}/ar86
96 %attr(755,root,root) %{_bindir}/bcc
97 %attr(755,root,root) %{_bindir}/dis86
98 %ifarch %{ix86}
99 %attr(755,root,root) %{_bindir}/elksemu
100 %endif
101 %attr(755,root,root) %{_bindir}/makeboot
102 %attr(755,root,root) %{_bindir}/nm86
103 %attr(755,root,root) %{_bindir}/objdump86
104 %attr(755,root,root) %{_bindir}/size86
105 %dir %{_libdir}/bcc
106 %attr(755,root,root) %{_libdir}/bcc/as86_encap
107 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
108 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
109 %attr(755,root,root) %{_libdir}/bcc/copt
110 %attr(755,root,root) %{_libdir}/bcc/unproto
111 %{_libdir}/bcc/i386
112 %{_libdir}/bcc/include
113 %{_libdir}/bcc/kinclude
114 %{_libdir}/bcc/crt*.o
115 %{_libdir}/bcc/lib*.a
116 %{_libdir}/bcc/rules.*
117 %{_mandir}/man1/bcc.1*
118 %{_mandir}/man1/dis86.1*
119 %ifarch %{ix86}
120 %{_mandir}/man1/elks.1*
121 %{_mandir}/man1/elksemu.1*
122 %endif
This page took 0.038285 seconds and 3 git commands to generate.