]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
1cd1914e83021bbc1fc2d948a040133d8852089a
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.17
5 Release:        5
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://homepage.ntlworld.com/robert.debath/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  e7bbfdbe61c2fb964994a087e29b0087
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-opt.patch
12 Patch2:         dev86-0.16.17-fortify.patch
13 Patch3:         dev86-pic.patch
14 Patch4:         dev86-0.16.17-make382.patch
15 URL:            http://homepage.ntlworld.com/robert.debath/
16 Requires:       bin86
17 ExclusiveArch:  %{ix86}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # don't try to strip Linux-8086 objects
21 # TODO: use _noautostrip
22 %define         no_install_post_strip   1
23
24 %description
25 Bcc is a simple C compiler that produces 8086 assembler, in addition
26 compiler compile time options allow 80386 or 6809 versions. The
27 compiler understands traditional K&R C with just the restriction that
28 bit fields are mapped to one of the other integer types.
29
30 %description -l pl.UTF-8
31 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
32 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
33 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
34 są odwzorowywane do jednego z innych typów całkowitych.
35
36 %prep
37 %setup -q -n dev86-%{version}
38 %patch0 -p1
39 %patch1 -p1
40 %patch2 -p1
41 %patch3 -p0
42 %patch4 -p0
43
44 mv -f bootblocks/README README.bootblocks
45 mv -f copt/README README.copt
46 mv -f dis88/README README.dis88
47 mv -f elksemu/README README.elksemu
48 mv -f unproto/README README.unproto
49
50 %build
51 CC="%{__cc}" \
52 %{__make} -j1 all other \
53         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
54 5
55 quit
56 !FooBar!
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} -j1 install-all \
62         DIST=$RPM_BUILD_ROOT
63
64 # FFU (dis88/Makefile is not ready)
65 #       MANDIR=%{_mandir}
66
67 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
68
69 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
70 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
71
72 # these are separated in bin86 package
73 rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
74 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
75 # move man pages where they belong
76 install -d $RPM_BUILD_ROOT%{_mandir}
77 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
78
79 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
80 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc Changes Contributors README*
88 %attr(755,root,root) %{_bindir}/ar86
89 %attr(755,root,root) %{_bindir}/bcc
90 %attr(755,root,root) %{_bindir}/dis86
91 %attr(755,root,root) %{_bindir}/elksemu
92 %attr(755,root,root) %{_bindir}/makeboot
93 %attr(755,root,root) %{_bindir}/nm86
94 %attr(755,root,root) %{_bindir}/objdump86
95 %attr(755,root,root) %{_bindir}/size86
96 %dir %{_libdir}/bcc
97 %attr(755,root,root) %{_libdir}/bcc/as86_encap
98 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
99 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
100 %attr(755,root,root) %{_libdir}/bcc/copt
101 %attr(755,root,root) %{_libdir}/bcc/unproto
102 %{_libdir}/bcc/i386
103 %{_libdir}/bcc/include
104 %{_libdir}/bcc/kinclude
105 %{_libdir}/bcc/crt*.o
106 %{_libdir}/bcc/lib*.a
107 %{_libdir}/bcc/rules.*
108 %{_mandir}/man1/*
This page took 0.071351 seconds and 3 git commands to generate.