]> git.pld-linux.org Git - packages/bats.git/blame - bats.spec
nwe, version 0.4.0
[packages/bats.git] / bats.spec
CommitLineData
0070e7df
ER
1Summary: Bash Automated Testing System
2Name: bats
3Version: 0.4.0
4Release: 1
5License: MIT
6Group: Development/Libraries
7Source0: https://github.com/sstephenson/bats/archive/v%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: aeeddc0b36b8321930bf96fce6ec41ee
9Patch0: install.patch
10URL: https://github.com/sstephenson/bats
11BuildRequires: bash
12BuildRequires: sed >= 4.0
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%define _libexecdir %{_prefix}/lib
17
18%description
19Bats is a TAP-compliant testing framework for Bash. It provides a
20simple way to verify that the UNIX programs you write behave as
21expected.
22
23Bats is most useful when testing software written in Bash, but you can
24use it to test any UNIX program.
25
26%prep
27%setup -q
28%patch0 -p1
29
30%{__sed} -i -e '1 s,#!.*bash,#!/bin/bash,' libexec/*
31
32%install
33rm -rf $RPM_BUILD_ROOT
34install -d $RPM_BUILD_ROOT{%{_prefix},%{_libexecdir},%{_mandir}}
35./install.sh $RPM_BUILD_ROOT%{_prefix}
36ln -sf ../lib/bats $RPM_BUILD_ROOT%{_bindir}
37
38%clean
39rm -rf $RPM_BUILD_ROOT
40
41%files
42%defattr(644,root,root,755)
43%doc README.md LICENSE
44%attr(755,root,root) %{_bindir}/bats
45%attr(755,root,root) %{_libexecdir}/bats
46%attr(755,root,root) %{_libexecdir}/bats-exec-suite
47%attr(755,root,root) %{_libexecdir}/bats-exec-test
48%attr(755,root,root) %{_libexecdir}/bats-format-tap-stream
49%attr(755,root,root) %{_libexecdir}/bats-preprocess
50%{_mandir}/man1/bats.1*
51%{_mandir}/man7/bats.7*
This page took 0.157442 seconds and 4 git commands to generate.