]> git.pld-linux.org Git - packages/bash.git/commitdiff
fix build without both static and tests
authorJan Palus <atler@pld-linux.org>
Mon, 16 Nov 2020 00:45:26 +0000 (01:45 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 16 Nov 2020 00:47:20 +0000 (01:47 +0100)
[ "shared" = "static ] effectively becomes last statement which rpmbuild
treats as failure. convert to if.

bash.spec

index b525f66633ba83e7e790100e64a2ae8f015892ed..cf9ceed2278cbb0a8cbeba68780fbbb5c2059ecc 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -233,7 +233,9 @@ for mode in %{?with_static:static} shared; do
 %{__make} \
        DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
 
-[ "$mode" = "static" ] && mv -f bash bash.static
+if [ "$mode" = "static" ]; then
+       mv -f bash bash.static
+fi
 done
 
 %{?with_tests:%{__make} tests}
This page took 0.036556 seconds and 4 git commands to generate.