]> git.pld-linux.org Git - packages/bash.git/commitdiff
- up to 5.0
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 21 Mar 2019 13:49:30 +0000 (14:49 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 21 Mar 2019 13:49:30 +0000 (14:49 +0100)
bash-autoconf.patch
bash-paths.patch
bash-requires.patch
bash.spec
sources

index 59e9d2315d16d560d2a41d22afaf9195e15e2f36..1f9d25761053f6b1a5ea54caeba795780d649952 100644 (file)
@@ -1,20 +1,20 @@
---- bash-3.0/aclocal.m4.orig   2004-05-13 19:37:25.000000000 +0200
-+++ bash-3.0/aclocal.m4        2004-08-06 08:39:20.961425816 +0200
-@@ -943,10 +943,10 @@
- fi
+--- bash-5.0/aclocal.m4~       2018-12-05 15:31:34.000000000 +0100
++++ bash-5.0/aclocal.m4        2019-03-21 14:19:55.805259147 +0100
+@@ -959,11 +959,10 @@ fi
  AC_CACHE_VAL(bash_cv_termcap_lib,
  [AC_CHECK_FUNC(tgetent, bash_cv_termcap_lib=libc,
--  [AC_CHECK_LIB(termcap, tgetent, bash_cv_termcap_lib=libtermcap,
+   [AC_CHECK_LIB(termcap, tgetent, bash_cv_termcap_lib=libtermcap,
 -    [AC_CHECK_LIB(tinfo, tgetent, bash_cv_termcap_lib=libtinfo,
 -        [AC_CHECK_LIB(curses, tgetent, bash_cv_termcap_lib=libcurses,
--          [AC_CHECK_LIB(ncurses, tgetent, bash_cv_termcap_lib=libncurses,
-+  [AC_CHECK_LIB(tinfo, tgetent, bash_cv_termcap_lib=libtinfo,
-+      [AC_CHECK_LIB(curses, tgetent, bash_cv_termcap_lib=libcurses,
-+      [AC_CHECK_LIB(ncurses, tgetent, bash_cv_termcap_lib=libncurses,
-+          [AC_CHECK_LIB(termcap, tgetent, bash_cv_termcap_lib=libtermcap,
-               bash_cv_termcap_lib=gnutermcap)])])])])])
++        [AC_CHECK_LIB(libncursesw, tgetent, bash_cv_termcap_lib=libncursesw,
+           [AC_CHECK_LIB(ncurses, tgetent, bash_cv_termcap_lib=libncurses,
+-                [AC_CHECK_LIB(ncursesw, tgetent, bash_cv_termcap_lib=libncursesw,
+-                  bash_cv_termcap_lib=gnutermcap)])])])])])])
++                [AC_CHECK_LIB(curses, tgetent, bash_cv_termcap_lib=libcurses,
++                  bash_cv_termcap_lib=gnutermcap)])])])])])
  if test "X$_bash_needmsg" = "Xyes"; then
  AC_MSG_CHECKING(which library has the termcap functions)
+ fi
 --- bash-2.05a-new/Makefile.in Fri Feb  8 00:20:46 2002
 +++ bash-2.05a/Makefile.in     Thu Feb  7 22:38:32 2002
 @@ -727,8 +727,8 @@ pathnames.h:               Makefile $(srcdir)/pathnam
index dbd44b8a66f9c105681869cadadfd13dd7f2b2b4..21736d50379fc87600bf1ccb6de82e6471d1c226 100644 (file)
@@ -10,11 +10,9 @@ diff -urbB bash-3.0.org/config.h.in bash-3.0/config.h.in
  
  /* Characteristics of the system's header files and libraries that affect
     the compilation environment. */
-Tylko w bash-3.0: config.h.in.orig
-diff -urbB bash-3.0.org/config-top.h bash-3.0/config-top.h
---- bash-3.0.org/config-top.h  2003-08-05 16:36:12.000000000 +0200
-+++ bash-3.0/config-top.h      2005-10-08 19:36:04.395581500 +0200
-@@ -59,14 +59,14 @@
+--- bash-5.0/config-top.h~     2019-03-21 14:06:54.000000000 +0100
++++ bash-5.0/config-top.h      2019-03-21 14:08:18.043987487 +0100
+@@ -63,7 +63,7 @@
  /* The default value of the PATH variable. */
  #ifndef DEFAULT_PATH_VALUE
  #define DEFAULT_PATH_VALUE \
@@ -22,12 +20,13 @@ diff -urbB bash-3.0.org/config-top.h bash-3.0/config-top.h
 +  "/usr/local/bin:/bin:/usr/bin"
  #endif
  
- /* The value for PATH when invoking `command -p'.  This is only used when
+ /* If you want to unconditionally set a value for PATH in every restricted
+@@ -74,7 +74,7 @@
     the Posix.2 confstr () function, or CS_PATH define are not present. */
  #ifndef STANDARD_UTILS_PATH
  #define STANDARD_UTILS_PATH \
 -  "/bin:/usr/bin:/sbin:/usr/sbin:/etc:/usr/etc"
-+  "/bin:/usr/bin:/sbin:/usr/sbin"
++  "/usr/local/bin:/bin:/usr/bin"
  #endif
  
  /* Default primary and secondary prompt strings. */
index ad58ecbe643f585a756da60bd3b83d0a978978f3..35670bd55cf43dbfd324894c2fa472e7912f9558 100644 (file)
@@ -1,36 +1,36 @@
-diff -up bash-4.1/builtins.h.requires bash-4.1/builtins.h
---- bash-4.1/builtins.h.requires       2009-01-04 20:32:23.000000000 +0100
-+++ bash-4.1/builtins.h        2010-08-02 17:42:41.000000000 +0200
-@@ -41,6 +41,8 @@
+diff --git a/builtins.h b/builtins.h
+index dac95fd..5b7e811 100644
+--- a/builtins.h
++++ b/builtins.h
+@@ -45,6 +45,7 @@
  #define ASSIGNMENT_BUILTIN 0x10       /* This builtin takes assignment statements. */
  #define POSIX_BUILTIN 0x20    /* This builtins is special in the Posix command search order. */
  #define LOCALVAR_BUILTIN   0x40       /* This builtin creates local variables */
-+#define REQUIRES_BUILTIN 0x80 /* This builtin requires other files. */
-+
++#define REQUIRES_BUILTIN 0x80  /* This builtin requires other files. */
  
  #define BASE_INDENT   4
  
-diff -up bash-4.1/builtins/mkbuiltins.c.requires bash-4.1/builtins/mkbuiltins.c
---- bash-4.1/builtins/mkbuiltins.c.requires    2009-01-04 20:32:23.000000000 +0100
-+++ bash-4.1/builtins/mkbuiltins.c     2010-08-02 17:42:41.000000000 +0200
-@@ -69,10 +69,16 @@ extern char *strcpy ();
+diff --git a/builtins/mkbuiltins.c b/builtins/mkbuiltins.c
+index 4f51201..91c25db 100644
+--- a/builtins/mkbuiltins.c
++++ b/builtins/mkbuiltins.c
+@@ -69,10 +69,15 @@ extern char *strcpy ();
  #define whitespace(c) (((c) == ' ') || ((c) == '\t'))
  
  /* Flag values that builtins can have. */
-+/*  These flags are for the C code generator, 
++/*  These flags are for the C code generator,
 +    the C which is produced (./builtin.c)
-+    includes the flags definitions found 
++    includes the flags definitions found
 +    in ../builtins.h */
  #define BUILTIN_FLAG_SPECIAL  0x01
  #define BUILTIN_FLAG_ASSIGNMENT 0x02
  #define BUILTIN_FLAG_LOCALVAR 0x04
  #define BUILTIN_FLAG_POSIX_BUILTIN 0x08
-+#define BUILTIN_FLAG_REQUIRES 0x10
-+
++#define BUILTIN_FLAG_REQUIRES  0x10
  
  #define BASE_INDENT   4
  
-@@ -163,10 +169,18 @@ char *posix_builtins[] =
+@@ -173,11 +178,19 @@ char *posix_builtins[] =
    (char *)NULL
  };
  
@@ -49,17 +49,17 @@ diff -up bash-4.1/builtins/mkbuiltins.c.requires bash-4.1/builtins/mkbuiltins.c
 +static int is_requires_builtin ();
  
  #if !defined (HAVE_RENAME)
-@@ -812,6 +826,9 @@ builtin_handler (self, defs, arg)
-     new->flags |= BUILTIN_FLAG_ASSIGNMENT;
+ static int rename ();
+@@ -831,6 +844,8 @@ builtin_handler (self, defs, arg)
+     new->flags |= BUILTIN_FLAG_LOCALVAR;
    if (is_posix_builtin (name))
      new->flags |= BUILTIN_FLAG_POSIX_BUILTIN;
 +  if (is_requires_builtin (name))
 +    new->flags |= BUILTIN_FLAG_REQUIRES;
-+
  
    array_add ((char *)new, defs->builtins);
    building_builtin = 1;
-@@ -1267,12 +1267,13 @@ write_builtins (defs, structfile, extern
+@@ -1250,12 +1265,13 @@ write_builtins (defs, structfile, externfile)
                  else
                    fprintf (structfile, "(sh_builtin_func_t *)0x0, ");
  
@@ -74,7 +74,7 @@ diff -up bash-4.1/builtins/mkbuiltins.c.requires bash-4.1/builtins/mkbuiltins.c
                    document_name (builtin));
  
                  /* Don't translate short document summaries that are identical
-@@ -1581,6 +1599,13 @@ is_posix_builtin (name)
+@@ -1645,6 +1661,13 @@ is_posix_builtin (name)
    return (_find_in_table (name, posix_builtins));
  }
  
@@ -88,15 +88,16 @@ diff -up bash-4.1/builtins/mkbuiltins.c.requires bash-4.1/builtins/mkbuiltins.c
  #if !defined (HAVE_RENAME)
  static int
  rename (from, to)
-diff -up bash-4.1/doc/bash.1.requires bash-4.1/doc/bash.1
---- bash-4.1/doc/bash.1.requires       2010-08-02 17:42:41.000000000 +0200
-+++ bash-4.1/doc/bash.1        2010-08-02 18:09:27.000000000 +0200
-@@ -231,6 +231,14 @@ The shell becomes restricted (see
+diff --git a/doc/bash.1 b/doc/bash.1
+index d91f1fd..111a66d 100644
+--- a/doc/bash.1
++++ b/doc/bash.1
+@@ -239,6 +239,14 @@ The shell becomes restricted (see
  .B "RESTRICTED SHELL"
  below).
  .TP
 +.B \-\-rpm-requires
-+Produce the list of files that are required for the 
++Produce the list of files that are required for the
 +shell script to run.  This implies '-n' and is subject
 +to the same limitations as compile time error checking checking;
 +Command substitutions, Conditional expressions and
@@ -104,17 +105,18 @@ diff -up bash-4.1/doc/bash.1.requires bash-4.1/doc/bash.1
 +builtin are not parsed so some dependencies may be missed.
 +.TP
  .B \-\-verbose
- Equivalent to  \fB\-v\fP.
+ Equivalent to \fB\-v\fP.
  .TP
-diff -up bash-4.1/doc/bashref.texi.requires bash-4.1/doc/bashref.texi
---- bash-4.1/doc/bashref.texi.requires 2010-08-02 17:42:41.000000000 +0200
-+++ bash-4.1/doc/bashref.texi  2010-08-02 18:11:58.000000000 +0200
-@@ -5343,6 +5343,13 @@ standard.  @xref{Bash POSIX Mode}, for a
+diff --git a/doc/bashref.texi b/doc/bashref.texi
+index d33cd57..6fc4d18 100644
+--- a/doc/bashref.texi
++++ b/doc/bashref.texi
+@@ -6453,6 +6453,13 @@ standard.  @xref{Bash POSIX Mode}, for a description of the Bash
  @item --restricted
  Make the shell a restricted shell (@pxref{The Restricted Shell}).
  
 +@item --rpm-requires
-+Produce the list of files that are required for the 
++Produce the list of files that are required for the
 +shell script to run.  This implies '-n' and is subject
 +to the same limitations as compile time error checking checking;
 +Command substitutions, Conditional expressions and @command{eval}
@@ -123,30 +125,25 @@ diff -up bash-4.1/doc/bashref.texi.requires bash-4.1/doc/bashref.texi
  @item --verbose
  Equivalent to @option{-v}.  Print shell input lines as they're read.
  
-diff -up bash-4.1/eval.c.requires bash-4.1/eval.c
---- bash-4.1/eval.c.requires   2009-01-04 20:32:26.000000000 +0100
-+++ bash-4.1/eval.c    2010-08-02 17:42:41.000000000 +0200
-@@ -53,6 +53,7 @@ extern int last_command_exit_value, stdi
- extern int current_command_number, current_command_line_count, line_number;
- extern int expand_aliases;
-+extern int rpm_requires;
- extern char *ps0_prompt;
- #if defined (HAVE_POSIX_SIGNALS)
- extern sigset_t top_level_mask;
-@@ -136,7 +137,7 @@ reader_loop ()
+diff --git a/eval.c b/eval.c
+index f02d6e4..76c1e8d 100644
+--- a/eval.c
++++ b/eval.c
+@@ -142,7 +142,8 @@ reader_loop ()
  
        if (read_command () == 0)
        {
 -        if (interactive_shell == 0 && read_but_dont_execute)
++
 +        if (interactive_shell == 0 && (read_but_dont_execute && !rpm_requires))
            {
              last_command_exit_value = EXECUTION_SUCCESS;
              dispose_command (global_command);
-diff -up bash-4.1/execute_cmd.c.requires bash-4.1/execute_cmd.c
---- bash-4.1/execute_cmd.c.requires    2010-08-02 17:42:41.000000000 +0200
-+++ bash-4.1/execute_cmd.c     2010-08-02 17:42:41.000000000 +0200
-@@ -503,6 +503,8 @@ async_redirect_stdin ()
+diff --git a/execute_cmd.c b/execute_cmd.c
+index 8b3c83a..4eae19c 100644
+--- a/execute_cmd.c
++++ b/execute_cmd.c
+@@ -538,6 +538,8 @@ async_redirect_stdin ()
  
  #define DESCRIBE_PID(pid) do { if (interactive) describe_pid (pid); } while (0)
  
@@ -155,7 +152,7 @@ diff -up bash-4.1/execute_cmd.c.requires bash-4.1/execute_cmd.c
  /* Execute the command passed in COMMAND, perhaps doing it asynchronously.
     COMMAND is exactly what read_command () places into GLOBAL_COMMAND.
     ASYNCHROUNOUS, if non-zero, says to do this command in the background.
-@@ -534,7 +536,13 @@ execute_command_internal (command, async
+@@ -569,7 +571,13 @@ execute_command_internal (command, asynchronous, pipe_in, pipe_out,
  
    if (breaking || continuing)
      return (last_command_exit_value);
@@ -170,58 +167,34 @@ diff -up bash-4.1/execute_cmd.c.requires bash-4.1/execute_cmd.c
      return (EXECUTION_SUCCESS);
  
    QUIT;
-@@ -5066,7 +5074,7 @@ execute_intern_function (name, function)
-   if (check_identifier (name, posixly_correct) == 0)
+@@ -2813,7 +2821,7 @@ execute_for_command (for_command)
+   save_line_number = line_number;
+   if (check_identifier (for_command->name, 1) == 0)
      {
 -      if (posixly_correct && interactive_shell == 0)
 +      if (posixly_correct && interactive_shell == 0 && rpm_requires == 0)
        {
          last_command_exit_value = EX_BADUSAGE;
          jump_to_top_level (ERREXIT);
-diff -up bash-4.1/execute_cmd.h.requires bash-4.1/execute_cmd.h
---- bash-4.1/execute_cmd.h.requires    2009-01-16 22:20:15.000000000 +0100
-+++ bash-4.1/execute_cmd.h     2010-08-02 17:42:41.000000000 +0200
-@@ -22,6 +22,8 @@
+diff --git a/execute_cmd.h b/execute_cmd.h
+index dc2f15e..506fff4 100644
+--- a/execute_cmd.h
++++ b/execute_cmd.h
+@@ -22,6 +22,9 @@
  #define _EXECUTE_CMD_H_
  
  #include "stdc.h"
 +#include "variables.h"
 +#include "command.h"
- extern struct fd_bitmap *new_fd_bitmap __P((int));
- extern void dispose_fd_bitmap __P((struct fd_bitmap *));
-diff -up bash-4.1/make_cmd.c.requires bash-4.1/make_cmd.c
---- bash-4.1/make_cmd.c.requires       2009-09-11 23:26:12.000000000 +0200
-+++ bash-4.1/make_cmd.c        2010-08-02 17:42:41.000000000 +0200
-@@ -42,11 +42,15 @@
- #include "flags.h"
- #include "make_cmd.h"
- #include "dispose_cmd.h"
-+#include "execute_cmd.h"
- #include "variables.h"
- #include "subst.h"
- #include "input.h"
- #include "ocache.h"
- #include "externs.h"
-+#include "builtins.h"
 +
-+#include "builtins/common.h"
  
- #if defined (JOB_CONTROL)
- #include "jobs.h"
-@@ -56,6 +60,10 @@
- extern int line_number, current_command_line_count, parser_state;
- extern int last_command_exit_value;
- extern int shell_initialized;
-+extern int rpm_requires;
-+
-+static char *alphabet_set = "abcdefghijklmnopqrstuvwxyz"
-+                     "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
- /* Object caching */
- sh_obj_cache_t wdcache = {0, 0, 0};
-@@ -820,6 +828,27 @@ make_coproc_command (name, command)
+ #if defined (ARRAY_VARS)
+ struct func_array_state
+diff --git a/make_cmd.c b/make_cmd.c
+index ecbbfd6..3d8bfa4 100644
+--- a/make_cmd.c
++++ b/make_cmd.c
+@@ -828,6 +828,27 @@ make_coproc_command (name, command)
    return (make_command (cm_coproc, (SIMPLE_COM *)temp));
  }
  
@@ -233,9 +206,9 @@ diff -up bash-4.1/make_cmd.c.requires bash-4.1/make_cmd.c
 +  if (strchr(filename, '$') || (filename[0] != '/' && strchr(filename, '/')))
 +    return;
 +
-+  /* 
++  /*
 +      if the executable is called via variable substitution we can
-+      not dermine what it is at compile time.  
++      not dermine what it is at compile time.
 +
 +      if the executable consists only of characters not in the
 +      alphabet we do not consider it a dependency just an artifact
@@ -249,7 +222,7 @@ diff -up bash-4.1/make_cmd.c.requires bash-4.1/make_cmd.c
  /* Reverse the word list and redirection list in the simple command
     has just been parsed.  It seems simpler to do this here the one
     time then by any other method that I can think of. */
-@@ -837,6 +866,27 @@ clean_simple_command (command)
+@@ -845,6 +866,28 @@ clean_simple_command (command)
        REVERSE_LIST (command->value.Simple->redirects, REDIRECT *);
      }
  
@@ -273,16 +246,18 @@ diff -up bash-4.1/make_cmd.c.requires bash-4.1/make_cmd.c
 +          output_requirement (find_function(cmd0) ? "function" : "executable", cmd0);
 +      }
 +    } /*rpm_requires*/
++
 +
    parser_state &= ~PST_REDIRLIST;
    return (command);
  }
-diff -up bash-4.1/shell.c.requires bash-4.1/shell.c
---- bash-4.1/shell.c.requires  2010-08-02 17:42:41.000000000 +0200
-+++ bash-4.1/shell.c   2010-08-02 17:42:41.000000000 +0200
+diff --git a/shell.c b/shell.c
+index a2b2a55..c5d99b3 100644
+--- a/shell.c
++++ b/shell.c
 @@ -193,6 +193,9 @@ int have_devfd = 0;
  /* The name of the .(shell)rc file. */
- static char *bashrc_file = "~/.bashrc";
+ static char *bashrc_file = DEFAULT_BASHRC;
  
 +/* Non-zero if we are finding the scripts requirements. */
 +int rpm_requires;
@@ -290,7 +265,7 @@ diff -up bash-4.1/shell.c.requires bash-4.1/shell.c
  /* Non-zero means to act more like the Bourne shell on startup. */
  static int act_like_sh;
  
-@@ -251,6 +254,7 @@ static const struct {
+@@ -259,6 +262,7 @@ static const struct {
    { "protected", Int, &protected_mode, (char **)0x0 },
  #endif
    { "rcfile", Charp, (int *)0x0, &bashrc_file },
@@ -298,7 +273,7 @@ diff -up bash-4.1/shell.c.requires bash-4.1/shell.c
  #if defined (RESTRICTED_SHELL)
    { "restricted", Int, &restricted, (char **)0x0 },
  #endif
-@@ -485,6 +489,12 @@ main (argc, argv, env)
+@@ -496,6 +500,12 @@ main (argc, argv, env)
    if (dump_translatable_strings)
      read_but_dont_execute = 1;
  
@@ -311,3 +286,36 @@ diff -up bash-4.1/shell.c.requires bash-4.1/shell.c
    if (running_setuid && privileged_mode == 0)
      disable_priv_mode ();
  
+diff --git a/shell.h b/shell.h
+index 8072605..6c4149d 100644
+--- a/shell.h
++++ b/shell.h
+@@ -34,12 +34,15 @@
+ #include "maxpath.h"
+ #include "unwind_prot.h"
+ #include "dispose_cmd.h"
++#include "execute_cmd.h"
+ #include "make_cmd.h"
+ #include "ocache.h"
+ #include "subst.h"
+ #include "sig.h"
+ #include "pathnames.h"
+ #include "externs.h"
++#include "builtins.h"
++#include "builtins/common.h"
+ extern int EOF_Reached;
+@@ -99,6 +102,9 @@ extern int interactive, interactive_shell;
+ extern int startup_state;
+ extern int reading_shell_script;
+ extern int shell_initialized;
++extern int rpm_requires;
++static char *alphabet_set = "abcdefghijklmnopqrstuvwxyz"
++                     "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
+ extern int bash_argv_initialized;
+ extern int subshell_environment;
+ extern int current_command_number;
+-- 
+2.17.2
+
index 4dbf119a8d1f27bf61248f049e18c7aa787f98c0..0aff53f10a513630b898573b258bca16ea4b03ef 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -6,9 +6,10 @@
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
 
-%define                ver             4.4
-%define                patchlevel      23
+%define                ver             5.0
+%define                patchlevel      3
 %define                rel             1
+%define                min_readline    8.0
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
@@ -18,7 +19,7 @@ Release:      %{rel}%{?with_bash_history:inv}
 License:       GPL v3+
 Group:         Applications/Shells
 Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
-# Source0-md5: 148888a7c95ac23705559b6f477dfe25
+# Source0-md5: 2b44b47b905be16f45709648f671820b
 Source1:       %{name}rc
 Source2:       %{name}-skel-.bash_logout
 Source3:       %{name}-skel-.bash_profile
@@ -32,17 +33,18 @@ Patch3:             %{name}-info.patch
 Patch4:                %{name}-profile.patch
 Patch5:                %{name}-requires.patch
 Patch6:                %{name}-compat.patch
+Patch7:                %{name}-loadables.patch
 Patch8:                %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
-%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.4-patches/bash44-%03g 1 %{patchlevel}
+%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 7.0
+BuildRequires: readline-devel >= %{min_readline}
 BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
@@ -50,9 +52,9 @@ BuildRequires:        texinfo
 # Require static library only for static build
 BuildRequires: glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
-BuildRequires: readline-static >= 7.0
+BuildRequires: readline-static >= %{min_readline}
 %endif
-Requires:      readline >= 7.0
+Requires:      readline >= %{min_readline}
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
 Obsoletes:     bash2
@@ -201,6 +203,7 @@ Pliki nagłówkowe do tworzenia wtyczek basha.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 %patch8 -p1
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
@@ -325,6 +328,7 @@ end
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/basename
 %attr(755,root,root) %{_libdir}/%{name}/dirname
+%attr(755,root,root) %{_libdir}/%{name}/fdflags
 %attr(755,root,root) %{_libdir}/%{name}/finfo
 %attr(755,root,root) %{_libdir}/%{name}/head
 %attr(755,root,root) %{_libdir}/%{name}/id
@@ -338,6 +342,7 @@ end
 %attr(755,root,root) %{_libdir}/%{name}/push
 %attr(755,root,root) %{_libdir}/%{name}/realpath
 %attr(755,root,root) %{_libdir}/%{name}/rmdir
+%attr(755,root,root) %{_libdir}/%{name}/seq
 %attr(755,root,root) %{_libdir}/%{name}/setpgid
 %attr(755,root,root) %{_libdir}/%{name}/sleep
 %attr(755,root,root) %{_libdir}/%{name}/strftime
diff --git a/sources b/sources
index b8feeb7019436bb2c19330a2fc8dbeed96e71550..2e9276b5a2b9cb6d511096a77146a30083b0516e 100644 (file)
--- a/sources
+++ b/sources
@@ -1,23 +1,3 @@
-817d01a6c0af6f79308a8b7b649e53d8  bash44-001
-765e14cff12c7284009772e8e24f2fe0  bash44-002
-49e7da93bf07f510a2eb6bb43ac3e5a2  bash44-003
-4557d674ab5831a5fa98052ab19edaf4  bash44-004
-cce96dd77cdd1d293beec10848f6cbb5  bash44-005
-d3379f8d8abce5c6ee338f931ad008d5  bash44-006
-ec38c76ca439ca7f9c178e9baede84fc  bash44-007
-e0ba18c1e3b94f905da9b5bf9d38b58b  bash44-008
-e952d4f44e612048930c559d90eb99bb  bash44-009
-57b5b35955d68f9a09dbef6b86d2c782  bash44-010
-cc896e1fa696b93ded568e557e2392d5  bash44-011
-fa47fbfa56fb7e9e5367f19a9df5fc9e  bash44-012
-5e6a20166efe166267972cc78025417b  bash44-013
-00a8877a8787dbd78d97767db1115b0a  bash44-014
-2409586fd19e3104197ead86ce549eca  bash44-015
-4b31183db086daf8be8943d7f7ea7526  bash44-016
-c15c8844f1eb87bdbcde71417c9bd342  bash44-017
-b25e3373fc8de00523116dfe151ac4e0  bash44-018
-8f43e1d277b02f3319a34c1cd4a4ff3e  bash44-019
-5217ff08c444446ec306dce60437c288  bash44-020
-282c7d9b38da8005d25b4f816328a2f4  bash44-021
-0b709c9d7f8e6cf267a8b863efb899f7  bash44-022
-fe2e0ca4cf9409ff0e9428e1236f983e  bash44-023
+b026862ab596a5883bb4f0d1077a3819  bash50-001
+2f4a7787365790ae57f36b311701ea7e  bash50-002
+af7f2dd93fd5429fb5e9a642ff74f87d  bash50-003
This page took 0.227934 seconds and 4 git commands to generate.