]> git.pld-linux.org Git - packages/bash.git/commitdiff
- loadables patch still needed; files updated auto/th/bash-5.1.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 8 Dec 2020 09:14:15 +0000 (10:14 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 8 Dec 2020 09:14:15 +0000 (10:14 +0100)
bash-loadables.patch [new file with mode: 0644]
bash.spec

diff --git a/bash-loadables.patch b/bash-loadables.patch
new file mode 100644 (file)
index 0000000..c2e32db
--- /dev/null
@@ -0,0 +1,11 @@
+--- bash-5.1/examples/loadables/push.c~        2020-04-20 22:07:01.000000000 +0200
++++ bash-5.1/examples/loadables/push.c 2020-12-08 08:54:19.318948703 +0100
+@@ -36,7 +36,7 @@ extern int errno;
+ #endif
+ extern pid_t dollar_dollar_pid;
+-extern int last_command_exit_value;
++extern volatile int last_command_exit_value;
+ int
+ push_builtin (list)
index d5294f44e475dc51ac9e38b4f04e6d12df921935..7b2c6832fa527d24352f513b11d06cff2f3ce13d 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -33,11 +33,12 @@ Patch3:             %{name}-info.patch
 Patch4:                %{name}-profile.patch
 Patch5:                %{name}-requires.patch
 Patch6:                %{name}-compat.patch
-Patch7:                bash-5.1-parallel_make.patch
+Patch7:                %{name}-loadables.patch
 Patch8:                %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
+Patch12:       bash-5.1-parallel_make.patch
 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf >= 2.61
@@ -208,6 +209,7 @@ Pliki nagłówkowe do tworzenia wtyczek basha.
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
 
@@ -328,7 +330,10 @@ end
 
 # loadables
 %dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/accept
 %attr(755,root,root) %{_libdir}/%{name}/basename
+%attr(755,root,root) %{_libdir}/%{name}/csv
+%attr(755,root,root) %{_libdir}/%{name}/cut
 %attr(755,root,root) %{_libdir}/%{name}/dirname
 %attr(755,root,root) %{_libdir}/%{name}/fdflags
 %attr(755,root,root) %{_libdir}/%{name}/finfo
@@ -337,12 +342,15 @@ end
 %attr(755,root,root) %{_libdir}/%{name}/ln
 %attr(755,root,root) %{_libdir}/%{name}/logname
 %attr(755,root,root) %{_libdir}/%{name}/mkdir
+%attr(755,root,root) %{_libdir}/%{name}/mkfifo
+%attr(755,root,root) %{_libdir}/%{name}/mktemp
 %attr(755,root,root) %{_libdir}/%{name}/mypid
 %attr(755,root,root) %{_libdir}/%{name}/pathchk
 %attr(755,root,root) %{_libdir}/%{name}/print
 %attr(755,root,root) %{_libdir}/%{name}/printenv
 %attr(755,root,root) %{_libdir}/%{name}/push
 %attr(755,root,root) %{_libdir}/%{name}/realpath
+%attr(755,root,root) %{_libdir}/%{name}/rm
 %attr(755,root,root) %{_libdir}/%{name}/rmdir
 %attr(755,root,root) %{_libdir}/%{name}/seq
 %attr(755,root,root) %{_libdir}/%{name}/setpgid
This page took 0.041902 seconds and 4 git commands to generate.