]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
b2bcf7113f48545c73d5cc72af9bcba79de71bb3
[packages/bash.git] / bash.spec
1 # NOTE: when updating patchlevel, do not forget to update 'sources' file:
2 # $ md5sum bash44-??? > sources
3 #
4 # Conditional build:
5 %bcond_without  static          # don't build static version
6 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
7 %bcond_without  tests   # do not perform "make test"
8
9 %define         ver             5.0
10 %define         patchlevel      11
11 %define         rel             1
12 %define         min_readline    8.0
13 Summary:        GNU Bourne Again Shell (bash)
14 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
15 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
16 Name:           bash
17 Version:        %{ver}%{?patchlevel:.%{patchlevel}}
18 Release:        %{rel}%{?with_bash_history:inv}
19 License:        GPL v3+
20 Group:          Applications/Shells
21 Source0:        http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
22 # Source0-md5:  2b44b47b905be16f45709648f671820b
23 Source1:        %{name}rc
24 Source2:        %{name}-skel-.bash_logout
25 Source3:        %{name}-skel-.bash_profile
26 Source4:        %{name}-skel-.bashrc
27 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
28 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
29 Patch0:         %{name}-paths.patch
30 Patch1:         %{name}-security.patch
31 Patch2:         %{name}-autoconf.patch
32 Patch3:         %{name}-info.patch
33 Patch4:         %{name}-profile.patch
34 Patch5:         %{name}-requires.patch
35 Patch6:         %{name}-compat.patch
36 Patch7:         %{name}-loadables.patch
37 Patch8:         %{name}-sighup.patch
38 Patch9:         %{name}-backup_history.patch
39 Patch10:        %{name}-act_like_sh.patch
40 Patch11:        %{name}-elinks_cont.patch
41 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-%03g 1 %{patchlevel}
42 URL:            http://www.gnu.org/software/bash/
43 BuildRequires:  autoconf >= 2.61
44 BuildRequires:  automake
45 BuildRequires:  bison
46 BuildRequires:  ncurses-devel >= 5.2
47 BuildRequires:  readline-devel >= %{min_readline}
48 BuildRequires:  rpmbuild(macros) >= 1.462
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  texinfo
51 %if %{with static}
52 # Require static library only for static build
53 BuildRequires:  glibc-static >= 2.2
54 BuildRequires:  ncurses-static >= 5.2
55 BuildRequires:  readline-static >= %{min_readline}
56 %endif
57 Requires:       readline >= %{min_readline}
58 Requires:       setup >= 2.4.6-2
59 Obsoletes:      bash-doc
60 Obsoletes:      bash2
61 Obsoletes:      bash2-doc
62 Obsoletes:      etcskel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Bash is a GNU project sh-compatible shell or command language
67 interpreter. Bash (Bourne Again shell) incorporates useful features
68 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
69 be run by bash without modification. Bash offers several improvements
70 over sh, including command line editing, unlimited size command
71 history, job control, shell functions and aliases, indexed arrays of
72 unlimited size and integer arithmetic in any base from two to 64. Bash
73 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
74 Shell and Tools standard. Bash is the default shell for Linux
75 Mandrake. You should install bash because of its popularity and power.
76 You'll probably end up using it.
77
78 %description -l es.UTF-8
79 Bash es un interpretador de comandos compatible con sh, que ejecuta
80 comandos leídos de la entrada padrón o de un archivo. Bash también
81 incorpora características útiles de las shells Korn y C (ksh y csh).
82 Bash ha sido desarrollado para ser una adición compatible con la
83 especificación IEEE Posix para shells y herramientas (IEEE Working
84 Group 1003.2).
85
86 %description -l de.UTF-8
87 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
88 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
89 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
90 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
91 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
92 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
93 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
94 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
95 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
96 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
97 Mandrake.
98
99 %description -l fr.UTF-8
100 Bash est un shell (interpréteur de commande) du projet GNU, compatible
101 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
102 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
103 plupart des scripts sh sont exécutables sans modifications. Bash
104 comprend nombre d'améliorations par rapport à sh : édition de la ligne
105 de commande, historique illimité, contrôle des processus
106 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
107 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
108 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
109 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
110 l'installer du fait de sa puissance et de sa popularité. Vous finirez
111 probablement par l'utiliser.
112
113 %description -l pl.UTF-8
114 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
115 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
116 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
117 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
118 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
119 historii poleceń, funkcje i aliasy, indeksowane tablice
120 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
121 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
122 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
123
124 %description -l pt_BR.UTF-8
125 Bash é um interpretador de comandos compatível com sh, que executa
126 comandos lidos da entrada padrão ou de um arquivo. Bash também
127 incorpora características úteis das shells Korn e C (ksh e csh). Bash
128 tem sido desenvolvido para ser uma implementação compatível com a
129 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
130 1003.2).
131
132 %description -l ru.UTF-8
133 Bash - это sh-совместимый интерпретатор командного языка (shell),
134 исполняющий команды, поступающие со стандартного ввода или из файла.
135 Bash включает полезные расширения из интерпретаторов Korn и C shell
136 (ksh и csh).
137
138 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
139 Tools specification (IEEE Working Group 1003.2).
140
141 %description -l tr.UTF-8
142 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
143 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
144 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
145 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
146 uyumlu bir uygulama olarak tasarlanmıştır.
147
148 %description -l uk.UTF-8
149 Bash - це sh-сумістний інтерпретатор командної мови (shell),
150 виконуючий команди зі стандартного вводу або з файла. Bash містить
151 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
152
153 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
154 Tools specification (IEEE Working Group 1003.2).
155
156 %package static
157 Summary:        Statically linked GNU Bourne Again Shell (bash)
158 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
159 Group:          Applications/Shells
160 Requires:       %{name} = %{version}-%{release}
161
162 %description static
163 Bash is a GNU project sh-compatible shell or command language
164 interpreter. Bash (Bourne Again shell) incorporates useful features
165 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
166 be run by bash without modification. Bash offers several improvements
167 over sh, including command line editing, unlimited size command
168 history, job control, shell functions and aliases, indexed arrays of
169 unlimited size and integer arithmetic in any base from two to 64. Bash
170 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
171 Shell and Tools standard. Bash is the default shell for Linux
172 Mandrake. You should install bash because of its popularity and power.
173 You'll probably end up using it. This package contains statically
174 linked version of bash.
175
176 %description static -l pl.UTF-8
177 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
178 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
179 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
180 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
181 tym pakiecie jest wersja basha skonsolidowana statycznie.
182
183 %package devel
184 Summary:        Header files for bash plugins development
185 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek basha
186 Group:          Development/Libraries
187 # doesn't require base
188
189 %description devel
190 Header files for bash plugins development.
191
192 %description devel -l pl.UTF-8
193 Pliki nagłówkowe do tworzenia wtyczek basha.
194
195 %prep
196 %setup -q -n %{name}-%{ver} -a5
197 # official patches
198 %{?patchlevel:%patchset_patch 1 %{patchlevel}}
199 %patch0 -p1
200 %patch1 -p1
201 %patch2 -p1
202 %patch3 -p1
203 %patch4 -p1
204 %patch5 -p1
205 %patch6 -p1
206 %patch7 -p1
207 %patch8 -p1
208 %{?with_bash_history:%patch9 -p1}
209 %patch10 -p1
210 %patch11 -p1
211
212 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
213
214 %build
215 cp -f /usr/share/automake/config.* support
216 %{__autoconf}
217 for mode in %{?with_static:static} shared; do
218 %configure \
219         --enable-alias \
220         --enable-help-builtin \
221         --enable-history \
222         --enable-job-control \
223         --enable-restricted \
224         --enable-readline \
225         --with-curses \
226         --enable-extended-glob \
227         --enable-dparen-arithmetic \
228         --enable-separate-helpfiles \
229         --without-bash-malloc \
230         $([ "$mode" = "static" ] && echo "--enable-static-link") \
231         --with-installed-readline
232
233 %{__make} \
234         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
235
236 [ "$mode" = "static" ] && mv -f bash bash.static
237 done
238
239 %{?with_tests:%{__make} tests}
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
244 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
245
246 %{__make} install \
247         DESTDIR=$RPM_BUILD_ROOT
248
249 %{__mv} $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
250 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
251
252 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
253 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
254
255 for d in es fr it ja ko nl pl ; do
256         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
257         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
258         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
259 done
260
261 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
262
263 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
264 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
265 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
266
267 # use our bugtracker, upstream will ignore reports from this anyway
268 %{__rm} $RPM_BUILD_ROOT%{_bindir}/bashbug \
269         $RPM_BUILD_ROOT%{_mandir}/man1/bashbug.1 \
270         $RPM_BUILD_ROOT%{_mandir}/*/man1/bashbug.1
271 # packaged as %doc
272 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/bash
273
274 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
275
276 %find_lang %{name}
277
278 %clean
279 rm -rf $RPM_BUILD_ROOT
280
281 %post   -p <lua>
282 %lua_add_etc_shells /bin/bash /bin/rbash
283 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
284
285 %preun  -p <lua>
286 if arg[2] == 0 then
287         %lua_remove_etc_shells /bin/bash /bin/rbash
288 end
289
290 %postun -p /sbin/postshell
291 -/usr/sbin/fix-info-dir -c %{_infodir}
292
293 %post static -p <lua>
294 %lua_add_etc_shells /bin/bash.static
295
296 %preun static -p <lua>
297 if arg[2] == 0 then
298         %lua_remove_etc_shells /bin/bash.static
299 end
300
301 %files -f %{name}.lang
302 %defattr(644,root,root,755)
303 %doc AUTHORS CHANGES COMPAT NEWS POSIX README RBASH doc/{FAQ,INTRO,bash.html,bashref.html} 
304
305 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
306 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
307 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
308 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
309
310 %attr(755,root,root) /bin/bash
311 %attr(755,root,root) /bin/rbash
312
313 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
314 %{_infodir}/bash.info*
315 %{_mandir}/man1/bash.1*
316 %{_mandir}/man1/rbash.1*
317 %lang(es) %{_mandir}/es/man1/*
318 %lang(fr) %{_mandir}/fr/man1/*
319 %lang(it) %{_mandir}/it/man1/*
320 %lang(ja) %{_mandir}/ja/man1/*
321 %lang(ko) %{_mandir}/ko/man1/*
322 %lang(nl) %{_mandir}/nl/man1/*
323 %lang(pl) %{_mandir}/pl/man1/*
324 %dir %{_datadir}/%{name}
325 %doc %{_datadir}/%{name}/*
326
327 # loadables
328 %dir %{_libdir}/%{name}
329 %attr(755,root,root) %{_libdir}/%{name}/basename
330 %attr(755,root,root) %{_libdir}/%{name}/dirname
331 %attr(755,root,root) %{_libdir}/%{name}/fdflags
332 %attr(755,root,root) %{_libdir}/%{name}/finfo
333 %attr(755,root,root) %{_libdir}/%{name}/head
334 %attr(755,root,root) %{_libdir}/%{name}/id
335 %attr(755,root,root) %{_libdir}/%{name}/ln
336 %attr(755,root,root) %{_libdir}/%{name}/logname
337 %attr(755,root,root) %{_libdir}/%{name}/mkdir
338 %attr(755,root,root) %{_libdir}/%{name}/mypid
339 %attr(755,root,root) %{_libdir}/%{name}/pathchk
340 %attr(755,root,root) %{_libdir}/%{name}/print
341 %attr(755,root,root) %{_libdir}/%{name}/printenv
342 %attr(755,root,root) %{_libdir}/%{name}/push
343 %attr(755,root,root) %{_libdir}/%{name}/realpath
344 %attr(755,root,root) %{_libdir}/%{name}/rmdir
345 %attr(755,root,root) %{_libdir}/%{name}/seq
346 %attr(755,root,root) %{_libdir}/%{name}/setpgid
347 %attr(755,root,root) %{_libdir}/%{name}/sleep
348 %attr(755,root,root) %{_libdir}/%{name}/strftime
349 %attr(755,root,root) %{_libdir}/%{name}/sync
350 %attr(755,root,root) %{_libdir}/%{name}/tee
351 %attr(755,root,root) %{_libdir}/%{name}/truefalse
352 %attr(755,root,root) %{_libdir}/%{name}/tty
353 %attr(755,root,root) %{_libdir}/%{name}/uname
354 %attr(755,root,root) %{_libdir}/%{name}/unlink
355 %attr(755,root,root) %{_libdir}/%{name}/whoami
356
357 %if %{with static}
358 %files static
359 %defattr(644,root,root,755)
360 %attr(755,root,root) /bin/bash.static
361 %endif
362
363 %files devel
364 %defattr(644,root,root,755)
365 %{_includedir}/bash
366 %dir %{_libdir}/%{name}
367 %{_libdir}/%{name}/Makefile.inc
368 %{_libdir}/%{name}/loadables.h
369 %{_pkgconfigdir}/bash.pc
This page took 0.064746 seconds and 2 git commands to generate.