]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- up to 3.2.39
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %define         ver             3.2
8 %define         patchlevel      39
9 %define         rel             1
10 Summary:        GNU Bourne Again Shell (bash)
11 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
12 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
13 Name:           bash
14 Version:        %{ver}.%{patchlevel}
15 Release:        %{rel}%{?with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
19 # Source0-md5:  00bfa16d58e034e3c2aa27f390390d30
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
26 # based on GNU TP; omitted: eo (not supported), rw (empty)
27 Source6:        %{name}-translations.tar.bz2
28 # Source6-md5:  99701bc1f919cfc527cb95fadbc66c93
29 Patch0:         %{name}-paths.patch
30 Patch1:         %{name}-security.patch
31 Patch2:         %{name}-autoconf.patch
32 Patch3:         %{name}-info.patch
33 Patch4:         %{name}-profile.patch
34 Patch5:         %{name}-requires.patch
35 Patch6:         %{name}-compat.patch
36 Patch8:         %{name}-sighup.patch
37 Patch9:         %{name}-backup_history.patch
38 Patch10:        %{name}-act_like_sh.patch
39 Patch11:        %{name}-elinks_cont.patch
40 %patchset_source -f http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{patchlevel}
41 URL:            http://www.gnu.org/software/bash/
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  bison
45 BuildRequires:  ncurses-devel >= 5.2
46 BuildRequires:  readline-devel >= 5.2
47 BuildRequires:  rpmbuild(macros) >= 1.353
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  texinfo
50 %if %{with static}
51 # Require static library only for static build
52 BuildRequires:  glibc-static >= 2.2
53 BuildRequires:  ncurses-static >= 5.2
54 BuildRequires:  readline-static >= 5.2
55 %endif
56 Requires(post,preun):   grep
57 Requires(preun):        fileutils
58 Requires:       grep
59 Requires:       readline >= 5.2
60 Requires:       setup >= 2.4.6-2
61 Obsoletes:      bash-doc
62 Obsoletes:      bash2
63 Obsoletes:      bash2-doc
64 Obsoletes:      etcskel
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 Bash is a GNU project sh-compatible shell or command language
69 interpreter. Bash (Bourne Again shell) incorporates useful features
70 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
71 be run by bash without modification. Bash offers several improvements
72 over sh, including command line editing, unlimited size command
73 history, job control, shell functions and aliases, indexed arrays of
74 unlimited size and integer arithmetic in any base from two to 64. Bash
75 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
76 Shell and Tools standard. Bash is the default shell for Linux
77 Mandrake. You should install bash because of its popularity and power.
78 You'll probably end up using it.
79
80 %description -l es.UTF-8
81 Bash es un interpretador de comandos compatible con sh, que ejecuta
82 comandos leídos de la entrada padrón o de un archivo. Bash también
83 incorpora características útiles de las shells Korn y C (ksh y csh).
84 Bash ha sido desarrollado para ser una adición compatible con la
85 especificación IEEE Posix para shells y herramientas (IEEE Working
86 Group 1003.2).
87
88 %description -l de.UTF-8
89 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
90 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
91 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
92 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
93 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
94 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
95 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
96 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
97 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
98 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
99 Mandrake.
100
101 %description -l fr.UTF-8
102 Bash est un shell (interpréteur de commande) du projet GNU, compatible
103 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
104 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
105 plupart des scripts sh sont exécutables sans modifications. Bash
106 comprend nombre d'améliorations par rapport à sh : édition de la ligne
107 de commande, historique illimité, contrôle des processus
108 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
109 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
110 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
111 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
112 l'installer du fait de sa puissance et de sa popularité. Vous finirez
113 probablement par l'utiliser.
114
115 %description -l pl.UTF-8
116 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
117 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
118 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
119 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
120 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
121 historii poleceń, funkcje i aliasy, indeksowane tablice
122 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
123 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
124 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
125
126 %description -l pt_BR.UTF-8
127 Bash é um interpretador de comandos compatível com sh, que executa
128 comandos lidos da entrada padrão ou de um arquivo. Bash também
129 incorpora características úteis das shells Korn e C (ksh e csh). Bash
130 tem sido desenvolvido para ser uma implementação compatível com a
131 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
132 1003.2).
133
134 %description -l ru.UTF-8
135 Bash - это sh-совместимый интерпретатор командного языка (shell),
136 исполняющий команды, поступающие со стандартного ввода или из файла.
137 Bash включает полезные расширения из интерпретаторов Korn и C shell
138 (ksh и csh).
139
140 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
141 Tools specification (IEEE Working Group 1003.2).
142
143 %description -l tr.UTF-8
144 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
145 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
146 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
147 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
148 uyumlu bir uygulama olarak tasarlanmıştır.
149
150 %description -l uk.UTF-8
151 Bash - це sh-сумістний інтерпретатор командної мови (shell),
152 виконуючий команди зі стандартного вводу або з файла. Bash містить
153 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
154
155 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
156 Tools specification (IEEE Working Group 1003.2).
157
158 %package static
159 Summary:        Statically linked GNU Bourne Again Shell (bash)
160 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
161 Group:          Applications/Shells
162 Requires(post,preun):   grep
163 Requires(preun):        fileutils
164 Requires:       %{name} = %{version}-%{release}
165
166 %description static
167 Bash is a GNU project sh-compatible shell or command language
168 interpreter. Bash (Bourne Again shell) incorporates useful features
169 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
170 be run by bash without modification. Bash offers several improvements
171 over sh, including command line editing, unlimited size command
172 history, job control, shell functions and aliases, indexed arrays of
173 unlimited size and integer arithmetic in any base from two to 64. Bash
174 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
175 Shell and Tools standard. Bash is the default shell for Linux
176 Mandrake. You should install bash because of its popularity and power.
177 You'll probably end up using it. This package contains statically
178 linked version of bash.
179
180 %description static -l pl.UTF-8
181 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
182 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
183 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
184 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
185 tym pakiecie jest wersja basha skonsolidowana statycznie.
186
187 %prep
188 %setup -q -n %{name}-%{ver} -a5
189 # official patches
190 %patchset_patch 1 %{patchlevel}
191 %patch0 -p1
192 %patch1 -p1
193 %patch2 -p1
194 %patch3 -p1
195 %patch4 -p1
196 %patch5 -p1
197 %patch6 -p1
198 %patch8 -p1
199 %{?with_bash_history:%patch9 -p1}
200 %patch10 -p1
201 %patch11 -p1
202 tar xjf %SOURCE6 -C po
203 sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
204
205 %build
206 cp -f /usr/share/automake/config.* support
207 %{__autoconf}
208 for mode in %{?with_static:static} shared; do
209 %configure \
210         --enable-alias \
211         --enable-help-builtin \
212         --enable-history \
213         --enable-job-control \
214         --enable-restricted \
215         --enable-readline \
216         --with-curses \
217         --enable-extended-glob \
218         --enable-dparen-arithmetic \
219         --enable-separate-helpfiles \
220         --without-bash-malloc \
221         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
222         --with-installed-readline
223
224 %{__make} \
225         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
226
227 [ "$mode" = "static" ] && mv -f bash bash.static || :
228 done
229
230 %{?with_tests:%{__make} tests}
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
235 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
236
237 %{__make} install \
238         DESTDIR=$RPM_BUILD_ROOT
239
240 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
241 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
242
243 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
244 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
245
246 for d in es fr it ja ko nl pl ; do
247         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
248         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
249         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
250 done
251
252 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
253
254 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
255 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
256 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
257 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
258
259 %find_lang %{name}
260
261 %clean
262 rm -rf $RPM_BUILD_ROOT
263
264 %post
265 umask 022
266 if [ ! -f /etc/shells ]; then
267         echo "/bin/bash" > /etc/shells
268         echo "/bin/rbash" >> /etc/shells
269 else
270         if ! grep -q '^/bin/bash$' /etc/shells; then
271                 echo "/bin/bash" >> /etc/shells
272         fi
273         if ! grep -q '^/bin/rbash$' /etc/shells; then
274                 echo "/bin/rbash" >> /etc/shells
275         fi
276 fi
277
278 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
279
280 %preun
281 if [ "$1" = "0" ]; then
282         umask 022
283         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
284         mv -f /etc/shells.new /etc/shells
285 fi
286
287 %post static
288 umask 022
289 if [ ! -f /etc/shells ]; then
290         echo "/bin/bash.static" > /etc/shells
291 else
292         if ! grep -q '^/bin/bash.static$' /etc/shells; then
293                 echo "/bin/bash.static" >> /etc/shells
294         fi
295 fi
296
297 %preun static
298 if [ "$1" = "0" ]; then
299         umask 022
300         grep -v /bin/bash.static /etc/shells > /etc/shells.new
301         mv -f /etc/shells.new /etc/shells
302 fi
303
304 %postun -p      /sbin/postshell
305 -/usr/sbin/fix-info-dir -c %{_infodir}
306
307 %files -f %{name}.lang
308 %defattr(644,root,root,755)
309 %doc CHANGES NEWS README doc/{FAQ,INTRO}
310
311 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
312 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
313 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
314 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
315
316 %attr(755,root,root) /bin/bash
317 %attr(755,root,root) /bin/rbash
318 %attr(755,root,root) %{_bindir}/bashbug
319
320 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
321 %{_infodir}/bash.info*
322 %{_mandir}/man1/*
323 %lang(es) %{_mandir}/es/man1/*
324 %lang(fr) %{_mandir}/fr/man1/*
325 %lang(it) %{_mandir}/it/man1/*
326 %lang(ja) %{_mandir}/ja/man1/*
327 %lang(ko) %{_mandir}/ko/man1/*
328 %lang(nl) %{_mandir}/nl/man1/*
329 %lang(pl) %{_mandir}/pl/man1/*
330 %{_datadir}/%{name}
331
332 %if %{with static}
333 %files static
334 %defattr(644,root,root,755)
335 %attr(755,root,root) /bin/bash.static
336 %endif
This page took 0.061774 seconds and 3 git commands to generate.