]> git.pld-linux.org Git - packages/bash-completion.git/blob - bash-completion.spec
- updated to 20030821
[packages/bash-completion.git] / bash-completion.spec
1 Summary:        bash-completion offers programmable completion for bash
2 Summary(pl):    Programowalne uzupe³nianie nazw dla basha
3 Name:           bash-completion
4 Version:        20030821
5 Release:        1
6 License:        GPL
7 Group:          Applications/Shells
8 Source0:        http://www.caliban.org/files/bash/%{name}-%{version}.tar.bz2
9 # Source0-md5:  62208abed378d4441d9cf5907dbe5129
10 URL:            http://www.caliban.org/bash/
11 Requires(post,preun):   bash
12 Requires(post): grep
13 Requires(post): textutils
14 Requires(postun):       fileutils
15 Requires(postun):       sed
16 BuildArch:      noarch
17 Requires:       bash >= 2.05a-3
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 bash-completion is a collection of shell functions that take advantage
22 of the programmable completion feature of bash 2.04 and later.
23
24 %description -l pl
25 bash-completion jest kolekcj± funkcji shella, które opieraj± siê na
26 wbudowanych rozszerzeniach basha 2.04 lub pó¼niejszego umo¿liwiaj±cego
27 kompletowanie parametrów linii poleceñ.
28
29 %prep
30 %setup -q -n bash_completion
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
35
36 install bash_completion $RPM_BUILD_ROOT%{_sysconfdir}
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %post
42 if ! grep -q '\[ -f '%{_sysconfdir}'/bash_completion \]' \
43         %{_sysconfdir}/bashrc 2>/dev/null; then
44                 umask 022
45                 cat <<'EOF' >> %{_sysconfdir}/bashrc
46 # START bash completion -- do not remove this line
47 bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
48 if [ "$PS1" ] && [ "$bmajor" -eq 2 ] && [ "$bminor" '>' 04 ] \
49         && [ -f %{_sysconfdir}/bash_completion ]; then  # interactive shell
50         # Source completion code
51         . %{_sysconfdir}/bash_completion
52 fi
53 unset bash bmajor bminor
54 # END bash completion -- do not remove this line
55 EOF
56 fi
57
58 %postun
59 if [ "$1" -eq 0 ]; then
60         umask 022
61         sed -e '/^# START bash completion/,/^# END bash completion/d' /etc/bashrc \
62                 > /etc/bashrc.tmp
63         mv -f /etc/bashrc.tmp /etc/bashrc
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README Changelog contrib BUGS
69 %{_sysconfdir}/bash_completion
70 %dir %{_sysconfdir}/bash_completion.d
This page took 0.073566 seconds and 3 git commands to generate.