]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
- sorted BR
[packages/balsa.git] / balsa.spec
1 # TODO:
2 #       - not packaged /usr/share/locale/ar/LC_MESSAGES/balsa.mo
3 #       - problems with id locale
4 #
5 # Conditional build:
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_with     gpgme           # build with GPG support (experimental)
8 %bcond_without  esmtp           # build without ESMTP support
9 %bcond_without  gtkhtml         # build without HTML support
10 %bcond_with     gtkhtml2        # build with libgtkhtml-2 (default gtkhtml-3)
11 %bcond_with     compface        # build with Compface
12 %bcond_with     gtksourceview   # build with GtkSourceView
13 %bcond_without  gtkspell        # build without GtkSpell
14 %bcond_with     sqlite          # build with SQLite for GPE address books
15 #
16 Summary:        Balsa Mail Client
17 Summary(es.UTF-8):      Balsa es un lector de e-mail
18 Summary(pl.UTF-8):      Balsa - klient poczty
19 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
20 Name:           balsa
21 Version:        2.3.14
22 Release:        2
23 License:        GPL
24 Group:          X11/Applications
25 Source0:        http://balsa.gnome.org/%{name}-%{version}.tar.bz2
26 # Source0-md5:  6a86f8bebc21bd279b9fd4d2a21a36c0
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-includes.patch
29 Patch2:         %{name}-without_id_lang.patch
30 URL:            http://balsa.gnome.org/
31 BuildRequires:  ORBit2-devel >= 1:2.12.4
32 BuildRequires:  aspell-devel >= 2:0.50
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 %{?with_compface:BuildRequires: compface-devel}
36 BuildRequires:  glib2-devel >= 2.6.4-1
37 BuildRequires:  gmime-devel >= 2.1.9
38 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
39 BuildRequires:  gtk+2-devel >= 2:2.2.0
40 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
41 %{?with_gtkspell:BuildRequires: gtkspell-devel}
42 BuildRequires:  intltool
43 BuildRequires:  krb5-devel
44 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
45 %if %{with gtkhtml}
46 %{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
47 %{!?with_gtkhtml2:BuildRequires:        gtkhtml-devel >= 3.0}
48 %endif
49 BuildRequires:  libgnomeprintui-devel >= 2.1.4
50 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
51 BuildRequires:  libltdl-devel
52 BuildRequires:  libtool
53 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
54 BuildRequires:  openssl-devel >= 0.9.7d
55 BuildRequires:  pcre-devel >= 3.0
56 BuildRequires:  rpmbuild(macros) >= 1.197
57 BuildRequires:  scrollkeeper >= 0.1.4
58 # actually, it requires sqlite >= 2.8
59 %{?with_sqlite:BuildRequires:   sqlite3-devel}
60 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
61 Requires(post,postun):  scrollkeeper
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 Balsa is an e-mail reader.  This client is part of the GNOME
66 desktop environment.  It supports local mailboxes, POP3 and
67 IMAP.
68
69 %description -l es.UTF-8
70 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
71 cajas de correo electrónico locales, POP3 y IMAP.
72
73 %description -l pl.UTF-8
74 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
75 IMAP oraz lokalne skrzynki pocztowe. 
76
77 %description -l pt_BR.UTF-8
78 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
79 Suporta caixas de correio locais, POP3 a IMAP.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86
87 %build
88 %{__intltoolize}
89 %{__glib_gettextize}
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__autoconf}
95 %configure \
96         --with-gss \
97         --with-ssl \
98         %{!?with_esmtp:--without-esmtp} \
99         %{!?with_gtkhtml:--disable-gtkhtml}\
100         %{?with_gtkhtml2:--with-gtkhtml=2}\
101         %{?with_gpgme:--with-gpgme} \
102         %{?with_compface:--with-compface} \
103         %{?with_gtksourceview:--with-gtksourceview} \
104         %{?with_gtkspell:--with-gtkspell} \
105         %{?with_sqlite:--with-sqlite} \
106         %{?with_ldap:--with-ldap}
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %find_lang %{name} --with-gnome --all-name
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %scrollkeeper_update_post
122
123 %postun
124 %scrollkeeper_update_postun
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README TODO
129 %attr(755,root,root) %{_bindir}/*
130 %{_sysconfdir}/sound/events/*
131 %{_datadir}/%{name}
132 %{_datadir}/sounds/%{name}
133 %{_libdir}/bonobo/servers/*.server
134 %{_datadir}/idl/*.idl
135 %{_mandir}/man1/*
136 %{_omf_dest_dir}/%{name}
137 %{_desktopdir}/*.desktop
138 %{_pixmapsdir}/*
139 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.053253 seconds and 3 git commands to generate.