]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
- updated to 2.4.10
[packages/balsa.git] / balsa.spec
1 # TODO:
2 # - use webkit as html widget?
3 # - gtkhtml4 causes gtk2/gtk3 conflict:
4 #       Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
5 #
6 # Conditional build:
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_with     gpgme           # build with GPG support (experimental)
9 %bcond_without  esmtp           # build without ESMTP support
10 %bcond_without  gtkhtml         # build without HTML support
11 %bcond_without  gtkhtml2        # build with libgtkhtml-2 (default gtkhtml-4)
12 %bcond_with     compface        # build with Compface
13 %bcond_with     gtksourceview   # build with GtkSourceView
14 %bcond_without  gtkspell        # build without GtkSpell
15 %bcond_with     sqlite          # build with SQLite for GPE address books
16
17 Summary:        Balsa Mail Client
18 Summary(es.UTF-8):      Balsa es un lector de e-mail
19 Summary(pl.UTF-8):      Balsa - klient poczty
20 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
21 Name:           balsa
22 Version:        2.4.10
23 Release:        0.1
24 License:        GPL v3+
25 Group:          X11/Applications
26 Source0:        http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
27 # Source0-md5:  fa2b7cb9d248912ac2e3dcc08cd6aa5b
28 Patch0:         %{name}-desktop.patch
29 Patch1:         %{name}-gtkhtml4.patch
30 URL:            http://balsa.gnome.org/
31 BuildRequires:  ORBit2-devel >= 1:2.12.4
32 BuildRequires:  aspell-devel >= 2:0.50
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 %{?with_compface:BuildRequires: compface-devel}
36 BuildRequires:  docbook-dtd412-xml
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 2.6.4-1
39 BuildRequires:  gmime-devel >= 2.4.0
40 BuildRequires:  gnome-doc-utils
41 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
42 BuildRequires:  gtk+2-devel >= 2:2.10.0
43 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
44 %{?with_gtkspell:BuildRequires: gtkspell-devel}
45 BuildRequires:  heimdal-devel
46 BuildRequires:  intltool
47 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
48 %if %{with gtkhtml}
49 %{!?with_gtkhtml2:BuildRequires:        gtkhtml-devel >= 4.0}
50 %{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
51 %endif
52 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
53 BuildRequires:  libltdl-devel
54 BuildRequires:  libnotify-devel
55 BuildRequires:  libtool
56 BuildRequires:  libunique-devel
57 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel >= 3.0
60 BuildRequires:  pkgconfig
61 BuildRequires:  rpmbuild(macros) >= 1.197
62 BuildRequires:  scrollkeeper >= 0.1.4
63 # actually, it requires sqlite >= 2.8
64 %{?with_sqlite:BuildRequires:   sqlite3-devel}
65 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
66 Requires(post,postun):  scrollkeeper
67 # sr@Latn vs. sr@latin
68 Conflicts:      glibc-misc < 6:2.7
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Balsa is an e-mail reader. This client is part of the GNOME desktop
73 environment. It supports local mailboxes, POP3 and IMAP.
74
75 %description -l es.UTF-8
76 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
77 cajas de correo electrónico locales, POP3 y IMAP.
78
79 %description -l pl.UTF-8
80 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
81 IMAP oraz lokalne skrzynki pocztowe.
82
83 %description -l pt_BR.UTF-8
84 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
85 Suporta caixas de correio locais, POP3 a IMAP.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %{!?with_gtkhtml2:%patch1 -p1}
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__autoheader}
97 %{__autoconf}
98 %configure \
99         --with-gss \
100         --with-ssl \
101         --with-unique \
102         --disable-silent-rules \
103         %{!?with_esmtp:--without-esmtp} \
104 %if %{with gtkhtml}
105         --with-html-widget=%{?with_gtkhtml2:gtkhtml2}%{!?with_gtkhtml2:gtkhtml4} \
106 %else
107         --disable-gtkhtml \
108 %endif
109         %{?with_gpgme:--with-gpgme} \
110         %{?with_compface:--with-compface} \
111         %{?with_gtksourceview:--with-gtksourceview} \
112         %{?with_gtkspell:--with-gtkspell} \
113         %{?with_sqlite:--with-sqlite} \
114         %{?with_ldap:--with-ldap}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
124         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
125 %find_lang %{name} --with-gnome --all-name
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 %scrollkeeper_update_post
132
133 %postun
134 %scrollkeeper_update_postun
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog NEWS README TODO
139 %attr(755,root,root) %{_bindir}/balsa
140 %attr(755,root,root) %{_bindir}/balsa-ab
141 %dir %{_sysconfdir}/sound/events
142 %{_sysconfdir}/sound/events/balsa.soundlist
143 %{_datadir}/%{name}
144 %{_datadir}/sounds/%{name}
145 %{_mandir}/man1/balsa.1*
146 %{_omf_dest_dir}/%{name}
147 %{_desktopdir}/balsa.desktop
148 %{_pixmapsdir}/gnome-balsa2.png
149 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.07089 seconds and 3 git commands to generate.