]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
5d2cf076389639fbb446b6538f0d85f105d7be93
[packages/balsa.git] / balsa.spec
1 # TODO:
2 #       - not packaged /usr/share/locale/ar/LC_MESSAGES/balsa.mo
3 #       - problems with id locale
4 #
5 # Conditional build:
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_with     gpgme           # build with GPG support (experimental)
8 %bcond_without  esmtp           # build without ESMTP support
9 %bcond_without  gtkhtml         # build without HTML support
10 %bcond_with     gtkhtml2        # build with libgtkhtml-2 (default gtkhtml-3)
11 %bcond_with     compface        # build with Compface
12 %bcond_with     gtksourceview   # build with GtkSourceView
13 %bcond_without  gtkspell        # build without GtkSpell
14 %bcond_with     sqlite          # build with SQLite for GPE address books
15 #
16 Summary:        Balsa Mail Client
17 Summary(es.UTF-8):      Balsa es un lector de e-mail
18 Summary(pl.UTF-8):      Balsa - klient poczty
19 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
20 Name:           balsa
21 Version:        2.4.0
22 Release:        2
23 License:        GPL
24 Group:          X11/Applications
25 Source0:        http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
26 # Source0-md5:  47d68219a5ee768f1ebd2502a9c3c6f2
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-without_id_lang.patch
29 URL:            http://balsa.gnome.org/
30 BuildRequires:  ORBit2-devel >= 1:2.12.4
31 BuildRequires:  aspell-devel >= 2:0.50
32 BuildRequires:  autoconf >= 2.52
33 BuildRequires:  automake
34 %{?with_compface:BuildRequires: compface-devel}
35 BuildRequires:  glib2-devel >= 2.6.4-1
36 BuildRequires:  gmime-devel >= 2.4.0
37 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
38 BuildRequires:  gtk+2-devel >= 2:2.10.0
39 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
40 %{?with_gtkspell:BuildRequires: gtkspell-devel}
41 BuildRequires:  intltool
42 BuildRequires:  heimdal-devel
43 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
44 %if %{with gtkhtml}
45 %{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
46 %{!?with_gtkhtml2:BuildRequires:        gtkhtml-devel >= 3.0}
47 %endif
48 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
49 BuildRequires:  libltdl-devel
50 BuildRequires:  libnotify-devel
51 BuildRequires:  libtool
52 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
53 BuildRequires:  openssl-devel >= 0.9.7d
54 BuildRequires:  pcre-devel >= 3.0
55 BuildRequires:  rpmbuild(macros) >= 1.197
56 BuildRequires:  scrollkeeper >= 0.1.4
57 # actually, it requires sqlite >= 2.8
58 %{?with_sqlite:BuildRequires:   sqlite3-devel}
59 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
60 Requires(post,postun):  scrollkeeper
61 # sr@Latn vs. sr@latin
62 Conflicts:      glibc-misc < 6:2.7
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Balsa is an e-mail reader.  This client is part of the GNOME
67 desktop environment.  It supports local mailboxes, POP3 and
68 IMAP.
69
70 %description -l es.UTF-8
71 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
72 cajas de correo electrónico locales, POP3 y IMAP.
73
74 %description -l pl.UTF-8
75 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
76 IMAP oraz lokalne skrzynki pocztowe. 
77
78 %description -l pt_BR.UTF-8
79 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
80 Suporta caixas de correio locais, POP3 a IMAP.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__autoconf}
93 %configure \
94         --with-gss \
95         --with-ssl \
96         %{!?with_esmtp:--without-esmtp} \
97         %{!?with_gtkhtml:--disable-gtkhtml}\
98         %{?with_gtkhtml2:--with-gtkhtml=2}\
99         %{?with_gpgme:--with-gpgme} \
100         %{?with_compface:--with-compface} \
101         %{?with_gtksourceview:--with-gtksourceview} \
102         %{?with_gtkspell:--with-gtkspell} \
103         %{?with_sqlite:--with-sqlite} \
104         %{?with_ldap:--with-ldap}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
114         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
115 %find_lang %{name} --with-gnome --all-name
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %scrollkeeper_update_post
122
123 %postun
124 %scrollkeeper_update_postun
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README TODO
129 %attr(755,root,root) %{_bindir}/*
130 %{_sysconfdir}/sound/events/*
131 %{_datadir}/%{name}
132 %{_datadir}/sounds/%{name}
133 %{_libdir}/bonobo/servers/*.server
134 %{_datadir}/idl/*.idl
135 %{_mandir}/man1/*
136 %{_omf_dest_dir}/%{name}
137 %{_desktopdir}/*.desktop
138 %{_pixmapsdir}/*
139 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.049215 seconds and 2 git commands to generate.